Jump to content
Sign in to follow this  
Followers 0
sirlong

Realtek RTL8139 Family PCI Fast Ethernet (Driver From Mavericks to High Sierra)

2 posts in this topic

Recommended Posts

First of all, the attached driver works with the hardware with the following ID (Windows):


PCI \ VEN_10EC & DEV_8139 & SUBSYS_813910EC & REV_10

 

Tested on Mavericks, and the same kext works on High Sierra perfectly. Therefore, by simple logic, it must work in any of the intermediate versions.

 

I add a working proof in High Sierra.


Install in /S/L/E and in EFI/CLOVER/kexts/Other eventually.

 

Captura de pantalla 2018-12-07 a la(s) 02.29.49.png

PCGenRTL8139Ethernet.kext.zip

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By polyzargone
      Hi !
       
      I've got a strange problem with my PCGenRTL8139Ethernet.kext :
      I have an Asus p5gc-mx/1333 and a PCI Ethernet NIC with RTL8139 chipset running 10.9.3. Everything was fine until yesterday. For some unknown reason, the ethernet connection stoppped working. I tried to boot -f or - x or -x -f -v, UseKernelCache=Yes/No, USBBusFix=Yes/No, PCIRoot=0 etc. but still no connection anymore. I re-installed the kext, rebuild cache & permissions, no way.
      I deleted NetworkInterface.plist then re-installed the kext once again. After severeal attemps, I got my connection back and everything was OK until… next reboot.
      I started over with random success (sometimes it boots fine and the interface is recognized when I use bootflag -v). But everytime I reboot, I m' not sure the connection will be back.
       
      I'm sure the NIC works fine as I have no issue on Windows 8.1.
       
      In verbose mode, I've noticed that message : "ethernet cannot wake assert from d3cold" when things goes wrong. When the connection is OK, I see PCGenRTL8139 disable flow control (something like that, can't remember the exact message ;-(
       
      I made no change in my setup except the change of my Radeon HD 5450 by a Radeon HD 6570 and when I updated tfrom 10.9.2 to 10.9.3, everything was OK so I really don't know why I suddendly have this problem now.
       
      Any help please ? Thanks !
       
      [sOLVED] My Asus P5GC-MX/1333 has a known bug with the bottom PCI Slot where my LAN Adapter was attached. Just moved it to the upper one and my card is now recognized. But a mystery remains : the bottom PCI SLot was previously filled with my Lan Adapter and the upper one was with a Firewire Adapter and this setup was working. When I recently removed the Firewire adapter and left the Lan card on the bottom slot, problems started to occurs.
      Now my Firewire adapter fills the bottom slot and it's not recognized. This is a minor issue for me but that's a strage behavior…
    • By Andy Vandijck
      I rebuilt my PCGenRTL8139 specific for Mountain Lion.
      Sources are included...
      Using it right now... results are very good and ethernet is very fast
      Enjoy...
      PCGenRTL8139Ethernet.kext.zip
      PCGenRTL8139Ethernet-141-AnV-Src.zip
    • By phsilver
      Hello...
       
      I have a RTL8139 network card.
      Lion recognizes it perfectly, but when I try to configure it with an authomatic DCHP, it gives me a wrong IP address and wrong Submask...
       
      If I try to configure it manually, I can't get connection.
      When I run the Diagnosis, I got the first 3 lights on green, but red in the two last...
      I try everything: put DNS and Gateway and so on...
       
      This is what I'm talking about:


      Does anybody got a clue???
      Thanx in advance!!!
    • By DjrikyX
      Hi, i'm running SL 10.6.8 on my desktop..
      Specs:
       
      Mobo: Asus P5L-VM 1394
      CPU: Intel Core Duo E4300 @ 1.8Ghz
      RAM: A-data 1GBx2 667 DDR2
      GPU: Geforce 9500GT 1gb (1680x1050, QE/CI)
      PCI Ethernet: RTL8139/810x
       
      Everything works, except Ethernet..
       
      First of all i can only boot in 32bit mode, if i try to boot with arch=x86_64 just freeze on the grey apple screen.
       
      All kext i found seems to be 64bit only..
      I got them from osx86.net and there are a lot of kext for this card there, from description some are also for 32bit but none is working for me. When installing them, during repairing permission i get a popup that tell me the extension cannot be registered because has failed to load.. and also rebooting they do not load.
       
      So, i tried with another hard disk, where i have 10.6.7 without any kext for my machine, and boot fine in 64bit mode, and my ethernet is working, then just to see, i booted in 32 bit mode, and ethernet was obviously not working.
       
      So, i need a 32bit kext for my card, or fix my 10.6.8 to boot in 64bit..
       
      can you help me? is all day i try to make work this card.....
      Thank you
×