Jump to content
sskgaiqny

[Help!!!] ATI HD7850 Black Screen in High Sierra 13.6

13 posts in this topic

Recommended Posts

Hi guys ,i have a problem with my graphics card ati 7850(1GB/Sapphire).
1. When I start the system in Safe Boot mode(Clover Bootarg=-x), the graphics card (HD7850) is running normally.
2. But when I start the system in normal mode,the system is blank screen.(I confirm that the signal output, see the screen because there is light.)

 

I am already done:
1. I have been  tried Whatevergreen+Lilu,but the problem remains.
2. I also have been tried patch up Framebuffer,bue still black screen

 

Can anyone help me!!!  Many Thinks

 

I use CLOVER version is r4760. Only FakeSMC.kext and RealtekRTL8111.kext in the EFI/CLOVER/kext/Other folder.

 

My computer configuration:

OS: MacOS 10.13.6 /Windows 10
CPU: Intel Q9550 @ 2.83GHz, 
MOBO: Gigabyte  P43-ES3G (Intel ICH10), 
GPU: AMD Radeon HD 7850 (1 GB/Sapphire )
RAM:8GB DDR2
Ethernet: RealtekRTL8111
Sound: ALC888

radeon_bios_decode  give the following result:

ATOM BIOS Rom: 
	SubsystemVendorID: 0x174b SubsystemID: 0xe221
	IOBaseAddress: 0x0000
	Filename: 221P0300.S04
	BIOS Bootup Message: 
C40304 PITCAIRN PRO A1 GDDR5 32MX32 1GB                                     

PCI ID: 1002:6819
Connector at index 0
	Type [@offset 43408]: DisplayPort (10)
	Encoder [@offset 43412]: INTERNAL_UNIPHY2 (0x21)
	i2cid [@offset 43518]: 0x90, OSX senseid: 0x1
Connector at index 1
	Type [@offset 43418]: HDMI-A (11)
	Encoder [@offset 43422]: INTERNAL_UNIPHY2 (0x21)
	i2cid [@offset 43545]: 0x92, OSX senseid: 0x3
Connector at index 2
	Type [@offset 43428]: DVI-D (3)
	Encoder [@offset 43432]: INTERNAL_UNIPHY1 (0x20)
	i2cid [@offset 43572]: 0x94, OSX senseid: 0x5
Connector at index 3
	Type [@offset 43438]: DVI-I (2)
	Encoder [@offset 43442]: INTERNAL_UNIPHY (0x1e)
	i2cid [@offset 43609]: 0x95, OSX senseid: 0x6
Connector at index 4
	Type [@offset 43448]: DVI-I (2)
	Encoder [@offset 43452]: INTERNAL_KLDSCP_DAC1 (0x15)
	i2cid [@offset 43609]: 0x95, OSX senseid: 0x6

redsock_bios_decoder give the following result:

221P0300.S04:

C40304 PITCAIRN PRO A1 GDDR5 32MX32 1GB                                     

Subsystem Vendor ID: 174b
       Subsystem ID: e221
Object Header Structure Size: 355
Connector Object Table Offset: 48
Router Object Table Offset: 0
Encoder Object Table Offset: fd
Display Path Table Offset: 12
Connector Object Id [19] which is [DISPLAY_PORT]
	encoder obj id [0x21] which is [INTERNAL_UNIPHY2 (osx txmit 0x12 [duallink 0x2] enc 0x4)] linkb: false
Connector Object Id [12] which is [HDMI_TYPE_A]
	encoder obj id [0x21] which is [INTERNAL_UNIPHY2 (osx txmit 0x22 [duallink 0x2] enc 0x5)] linkb: true
Connector Object Id [4] which is [DVI_D]
	encoder obj id [0x20] which is [INTERNAL_UNIPHY1 (osx txmit 0x11 [duallink 0x1] enc 0x2)] linkb: false
Connector Object Id [2] which is [DVI_I]
	encoder obj id [0x1e] which is [INTERNAL_UNIPHY (osx txmit 0x10 [duallink 0x0] enc 0x0)] linkb: false
Connector Object Id [2] which is [DVI_I]
	encoder obj id [0x15] which is [INTERNAL_KLDSCP_DAC1 (osx txmit 0x00 enc 0x10?)] linkb: false

 

7850.rom

connector.txt

redsock.txt

config.plist

DSDT(iasl4.0).aml

iMac( export from safe mode).ioreg

Edited by sskgaiqny

Share this post


Link to post
Share on other sites
Advertisement
CPU: Intel Q9550 @ 2.83GHz, 
MOBO: Gigabyte  P43-ES3G 

WEG will not work properly on non UEFI Boards ...see manual... therefore this is no solution. 

 

  • Quote

    What is the state of 10.13 support?
    At the time of the release 10.13 is still being tested, so no support could even be thought about. There exist cases of broken AMD graphics on pre-Nehalem CPU chipsets. If you have older hardware please stay away from using 10.13. For other systems WhateverGreen may work if no drastic changes happen in 10.13.

     

Share this post


Link to post
Share on other sites
Just now, AkimoA said:

CPU: Intel Q9550 @ 2.83GHz, 
MOBO: Gigabyte  P43-ES3G 

WEG will not work properly on non UEFI Boards ...see manual... therefore this is no solution. 

 

  •  

But start the system in Safe Boot mode,it can work. And I didn't use whatevergreen, so I think it can be work. 

I use whatevergreen only to tried,but it didn't work.

Share this post


Link to post
Share on other sites

9 out of 10 cards work in vesa mode ,

 

 

there are known issues on these 7xxx cards on HighSierra and old 775 socket cpus  , go back to Sierra or change card /or mobo & cpu ,

 

sounds harsh but is the truth

Share this post


Link to post
Share on other sites
Just now, AkimoA said:

9 out of 10 cards work in vesa mode ,

 

 

there are known issues on these 7xxx cards on HighSierra and old 775 socket cpus  , go back to Sierra or change card /or mobo & cpu ,

 

sounds harsh but is the truth

But it can work in Safe Boot mode, really no anyway to solve it?

Share this post


Link to post
Share on other sites

In safe mode, you just have basic/default graphics (VESA mode) and no hardware acceleration at all because no drivers load. It does not mean there is support for your graphics card.

Share this post


Link to post
Share on other sites
Hello AkimoA
I have ati 7950 and an ati 7970 .... socket 775 .... 
in both cases I have solved with the kext of sierra ... 
it is clear that I have to redo the procedure with each update

Share this post


Link to post
Share on other sites

hehe nice , well ok i mentioned go back to Sierra as well

 

tbh good catch ;) ,  in didnt expect  Sierra kexts still to respond very well in  Mojave( in terms of dependencies) in this case OP should take it for a spin 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By yehia2amer
      Problem:
      When I Attempt to wake my Machine from sleep, the screen stays black, although the computer is obviously awake !
      This Machine has a 1300W Power Supply So Sleep is Very Useful.
       
      I Tried:
      1) FIX_WAK and FixShutdown as per Clover Wiki.
      2) Although I am using "SAPPHIRE Radeon PULSE RX 580 8GB GDDR5", which Should be completely Supported by Mojave, I Also changed the Part Number to "113-4E353BU-O4E" as per this Guide: http://www.xlr8yourmac.com/archives/feb18/RadeonRX-580_MacPro.html. The GPU is working GREAT without even Clover Inject
      3) Tried to Run this command: disablehibernate.command.zip
      4) Tried darkwake=0 to 10
      5) Disabled wake on USB & Wake on LAN (BIOS)
       
      Logs:
      sudo pmset -g
      System-wide power settings: Currently in use: hibernatemode 0 disksleep 10 womp 0 networkoversleep 0 sleep 0 Sleep On Power Button 1 ttyskeepawake 1 hibernatefile /var/vm/sleepimage autorestart 0 gpuswitch 2 displaysleep 10 pmset -g assertions
      2019-02-19 18:51:04 +0200 Assertion status system-wide: BackgroundTask 1 ApplePushServiceTask 0 UserIsActive 1 PreventUserIdleDisplaySleep 0 PreventSystemSleep 0 ExternalMedia 1 PreventUserIdleSystemSleep 0 NetworkClientActive 0 Listed by owning process: pid 56(powerd): [0x0000001700088000] 00:13:44 ExternalMedia named: "com.apple.powermanagement.externalmediamounted" pid 100(hidd): [0x00000025000980a7] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle.4294968578.17" Timeout will fire in 600 secs Action=TimeoutActionRelease pid 200(mds_stores): [0x0000034e000b8279] 00:00:00 BackgroundTask named: "com.apple.metadata.mds_stores.power" Kernel Assertions: 0x4=USB id=502 level=255 0x4=USB mod=1/1/70, 2:00 AM description=com.apple.usb.externaldevice.1d130000 owner=USB Keyboard id=503 level=255 0x4=USB mod=1/1/70, 2:00 AM description=com.apple.usb.externaldevice.1d120000 owner=Lenovo Optical Mouse Idle sleep preventers: IODisplayWrangler  
      Specs:
      CPU: 2x Xeon E5-2680 v2 2.8GHz Ten Core Processors
      RAM: 128 GB 1333 MHz DDR3 ECC Memory
      GPU: SAPPHIRE Radeon PULSE RX 580 8GB GDDR5
      Chipset: Intel C602
      Audio: Realtek ALC3220 (ALC280) High Definition Audio
      SAS Drive Controllers (RAID): LSI 2308 SATA/SAS 6Gb/s controller with host based RAID 0, 1, 10 (4  
      Network Controller 1: Intel 82579 Gigabit Ethernet controller with Remote Wake UP, PXE and Jumbo frames support
      Network Controller 2: Intel Ethernet Controller I210 
      NEC USB3.0 xHCI Controller: Renesas Electronics uPD720201 & uPD720202
       
      for more info:
       
      Any Help will be appreciated, Thanks !
       
      Send me Yehias-Mac-Pro.zip
    • By FZSX
      Hello, im FZ, been in hackintosh community since mac os X lion years. Please consider me noob. i have helped hackintoshed pc of my friends and family. i ran el capitan, sierra, high sierra on below spec.
      I lost some interest in hackintoshing from past 1 year now im back again cuz of mojave.
      Lets start.
       
      I posted this issue in Nvidia Topic for discussion but decided not to post until i could get some bug log out of it... but. eh.
       
      Well ive Kepler based gt 710 card.
      Issues:
      Black Screen when booting with default drivers or nvda_drv=1 mode
      OR
      White/Grey Screen with 1 sec mouse movement then freezed keyboard and mouse with nv_disable=1.
        
      Tested:
      tried numerous ways to boot Mojave but does not works such as >
      High Sierra/Sierra default Apple geforce nvda kexts, High Sierra Web Drivers, various clover configs, display edids, HDMI dvi port tests... so on.
       
      Specs:
      Tri Boot Setup:
      Windows 10, Sierra(gt 710 works OOB, or with Web Drivers too), Mojave.
      ASUS P5G41TM LX
      Core2Duo E8500
      Gigabyte Nvidia Geforce GT 710 2GB
       
       
      I couldn't managed to get logs as half part of installation is still incomplete i.e Mojave installed from USB to HDD after but cant get into login/setup screen due to above mentioned black screen issue.
       
      I will try to be as detailed as possible.
       
      i had no mac device or any macos dmg/iso to install mojave so performed some steps in windows.
       
      Steps i performed:
      1. I downloaded Mojave 10.14.1 tar file from Olarila.com which is a complete raw image of Mojave USB stick as the post title says **The image is clean, without any mod with Clover bootloader, essentials kexts and patches inside Clover folder**. Which comes with this OLIRALA_MOJAVE_USB_EFI.zip which i backed up(see attachment OLIRALA_MOJAVE_USB_EFI.zip)
      2. made usb in windows with win32diskimager
      3. booted from usb and got kernel panic(i dont know which panic it is, see pic) 
      4. swapped usb EFI folder with Olarila Clover EFI for LGA 775 (see attachment CLOVER.LGA775.OLARILA.zip)
      5. booted from usb susccesfully till install screen but throws macOs Mojave could not be installed on this computer
      6. i was fed up trying workarounds , i knew i need newer mac ids in clover config.plist to make it install 
      7. i downloaded Olarila Sierra from same site flashed in another usb stick and it worked out of box without messing any kext or kind.
      8. added SMBIOS iMac13,1 in config.plist with clover configurator. 
      9. booted from usb and succesfully installed Mojave with HFS+ partition on MBR partitioned HDD(dual booting with windows 10) 
      10. booted from usb to complete partial installation of Mojave but got black screen. 
       
      For getting all kernel, bug, kext logs i tried Problem Reporting script of black-dragon74 https://github.com/black-dragon74/OSX-Debug which requires active internet connection which is not possible, I tried to mod the script to run local but im not good at bash and it went in errors. I will do provide mojave logs manually from single user -x mode if i can. 
      Ok I managed to run the script locally in single go and it went well problem_reporting_mojave10_14_1_debug_27676.zip
      if any wants to have a look at script i modded gen_debug_local.sh
       
      ___
      some other files
      Patched DSDT.aml.zip
      currentCloverEFI.zip
      /CLOVER/misc.zip
      EFI/CLOVER/ACPI/origin.zip
      problem_reporting_mojave10_14_1_debug_27676.zip
       
      ___
      UPDATE: Mojave 10.14.1 running successfully with some graphic glitches.
      Here's what i did in short.
      1. Patched official app store mojave with dosdude1 mojave patcher tool.
      2. Only used its Post Install app with iMac 10,1 config(see pic) to patch already installed Olarila's Mojave(above 1 - 10 steps) with same currentCloverEFI.zip
      3. Restarted and it all went well.
       
      Detailed(it will confuse u, ignore/skim it.):
      1. Downloaded official app store mojave
      2. used crazybirdy's mojave mbr patcher tool (MBR-Manual-Method-20181108.dmg) with manual install.
      3. when installing it went in errors related to "OSInstall.mpkg".
      4. i had few options such as
      use automatic mbr patcher tool(MBR-Auto-Method14-20181108.dmg) upgrade from high sierra try dosdude1 patcher on official app store mojave 5. i did the above short steps(step no2) at first try. enough tats it.
       
       
      (attaching working mojave files...)
      Attached log files
      see post#3 mojave-working.zip
    • By Dmitry R
      Hi guys, stuck on problem of switching on my TV back from off state. I have asus H270f strix mobo with i7-6700K CPU (HD530), Clover 4722 and latest whatevergreen and lilu. I installed 10.14.1 on it and it works fine.  the m/b has dp, hdmi and dvi on board. I'm using dp + dp<->hdmi adapter to connect my mac to 4k tv which I'm using as a primary monitor. This connection supports 4k@60hz and I'm happy with the detailed and sharp picture I see on my tv. The problem is that when I get out for a while then, when I come back, I see my tv turned off by timeout and when I turn it back on, I see only the black screen. The computer works, I prevented it from going to sleep. To see the picture again on my tv I have to go to another computer, then, using screen sharing, I have to connect to my computer and then I have to choose couple of times different refresh rates in System Preferences -> Displays. After that I go back to my tv, see the picture and can continue to work. I made a edid report for my tv. may be somebody knows how to use this data to make my mac to wake up the tv correct way?
      Thank you, Dmitry
      43UHD_LCD_TV.txt.zip
    • By JohnCenaTheMemeMachine
      I'm not expecting too much help, but if anyone has any suggestions, that would be great.

      I recently got my Hackintosh running on macOS 10.14, and went to install the graphics drivers for my Nvidia GeForce GTX 750 Ti. My setup is a little different, so here it is:

      Screen 1 Screen 2 Screen 3

      Screen 1 and 2 are both connected to my 750 Ti, whereas screen 3 is connected to my iGPU, with is an intel HD 4600. The intel GPU works like a charm, just as it did under High Sierra.

      Now, I got the Nvidia Web drivers to "work" by removing any traces via the "Web Driver Toolkit" that others have recommended. I then patched the installer, installed it, rebooted, patched the installed drivers, and rebooted again, where the drivers are at their current state.

      This is where things get interesting though. All 3 monitors are recognized. My GPU is recognized in my system profiler. However, it is NOT able to be used to run a compute in Geekbench, meaning that GPU acceleration is obviously disabled. The other thing that doesn't work, is, well, the 2 monitors connected to the GPU. They are set to the correct resolution and refresh rates, and are recognized in System Preferences, and I can even drag things between the different desktops.

      But I can only see my cursor. The screens are totally black, and I can't see anything on them except my cursor moving across them. Has this happened to anyone else? Thanks in advance!

      Specs:
      Asrock B85M-Pro4 Motherboard
      Intel Core i5-4690 CPU
      Intel HD 4600 GPU 1
      Nvidia GeForce GTX 750 Ti GPU 2
      iMac 15,1 SMBIOS

      Here is a picture of what happens
      https://imgur.com/gallery/lWTLWlw

      My clover and EFI folders are attached
      EFI.zip
×