Jump to content

Overall system is very sluggish, sometimes leading to glitches like this. Is this a plist/driver problem or a hardware problem?

10 posts in this topic

Recommended Posts



System specs are:

• HP 750-177c Desktop

• i7-6700

• 16GB DDR3

• Intel HD 530 iGPU


I'm doing a complete vanilla install without using any beast tools. My bios is very limited, so I had to do some framebuffer patching with whatevergreen. When I can get into my account and try to play some music, it sounds very choppy and laggy. It'll play-stop-play-stop if that makes any sense, like the computer is running at 1/4 speed.


Anyone have any tips or pointers?

Well, that clearly rules out lack of graphics acceleration then... :)


Looking at your Clover config, I'd say you're missing the Plugin type being set to 1 in the ACPI section. Change this using Clover Configurator app. You may then check your CPU power management with apps such as Intel's Power Gadget tool or HWMonitor app. You can Google for these.



If you're still not getting full CPU SpeedStep/power management, try setting Kernel XCPM in the Kernel & Kext Patches section.



Edited by Hervé

I checked the "KernelLapic" option in clover and restarted, no difference


My BIOS settings just in case I missed something:

Boot Order

    - UEFI Boot sources

       • Mojave SSD

       • USB Floppy/CD

       • USB Hard Drive

    - Legacy Boot Sources

       • ATAPI CD/DVD drive

       • USB Floppy/CD

       • Hard drive

Device Security

     - System Audio (device available)

     - Network Controller (device available)

     - SATA0 (device available)

     - SATA1 (device available)

     - SATA2 (device available)

USB Security

     - Front, Rear, and internal ports are all enabled

Slot Security

     - PCIe 16x (enable)

     - PCIe 1x (enable)

     - M.2 card slot (enable)

Network boot (Disable)

System Security

     - Virtualization technology (VTx/VTd) (Disable)

     - TPM

       • TPM device (Hidden)

Secure Boot Config

     - Legacy Support (enable)

     - Secure Boot (disable)

        • Key Management

           - Clear Secure Boot Keys (don't clear)

           - Key Ownership (HP Keys)

     - Fast boot (disable)

OS Power management

     - Runtime power management (enable)

     - Idle Power Savings (extended)

Hardware Power Management

     - SATA Power Management (enable)

     - S4/S5 wake on LAN (disable)

Power-On Options

     - POST messages (disable)

     - After power loss (off)

     - POST delay (none)

Bus Options

     - PCI SERR# Generation (disable)

     - PCI VGA Palette Snooping (disable)

Device Options

     - Num lock state at power on (on)

     - Multi-processor (enable)

     - Hyper-threading (enable)

     - NIC PXE Option ROM download (enable)

Edited by isleeptill12
More info

Tried using Intel Power Gadget and this is the result:



It works for about a second or two and then stops showing any data


edit: Maybe I do have a graphics acceleration problem since the data shows its stuck at zero?

Edited by isleeptill12
noticed something

Someone on another forum suggested that I select the "InjectIntel" option in graphics in clover. 

Although in the Lilu+whatevergreen framebuffer patching guide it tells you not to do that, I tried it anyway.


I don't know if it did anything, but I was able to boot in and was able to get some more data with IPG.

On the left is pretty much idle, the activity on the right is me playing a song in iTunes. Trying to use the visualizer in iTunes would result in a spinning beach ball and a black window.


  • Create New...