Jump to content
CreativelyChris

After Mojave Install, no APFS SSD in Clover Boot Menu

9 posts in this topic

Recommended Posts

I've made a Mojave Install USB and used Clover 2.4k_r4682 and selected ApfsDriverLoader-64 and also grabbed the APFS.efi file from my install medai and put it into EFI/Clover/drivers64UEFI

 

The installer boots fine. I'm forced to make my SSD an APFS drive, files install and the system reboots, but then I only see my install media. It doesn't see my SSD at all.

 

What can I/should I do?

Share this post


Link to post
Share on other sites
Advertisement

Same problem in New Mojave on T470p. SAMSUNG MZVLW512HMJP-000L7 (512 GB, PCI-E 3.0 x4) with NVM . Tried without success:
- SATA-100-series-unsupported.kext
- NvmExpressDxe-64.efi
- One of the special LiteOn/Plextor/Hynix patches. https://github.com/RehabMan/patch-nvme

 

This solution worked my on High Sierra, but not on Mojave.

Ane idea?

Share this post


Link to post
Share on other sites

I don't think you need APFS.efi, ApfsDriverLoader-64 is enough.

This is what I have on drivers64UEFI,  and you can see that I don't have APFS.efi 

drivers64UEFI/
├── ApfsDriverLoader-64.efi
├── AppleImageCodec-64.efi
├── AppleKeyAggregator-64.efi
├── AppleUITheme-64.efi
├── AptioInputFix-64.efi
├── AptioMemoryFix-64.efi
├── DataHubDxe-64.efi
├── FSInject-64.efi
├── FireWireDevice.efi
├── FireWireOhci.efi
├── FirmwareVolume-64.efi
├── HFSPlus-64.efi
├── PartitionDxe-64.efi
└── SMCHelper-64.efi

Share this post


Link to post
Share on other sites

add hfs+64uefi driver to your usb efi/drivers64uefi folder. also keep apfs.efi as it is. hope it works!!!!!

Share this post


Link to post
Share on other sites
On 10/10/2018 at 11:25 AM, luky35 said:

I have a SSD and I will make a clean installation of Mojave,

 

Which installation do you recommend as HFS + or APFS.

 

Thank you

If you got an SSD, you wont have a choice. MacOS will convert any HFS+ SSD to APFS.

Share this post


Link to post
Share on other sites
6 hours ago, ameris cyning said:

If you got an SSD, you wont have a choice. MacOS will convert any HFS+ SSD to APFS.

I used the installer of chris1111 and made the installation of Mojave HFS and not APFS.

Share this post


Link to post
Share on other sites
On 11/10/2018 at 21:44, luky35 said:

Tôi đã sử dụng bộ cài đặt của chris1111 và làm cho việc lắp đặt Mojave HFS và không APFS.

And with Mojave HFS, can you still update direct from App Store, bro? Cause i hear somewhere seems HFS+ can't update from AppStore, only APFS can update from AppStore.

Share this post


Link to post
Share on other sites

I had the same issue...fixed it by keeping hfs+ instead of apfs. If you really want the apfs file format this will obviously not fix your problem.

 

I Tried apfs.efi and apfsloader64.efi, but it never showed me the apfs partition, then tried the paragon apfs to hfs+ converter and manual repartitioning after the mojave installation, but it just corrupted my drive so it wasnt able to boot (Showed prohibitory sign). 

I then tried skipping the apfs conversion in the install-process via terminal (/Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/startosinstall --converttoapfs NO) but it didnt work because of an firmware error within my drive.

 

BUT!...This installer made my day: https://www.insanelymac.com/forum/files/file/944-mojave-mbr-hfs-firmware-check-patch/

 

It skipped the firmware check so I was able to install mojave on my HFS+ SSD with the converttoapfs No

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×