Jump to content
kinetos

Mojave DP8 on Lenovo X230

6 posts in this topic

Recommended Posts

Hello !
I've tried to update from High Sierra to Mojave but I've some problems...

I've tried a clean install ! :-)

I've used Clover (via hackintosh montreal) to install Mojave DP8.
I've installed some kexts :-) (Brcm, lilu, applealc, fakesmc, mausi, intelgraphic)
I've not a DSDT for the moment and my config.plist is not really good I think

Graphic card : OK

Processor : OK

Memory : OK

Webcam : OK

LAN : OK

USB ports seems to be ok

My laptop is recognize like MacBook Air 13'' mid 2012.

I've installed lilu, applealc and brcm but I've not audio and bluetooth (kexts are the latest). I've added flags for lilu, applealc and brcm).

Have you some ideas to solve that? :-)

Share this post


Link to post
Share on other sites
Advertisement

This is the configuration that I used.

 

**EFI Firmware Configuration**

| Item                                                        | Setting       | Remarks                                                                                                           |
|---------------------------------------------------------    |-----------    |---------------------------------------------------------------------------------------------------------------    |
| Config/Network/Wake On Lan                                  | Disabled      | Not Supported.                                                                                                    |
| Config/USB UEFI BIOS Support                                | Enabled       | Important for booting into USB Installer for OS X/ macOS.                                                         |
| Config/USB 3.0 Mode                                         | Enabled       | Enables USB 3.0                                                                                                   |
| Config/Power/Intel SpeedStep Technology                     | Enabled       | Enables Intel SpeedStep.                                                                                          |
| Config/Power/Intel Rapid Start Technology                   | Disabled      | This feature requires a hibernation partition (0xA0). Not supported on OS X / macOS.                              |
| Config/Power/CPU Power Management                           | Enabled       | Enables CPU Power Management.                                                                                     |
| Config/Serial ATA (SATA)/SATA Controller Mode Option        | AHCI          | Enables AHCI which is better for SSDs and HDDs.                                                                   |
| Security/Predesktop Authentication                          | Optional      | Fingerprint is not supported on macOS / OS X but you can still use it for waking your ThinkPad.                   |
| Security/Security Chip                                      | Disabled      | Disable it if you have a modified UEFI Firmware.                                                                  |
| Security/Memory Protection/Execution Prevention             | Enabled       | This enables NX which is required for macOS / OS X installations.                                                 |
| Security/Virtualization/Intel Virtualization Technology     | Enabled       | Delete boot argument named "dart=0" in config.plist if you set this as Disabled.                                  |
| Security/Virtualization/Intel VT-d Feature                  | Enabled       | Delete boot argument named "dart=0" in config.plist if you set this as Disabled.                                  |
| Security/Secure Boot/Secure Boot                            | Disabled      | Not supported by Clover.                                                                                          |
| Startup/Boot Mode                                           | Quick         | This is optional.                                                                                                 |
| Startup/UEFI / Legacy Boot                                  | UEFI Only     | Reduces Confusion.                                                                                                |
| Startup/UEFI / Legacy Boot/CSM Support                      | No            | 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×