Jump to content

AB9 Pro

16 posts in this topic

Recommended Posts

I got my AB9 Pro and this is what works:


*) All 6 SATA ports when in IDE or AHCI mode.

*) The 2 SATA ports on the JMicron controller.

*) USB.

*) Network, both ports.

*) Sil3132, after setting the PCIclass for the driver.

*) Sound using ALCinject on the ALC882D (using version 0.4 or 0.2a).

*) PATA port of on the JMicron controller.


What's working but flaky:

*) Firewire (sometimes it gives me 40 errors on boot-up regarding bad self ids and it doesn't work thereafter. Seems I have to clear CMOS to get it working again, don't know what's causing it though.)




*) "About this Mac" crashed all the time (it is now fully working ;) ) and hardware info is not correctly reported from the BIOS. See my posts on the subject (and later on how to correct it).




I'm using BIOS 15 and running my C2D E6300 at 420MHz FSB => 2.94GHz. Sweet.



EDIT: I did use a HDD were I had installed OSX on an Asus P5B but I could not get it to install on the AB9 using either PATA DVD or USB DVD. I have not tried SATA DVD and it would be interesting to hear about any success on that. Besides not installing and not being able to wake from sleep this board is a mush better one than the Asus P5B for running OSX in my oppinion (much snappier, especially network), however I returned it since I could not install on it (maybe I should have gotten a SATA DVD??).



EDIT2: The install DVD loads the installer when a SATA DVD is used. The installer also sees all HDDs (at least when in IDE mode).


EDIT3: Sound DOES work using ALCinject.

Edited by tomtefar
Link to comment
Share on other sites

  • 3 weeks later...
  • 3 weeks later...

I'm pretty much ready to give up on this board. Install of JaS 10.4.7 went through with WMware, but booting halts with "waiting for volume with UUID...". Semthex 10.4.8 won't even boot in WMWare: a segfault error pops up.


Thanks for the advice, though.

Link to comment
Share on other sites

I have a new AB9 board (decided to give it a second go ;) ) and a new SATA DVD. My hope is that I can install with the SATA DVD.


Regarding installing in VMware; it seems that you have to pick the right version of vmware to get device drivers in osx to work with it.


Regarding segfault; it seems that you need a newer semthex 10.4.8 kernel than what's on the install DVD to be able to boot in vmware. Can be fixed by mounting the image as read/write and changing the kernel.


Regarding "volume with UUID"; this is because your IntelPIIXATA kext is to old and therefor it does not support ICH8. Could probably be fixed by installing the ICH8 package from the 10.4.8 reseed DVD (guessing).


Gonna report back when I have tested the SATA DVD.

Link to comment
Share on other sites

The install DVD boots fine and loads the installer with a SATA DVD! The installer also sees all HDDs at least as long as they are in IDE mode. I did not install though, I was satisfied with what I saw.



What's odd is that the install I'm currently running, which used to work like a champ on my previous AB9 behaved very strange indeed with random lock-ups etc. I saw nothing of this the last time around with the AB9.

Might have been the ALCinject though since that is NOT working with the AB9.


Edited my first post also.

Link to comment
Share on other sites

  • 2 months later...

Hi there Tomtefar !


I 've recently bought a new AB9 Pro along with QX6600, 2GB Cellshock 4-4-4-12 and a GF6600GT 128MB.


I installed Jas.10.4.8.Intel.SSE3 via VMWARE Workstation 5.5. I applied the ALCInject, JMB and R1000 Patches and everything works according to your post above !


However I cannot get my PCI 1394a (VIA 6306 Based Firewire Controller) to work properly :(


Did u have any progress with firewire yet ?

Link to comment
Share on other sites

  • 2 weeks later...



Some progress regarding firewire support under 10.4.8 on ABIT AB9 Pro motherboard:


If USB 2.0 support is disabled in BIOS, the firewire ports are initialized correctly during kernel boot.


I use my PC mainly for audio, and the USB controllers take up many important IRQs, so I am gonna move my Keyb and Mouse onto PS/2 ports and completely disable USB support.

Link to comment
Share on other sites

  • 1 month later...

lol this motherboard didn't work for me... i have done a partition AF tu be recognized by the installer in vmware, but i loaded the iso from a virtual drive with daemon tools. He recognizes only the partition with Windows xp 132gb and not the 19gb (formatted with diskpart in AF) left to install Mac osx... It is a SATA drive Maxtor 160gb, and trying to install jas 10.4.8 iso


what i have to dooo :(

Link to comment
Share on other sites

AB9 Pro - E6300 (2.8GHz on 400MHz bus) - 2 GB A-Data DDR2-800 (board didn't like my MDT DDR2-667).

I installed Mac OS X 10.4.8 [JaS SSE3 with PPF1 & PPF2] with a TSCorp SH-S183A (S-ATA) onto an empty Samsung HD501LJ (even unpartitioned).

All drives in AHCI mode connected to the ICH8R. Boot from DVD hang when in IDE mode.

I used the loginwindow patch, ALC882 AppleHDA v0.4b for audio (not recogniced in profiler) and Natit_Uni_1.0 for video (eVGA GF7800GT Co - fan control is working).

LAN, Sil3132, JMicron and firewire turned off in BIOS.

I'm trying to get WLAN working first, will try the others later...

Link to comment
Share on other sites

  • 3 months later...
  • 1 month later...

Hey all! This is my first post on the board and although I'm sure many of you are tired of hearing this, I'm an OSX86 n00b. Although I do love me some FreeBSD ;)


I've got an AB9 Pro as follows:

Core 2 Duo E6400 2.13Ghz

300 GB SATA HDD (Maxtor)


Nvidia GeForce 7300GT PCI-express

Windows Vista Ultimate


I also have, for the OSX86 install, an IBM 40GB IDE HDD. This is attached to a Promise ATA133TXX2 card in a PCI slot.


So, here's what I've tried with identical results for upchuck 1.3 10.4.9 and 10.4.9 with 10.4.10 update by Kill3r:

- dvd burns fine no probs.

- w/out adjusting any settings in Bios, I get the plist error

- a little research directed me to connect the ide hdd to the Promise ATA card so that it's not using the JMicron controller

- this got me a little further to a AppleHDA or something or other (sorry did all this last night and have just been researching since then) but the error was something like that.

- A little more research directed me to disable the audio in the Bios

- This gets me to where I'm stuck

- Now I get the waiting for boot device uuid error and it just hangs and repeats waiting for root device (or something)

- I've tried -v to get some more info but no dice


At any rate, I'm trying to get two other releases to see if there's any change. Not sure if there's issues with the ISO's - burned them with Nero 7.


Looks like folks have had some success on the AB9 Pro and I'm just looking for my share :P


Thanks and thanks for helpin' a n00b!

Link to comment
Share on other sites


  • Create New...