Jump to content
Sign in to follow this  
Followers 0
diogosilva48

Acer E1-571G, alguns problemas

29 posts in this topic

Recommended Posts

Posted (edited)

Olá, há quase um ano pedi ajuda com o meu hackintosh aqui 

 e desde então tem-me servido bem como está mas agora decidi que era hora de pedir a ajudar a resolver mais alguns problemas que ainda não tinha conseguido:

-O brilho funciona perfeitamente mas faz reset do valor que estava sempre que reinicio o sistema, ou seja, se tinha o brilho no minimo, depois de reiniciar o PC, ele volta a estar quase no máximo.
-Não consigo colocar o audio por HDMI a funcionar corretamente. Já procurei no tutoriais, mas não percebi muito bem, sendo eles muito distintos uns dos outros também...
-Ainda não sei que kexts colocar ou o que fazer para ter um power management decente... Já vi diferentes kexts para isso, mas não sei qual deles o melhor ou se são até compativeis entre eles...

O processador é o i5-3230M, Ivy Bridge com HD 4000, a placa dedicada é a GEFORCE 710M (caso o hdmi esteja relacionado com isso).

 


Agradeço desde já a ajuda.

Edited by diogosilva48

Share this post


Link to post
Share on other sites
Advertisement
Posted (edited)
37 minutes ago, Allan said:

Veja como ficou: CLOVER.zip

Obrigado, parece ter ficado bastante mais limpo. Tenho duas de perguntas: quando os kexts estão em Other funcionam em qualquer versão do MacOS e não vai ser mais necessária uma DSDT ?

 

EDIT: Acabei de testar essa pasta e a barra de brilho desapareceu das definições e tem aquele bug do brilho depois do modo sleep.

Edited by diogosilva48

Share this post


Link to post
Share on other sites

DSDT sempre é bom, isso que fiz pra você é provisório.

 

Talvez o @MaLd0n consiga editar pra você, ele tem os patches mais atualizados, eu não. :cry:

Vá no GUI do Clover e pressione a tecla F4, inicie o macOS, e faça upload da DSDT que está em CLOVER> ACPI> origin.

Dai ele já ajusta o brilho pra você.

 

E sim, a pasta Other funciona para todos os OS X instalados. Agora se precisar de uma kext especifica pra um OS X, dai sim use as pastas nomeadas.

Share this post


Link to post
Share on other sites
1 hour ago, diogosilva48 said:

Obrigado, parece ter ficado bastante mais limpo. Tenho duas de perguntas: quando os kexts estão em Other funcionam em qualquer versão do MacOS e não vai ser mais necessária uma DSDT ?

 

EDIT: Acabei de testar essa pasta e a barra de brilho desapareceu das definições e tem aquele bug do brilho depois do modo sleep.

primeiro, resolver o gerenciamento de energia, usa o script do pike

ssdtPRGen.command.zip

segundo, desabilitar nvidia, etc

terceiro, limpar essa install, remover os "duplicate"

tem de ver o que funciona

https://www98.zippyshare.com/v/59xpFtuG/file.html
 

 

Share this post


Link to post
Share on other sites
19 minutes ago, Allan said:

DSDT sempre é bom, isso que fiz pra você é provisório.

 

Talvez o @MaLd0n consiga editar pra você, ele tem os patches mais atualizados, eu não. :cry:

Vá no GUI do Clover e pressione a tecla F4, inicie o macOS, e faça upload da DSDT que está em CLOVER> ACPI> origin.

Dai ele já ajusta o brilho pra você.

 

E sim, a pasta Other funciona para todos os OS X instalados. Agora se precisar de uma kext especifica pra um OS X, dai sim use as pastas nomeadas.

Está em anexo.

 

 

16 minutes ago, MaLd0n said:

primeiro, resolver o gerenciamento de energia, usa o script do pike

ssdtPRGen.command.zip

segundo, desabilitar nvidia, etc

terceiro, limpar essa install, remover os "duplicate"

tem de ver o que funciona

https://www98.zippyshare.com/v/59xpFtuG/file.html
 

 


Não percebi muito bem o segundo passo, supostamente a nvidia não está já desabilitada ? Como faço para desabilitar então ? Obrigado

origin.zip

Share this post


Link to post
Share on other sites
Just now, MaLd0n said:

no dsdt dentro da pasta acima eu já desabilitei, o nv_disable não faz esse serviço


obrigado, vou então experimentar colocar a pasta clover que me enviou.

Share this post


Link to post
Share on other sites
38 minutes ago, diogosilva48 said:

substitui o DSDT

DSDT.aml.zip

cara, vc tem de gerar a ssdt pro gerenciamento de energia

roda esse app, vai gerar uma pasta no desktop, dentro dela a sua ssdt, coloca na mesma pasta do DSDT

https://www58.zippyshare.com/v/Cv9YrcVI/file.html
 

 

Share this post


Link to post
Share on other sites
27 minutes ago, MaLd0n said:

substitui o DSDT

DSDT.aml.zip

cara, vc tem de gerar a ssdt pro gerenciamento de energia

roda esse app, vai gerar uma pasta no desktop, dentro dela a sua ssdt, coloca na mesma pasta do DSDT

https://www58.zippyshare.com/v/Cv9YrcVI/file.html
 

 

Agora está tudo a funcionar muito bem, parece, muito obrigado, ainda não consegui testar o audio por HDMI, mas amanhã vou testar isso. Agora reparei que também preciso de ajuda a programar as teclas de brilho, se der, se não der também não é um problema grande.

Queria perguntar também se já posso atualizar sem problema para o High Sierra e continua tudo a funcionar perfeitamente.

E também perguntar outra coisa um bocado mais off topic, eu tenho outro laptop, que comprei recentemente, i7-7700hq, 1060 max q, tipo, ele não vem com hd 630, ou seja, não tem optimus, já tive a ver que há pessoas que conseguiram instalar o MacOS em especificações similares com o NVIDIA webdrive, será que será muito trabalhoso neste e será que vai rodar bem, tipo, será que terá um bom power management...

Share this post


Link to post
Share on other sites
7 minutes ago, diogosilva48 said:

Agora está tudo a funcionar muito bem, parece, muito obrigado, ainda não consegui testar o audio por HDMI, mas amanhã vou testar isso. Agora reparei que também preciso de ajuda a programar as teclas de brilho, se der, se não der também não é um problema grande.

Queria perguntar também se já posso atualizar sem problema para o High Sierra e continua tudo a funcionar perfeitamente.

E também perguntar outra coisa um bocado mais off topic, eu tenho outro laptop, que comprei recentemente, i7-7700hq, 1060 max q, tipo, ele não vem com hd 630, ou seja, não tem optimus, já tive a ver que há pessoas que conseguiram instalar o MacOS em especificações similares com o NVIDIA webdrive, será que será muito trabalhoso neste e será que vai rodar bem, tipo, será que terá um bom power management...

pro debug das teclas

usa esse dsdt

DSDT.aml.zip

instala essa kext em Library/Extensions

ACPIDebug.kext.zip

reinicia , aperta as teclas de brilho do seu notebook

abre o terminal e roda esse comando

Quote

log show | grep -i acpidebug

cola o resultado aqui

 

Esse seu outro notebook funciona como um desktop, esses sem a intelHD usamos a nvidia/amd, é muito melhor que os com tecnologia optimus

 

Share this post


Link to post
Share on other sites
Posted (edited)
28 minutes ago, MaLd0n said:

pro debug das teclas

usa esse dsdt

DSDT.aml.zip

instala essa kext em Library/Extensions

ACPIDebug.kext.zip

reinicia , aperta as teclas de brilho do seu notebook

abre o terminal e roda esse comando

cola o resultado aqui

 

O resultado está em anexo, copiei uma parte apenas porque vi que já repetia um bocado, deve chegar.

 

 

28 minutes ago, MaLd0n said:

 

Esse seu outro notebook funciona como um desktop, esses sem a intelHD usamos a nvidia/amd, é muito melhor que os com tecnologia optimus

 

O que me preocupa é mesmo a bateria mas deve durar razoavelmente, mas agora só testando...

 

 

Não sei se será um problema o ficheiro ir em rtf mas só reparei agora. E já agora, já testei o audio HDMI e funciona mesmo na perfeição, obrigado.

 

resultado.rtf

Edited by diogosilva48

Share this post


Link to post
Share on other sites
Posted (edited)
18 hours ago, MaLd0n said:

testa aí, apareceram outras entradas, vamos ver se funciona

DSDT.aml.zip

 

se funcionar, deleta a kext ACPIDebug.kext

Obrigado, ficou tudo a funcionar na perfeição, obrigado. Se fizer update para o High Sierra continua tudo a funcionar assim perfeitamente ?

Edited by diogosilva48

Share this post


Link to post
Share on other sites

Estou a tentar fazer instalação limpa do High Sierra usando aqueles mesmos arquivos do Clover no pen drive mas estou a ter o erro "Este disco não pode ser usado para inicializar o seu computador" ao selecionar o disco de instalação.

Share this post


Link to post
Share on other sites
Posted (edited)

Só consigo dar boot no Sierra, tentei atualizar o Clover selecionando todos os drivers64UEFI e não dava boot, não posso fazer isso ? 

 

Edit: Consegui atualizar para o High Sierra a partir do Sierra sem problema.

Edited by diogosilva48

Share this post


Link to post
Share on other sites
Posted (edited)

Eu fui testar umas distros linux já que este é o meu notebook secundário, mas antes fiz backup da pasta do Clover tudo certinho, agora voltei a instalar o macOS Sierra e coloquei a pasta Clover e o slider do brilho não está a funcionar, não sei porquê, estava a funcionar antes, coloquei tudo direitinho, até DSDT e SSDT.

Edited by diogosilva48

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×