Jump to content
zekeer

[SOLVED] GA-B250-HD3 all works very well except sleep

23 posts in this topic

Recommended Posts

Hello everybody

I have GA-B250-HD3, and core i5 6500 CPU whith inernal graphics

I'am happy that Mac OS X High Sierra on my machine is work very well, but 1 trouble is saddens me.
Sleep/Hybernation dont work. I tryied to write several darkwake options in Clover, and tryied to change
hibernatemode 0,3,25. I am newbie at hackintosh, and i think that if i want that sleep is working i need to patch DSDT, but i cant do it.
If somebody have this motherboard too and know how repair sleep, please help.

Sorry for my English, i hope somebody understood me =)

 

UPD: I solved the problem and hibernation worked very well whith integrated graphics hd530.

If you want to hibernation works:

- put atached  HibernationFixup.kext to /EFI/CLOVER/kexts/Other

- put atached AptioMemoryFix.efi to /EFI/CLOVER/drivers64UEFI

-delete EmuVariableUefi-64.efi from /EFI/CLOVER/drivers64UEFI

- in terminal enter

sudo pmset -a hibernatemode 25

-in config.plist add boot args:

-hbfx-patch-pci=XHC -hbfx-dump-nvram

and

<key>StrictHibernate</key>
		<true/>

My config.plist is atached, i hope it wil be useful

AptioMemoryFix.efi

HibernationFixup.kext.zip

config.plist

Edited by zekeer
i had solved the problem with hibernation and want to put it to other users

Share this post


Link to post
Share on other sites
Advertisement

here we go, replace full folder, , remove VoodooHda, Reboot

CLOVER.zip

*in some cases intelHD 6xx have several problems with sleep, dont work

Share this post


Link to post
Share on other sites

here we go, replace full folder, , remove VoodooHda, Reboot

attachicon.gifCLOVER.zip

*in some cases intelHD 6xx have several problems with sleep, dont work

thx, good news - system is booted, bad news i haven't sound but output devices is on and sleep steel rebooting after wake up

Share this post


Link to post
Share on other sites

go to system preferences/audio/output and check there

output devices i see there, but sound is absent, and video on youtube dont going

Share this post


Link to post
Share on other sites

back ur voodoohda

ok, sound is coming back.

Hibernation is steel broken :cry:

anyway thank you very much for your time spent for me, i am very glad that guys all over the world can help each other

Share this post


Link to post
Share on other sites

later we try other layout id, ur audio work with native drivers ;)

sounds great)

sleep is absolutly imposible for my chipset?

Share this post


Link to post
Share on other sites

Did you try darkwake=10 flag? On my motherboard (which is, I guess by the name, very similar to yours) it works perfectly fine. I don't use internal graphics, maybe that makes the difference.

Share this post


Link to post
Share on other sites

Did you try darkwake=10 flag? On my motherboard (which is, I guess by the name, very similar to yours) it works perfectly fine. I don't use internal graphics, maybe that makes the difference.

thx brat.

I tried connect old Geforce GT9600 and turn off the internal graphics, then boot with darkwake=10, sleep works perfect.

Guys if somebody knows how to work sleep on integrated graphics on core i5 6500 please tell me)

Share this post


Link to post
Share on other sites

I am download olarila image, took config.plist from it and my sound works with native kext.

And sleep works perfectly with my good old 9600 gt)))

Thanx guys, all solved)

Share this post


Link to post
Share on other sites

I solved the problem and hibernation is worked very well, at 1st post wrote how did it

Share this post


Link to post
Share on other sites

This get's sleep working for me on Intel  graphics

 

sudo pmset -a standby 0 

Share this post


Link to post
Share on other sites
On 12.03.2018 at 3:50 PM, Donw35 said:

This get's sleep working for me on Intel  graphics

 

sudo pmset -a standby 0 

What hibernatemode do you use?

Share this post


Link to post
Share on other sites

not sure I know, I just have dark wake without anything after it

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By SeePurple
      The display sleep does not work correctly. Starting with Mac 10.12.4, the display sometimes does not wake up. The backlight works, there is no image, a black screen. Currently installed 10.14.1. All the same. If the display is sent to sleep, then sometimes it can wake up in a black screen with a working backlight. From the description, it is not difficult to guess that the display sometimes wakes up correctly and sometimes wakes up in a black screen. In the course of the experiments, I also saw that the display sometimes woke up and showed the boot screen (the Apple logo and progress bar), a second after that the desktop appeared. This behavior occurs only when the display wakes up on a black screen and then I close and open the laptop cover again, after which the boot screen sometimes appears for a second, but sometimes nothing appears, the system just hangs.
      I hope I clearly described the symptoms of the problem.
       
       
      The screenshot was taken after the experiment. I sent the display to sleep, then woke it up. He woke up in a black image with burning lights. Then I closed and opened the laptop bucket, pressed the space bar and waited a few seconds. After a few seconds, the boot screen with the Apple logo appeared and then the desktop appeared. Immediately made a screenshot.
       
      Asus k501lb
      Intel HD 5500
      Core i-5 5200U ( Broadwell )
      Display: au optronics B156HTN03.8

       

    • By BrianWong11031
      Hi, my hackintosh won't sleep!
      It often sleeps for 3-5 seconds and auto wakes up.
      sometimes it can't enter the sleep mode even you click the sleep button.
      I have uploaded my DSDT file.
      but I don't know how to patch DSDT.
      If you know how to solve this issue, please help me!
       
      Cheers,
      Brian
      DSDT.aml
    • By BrianWong11031
      1, my hackintosh machine can sleep but just for a few seconds and the fans and HDD or some devices will start working.
      2, i have tried many ways to solve this issue, such as install DSDT.aml and Patch USB limit.
      Do you have any method to solve this issue?
      I really want some useful advice from you!
      Thanks for replying.
       
      Cheers,
      Brian
    • By ozy1ozy
      Resolved:
      After nearly going completely crazy trying to disable everything, it turned out to be the Common Unix Printing System (thanks to DGKApps.com).
       
      Turn off the CUPS from the command line:
       
      sudo launchctl unload -w /System/Library/LaunchDaemons/org.cups.cupsd.plist
       
       
      You can re-enable it with the following:
      sudo launchctl load -w /System/Library/LaunchDaemons/org.cups.cupsd.plist
       
       
      You can test to see if it’s running with the following command:
      sudo launchctl list | grep cupsd
    • By C0nvert
      EFI Clover zip: https://aster-cloud.de/nextcloud/index.php/s/TjXg3qs2ydRTmS9
×