Jump to content
heptas

Atheros AR8151 - AlienWare M17X R4

16 posts in this topic

Recommended Posts

Olá a todos.

 

fiz o Upgrade do Sierra para o HS e estou com quase tudo ok. Já tentei muitas coisas para fazer a LAN funcionar e nada.

no Sierra funcionava de Boa com a Kext AtherosL1cEthernet.kext em EFI/CLOVER/KEXT/OTHER

 

Ja tentei:

 

AtherosL1cEthernetSierra.kext

AtherosE2200Ethernet.kext

ALXEthernet.kext (essa da pal e nem boota)

 

ja tentei por o device id em fake lan , já tentei outro device id 

 

Estou mandando o config.plist e IOREG (com e sem DSDT ) e DSDT.aml

 

estou no 10.13.1

 

Quem tiver alguma sugestão eu agradeço.

abraço e feliz 2018

 

EFI.zip

Share this post


Link to post
Share on other sites
Advertisement

Boa noite usa a kext AtherosE2200Ethernet.kext mas coloca ela na /System/Library/Extensions/AtherosE2200Ethernet.kext ou instala ela com o kext utility. Na minha depois que eu troquei de Sierra para o HS, tbem não funcionava.

Share this post


Link to post
Share on other sites

usa na Library/Extensions, bem melhor que na S/L/E que tem 300+ kexts

coloca a kext na pasta e roda o kext utility

Share this post


Link to post
Share on other sites

olá

 

teu device id é 1083 ?

 

está na kext AtherosE2200Ethernet.kext

 

​mas essa kext precisa de dependências da ionetworkingfamilly.kext que se encontra em /System/Library/Extensions

 

no ioreg mostra que a kext está sendo carregada

 

bom hack 

Share this post


Link to post
Share on other sites

Ola tenho o mesmo problema meu wifi funciona sem problema, mas a AR8151 V1969 D1083 nao vai!

Quero fazer ela funcionar pq com o wifi so pego 41mb ja no cabo eu pegaria os 70mb da internet.

Tentei ALXEthernet, AtherosE2200Ethernet, AtherosL1cEthernet. e nada...

nenhuma mostra no IOREG. tenho apenas wifi.
nao sei se o problema ta no DSDT..
caso alguem possa ajudar.

m17xr4.zip

Share this post


Link to post
Share on other sites

Update...

esperimentei essa kext https://github.com/andyvand/AtherosE2200Ethernet
Instalei ela a 1 vez no /S/L/E e tambem uma copia na pasta EFI e nada..
porem ao modificar ela nos campos <key>OSBundleLibraries</key> etc..(eu sei que nao adianta muita coisa mudar o info.plist da kext, mas nao custa tentar)

ela carrega e mostra no IOREG mas ainda nao funciona nem mostra o dispositivo no system preferences.

A Kext desse link parece promissora ja que a original AtherosE2200Ethernet nao suporta o chip AR815X
acho que deve ser preciso recompilar ela pro high Sierra.

To enviando uns prints e o IOREG e a kext.

OBS ainda to usando o 10.13.1
 

Archive.zip

Share this post


Link to post
Share on other sites

olá

 

tenta esta kext

 

AtherosE2200Ethernet.kext.zip

 

é + 1 tentativa

 

www.insanelymac.com/forum/topic/284119-experimental-atheros-ar813132515261627172-driver-for-107108/

 

essa ai tem teu dev id e vender id .. mas o projecto penso que está meio abandonado

 

bom hack

Share this post


Link to post
Share on other sites

olá

 

tenta esta kext

 

attachicon.gifAtherosE2200Ethernet.kext.zip

 

é + 1 tentativa

 

www.insanelymac.com/forum/topic/284119-experimental-atheros-ar813132515261627172-driver-for-107108/

 

essa ai tem teu dev id e vender id .. mas o projecto penso que está meio abandonado

 

bom hack

mesma coisa. Mostra bonitinho na lista de dispositivos PCI, mas nada...

Share this post


Link to post
Share on other sites
On 24/01/2018 at 8:54 AM, artur_pt said:

olá

 

teu device id é 1083 ?

 

está na kext AtherosE2200Ethernet.kext

 

mas essa kext precisa de dependências da ionetworkingfamilly.kext que se encontra em /System/Library/Extensions

 

no ioreg mostra que a kext está sendo carregada

 

bom hack 

Meu device id é: 1090.

Share this post


Link to post
Share on other sites

olá

estes são os que estão na kext de atheros2200

0x10901969 0x10911969 0x10A01969 0x10A11969 0xE0911969 0xE0A11969 0xE0B11969

podes tentar com clover fake id da lan

Captura de ecrã 2018-03-31, às 09.30.23.png

bom hack

Share this post


Link to post
Share on other sites
6 hours ago, artur_pt said:

olá

estes são os que estão na kext de atheros2200

0x10901969 0x10911969 0x10A01969 0x10A11969 0xE0911969 0xE0A11969 0xE0B11969

podes tentar com clover fake id da lan

Captura de ecrã 2018-03-31, às 09.30.23.png

bom hack

posso ate tentar. mas no proprio git do projeto da atheros2200 o dev fala que a kext nao suporta a ar81xx.. 

como eu falei antes esse dev id (1083)so vi ser suportado no mavericks. depois disso nao vi mais. (não com sucesso)

Share this post


Link to post
Share on other sites

já tentei com fake id, apenas uma correção. a placa de rede não é AR8151, mas sim AR8162. não sei de onde eu tirei esse AR8151. o id que passei, 1090 é o ID correto mesmo.

Vendor : 1969

Device :1090

SubVen:1028

Vendor Name: Qualcomm Atheros

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×