Jump to content

Qualcomm Atheros AR9565 Wireless for OS X 10.8 - 10.14


Meowthra
 Share

37 posts in this topic

Recommended Posts

Atheros AR9565 Wireless for OS X  10.8.x/10.9.x / 10.10.x / 10.12.6/10.13.6/10.14

 

# Install Atheros AR9565 Driver for MacOS  10.8 - 10.14

curl -O https://raw.githubusercontent.com/kalifans/Darwin/Driver/ar956x-drv-osx.tar.gz
tar zxvf ar956x-drv-osx.tar.gz
cd ar956x-drv-osx
./ar956x-inst.sh

 

Reboot

 

 

Preview

 

wLKQ95s.png

 

eaUqGsr.png

 

iaeq8WI.png

 

V0ftGMq.png

 

 

 

 

 

Edited by Meowthra
  • Like 4
Link to comment
Share on other sites

  • 3 months later...
  • 3 weeks later...
  • 2 weeks later...
On 1/23/2019 at 9:31 AM, Meowthra said:

tNOjBsr.png

 

ulVRBiu.png

 

3qfk4kG.png

Dear Meowthra

 

ATHREOS AR 956x worked perfectly,

I installed kext in S/L/E  Bluetooth not working any solution ?

Edited by majoract100
Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...
On 2/22/2019 at 7:53 AM, majoract100 said:

Bluetooth not working any solution

For Bluetooth I use this kexts, just put they to /EFI/CLOVER/kexts/Other/ directory (unzip they before) 

BrcmFirmwareRepo.kext.zip

BrcmPatchRAM2.kext.zip

 

Integrated bluetooth device found other devices but I didn't try to connect they.

screenshot.png

Edited by Tatanka
Link to comment
Share on other sites

  • 3 weeks later...
On 3/23/2019 at 5:51 PM, Tatanka said:

For Bluetooth I use this kexts, just put they to /EFI/CLOVER/kexts/Other/ directory (unzip they before) 

BrcmFirmwareRepo.kext.zip

BrcmPatchRAM2.kext.zip

 

Integrated bluetooth device found other devices but I didn't try to connect they.

screenshot.png

Could not find other devices (not discoverable) using Brcm kexts in Clover.  WiFi works very well.

Link to comment
Share on other sites

  • 3 weeks later...
  • 3 weeks later...
  • 2 weeks later...
  • 1 month later...
  • 3 weeks later...

Thanks for the script!

Based on your script made mini GUI application (in Russian): https://vk.com/wall-135785821_1712

Also, I noticed that it is better to run the KextUtility program after running the script, so that the cache is rebuilt for sure.

 

P.S. the speed Limit is 11 Mb, I have not noticed, I have speedtest gave 24 Mbps for download and upload.

 

https://www.speedtest.net/result/8522447498

nPbCJ0GTwy4.jpg


P. P. S.


Tried just AirPortAtheros40.kext (AR9565.10.13.v21)throw in /Other, rebuild cache and restart Hackintosh - WiFi is not working. Similarly, only threw a text in KextUtility.
Tried already working IO80211Family.kext (inside of which / Plugins contains AirPortAtheros40.kext) throw in /Other (in /S/L/E lay not patched), rebuilt the cache, restarted the Hackintosh, but WiFi was also not recognized. In config.plist parameter InjectKexts=Yes. It's weird, I thought Clover kext from /Other would put "on top" of that kext that in /S/L/E.

Edited by Drovosek
Link to comment
Share on other sites

  • 1 month later...
kxld[com.apple.driver.AirPort.Atheros40]: The vtable 'vtable for AirPort_AtherosNewma40' is malformed. Make sure your kext has been built against the correct headers.
kxld[com.apple.driver.AirPort.Atheros40]: The vtable 'vtable for AtherosNewma40P2PInterface' is malformed. Make sure your kext has been built against the correct headers.
kxld[com.apple.driver.AirPort.Atheros40]: The vtable 'vtable for AirPort_AtherosNewma40' is malformed. Make sure your kext has been built against the correct headers.
kxld[com.apple.driver.AirPort.Atheros40]: The vtable 'vtable for AtherosNewma40P2PInterface' is malformed. Make sure your kext has been built against the correct headers.
Link failed (error code 5).
Prelink failed for com.apple.driver.AirPort.Atheros40; omitting from prelinked kernel.

I tried using the Mojave kext in Catalina, but no dice. Any plans to support Catalina?

Link to comment
Share on other sites

 Share

×
×
  • Create New...