Jump to content

ATI X1400 Fully Working Dell 9400


16 posts in this topic

Recommended Posts

Finally i get a fully x1400 working on my DELL 9400, DVD plays, CI/QE, Resolution Change, RSS Screen Saver. (Not tested under pro apps like finalcut or aperture)


Here is what i done.


I got 10.4.5 but when i tried to update to 10.4.8 with JAS combo update my OS X crashed -very understood, because i was using kexts and frameworks from several versions ;)- so i decided to download full JAS DVD 10.4.8 SS3.


Here is what i done.


1. Boot from 10.4.5 DVD (i think you can boot from other version 10.4.7 or 10.4.4, etc)

2. Format or erase MacOSX partition

3. Reboot with JAS 10.4.8

4. Select none of the JAS packages except Semthex kernel

5. Once OSX installed reboot WITHOUT CD (because if you left the cd inside later you would not be able to boot without cd)

6. configure your account and reboot

7. There's no network on my Broadcom Ethernet!. Download the IONETWORKINGFAMILY.KEXT from here




Replace it, repair permissions and reboot.


8. Done, network is working =)

9. Download from http://www.installers.dl.am the 3.6 version

10. Install the package and reboot.

11. X1400 working like a charm, i didn't have to do anything else, like mess with ATI KEXTS




Link to comment
Share on other sites

I tried installer. My Acer boots up but i get black screen upon boot. Everything works ok (i can shout down - with power button). My Acer does not freeze. I need one external monitor to try on (i do not have one).


Any news on Titan project for ATI?



Link to comment
Share on other sites

  • 1 month later...



I was just wondering if anyone else has had any success with the Inspiron 9400 (e1705 in the US) with the ATi x1400 card...?

I'm gonna follow thefabulous9mm's instructions when I get home, since I just managed to get the Jas 10.4.8 DVD. I hope the Natit patch (or any other method) will give me QE/CI, and in my internal panel...

Right now I've only managed to get OSX working at 1600x1200 with no qe/ci, no sound (sigmatel audio....), no wireless (Intel card...) and with just one core active in my Core Duo T2500, or else I get unbearable stuttering and poor performance. (I have 10.4.6 with older kernel)

If you have succeeded in getting the mobility x1400 fully working in any other machine it would be nice to know too :P

I'll post my success/disappointment here when I'm done :(


Thank you! You all rock.

Edited by eoy4
Link to comment
Share on other sites

  • 1 month later...


Thanks for all those posts.

But I'm a newbe with Mac.

I have a Dell Inspiro 6400/E1506 Duo Core

Installed MacOSX 10.4.8 JaS AMD/Intel SEE2 SEE3


How do I get the files I DL onto my WinXP disk to the MacOSX disk.

I do have those file on CD, USB, and on my win HDD.



Link to comment
Share on other sites

  • 1 month later...



I just installed the new Uni installer v1.0 but internal as external displays stay black after booting.

Can somebody post the readme that includes the instructions to remove the package again?

Just download the Uni installer, execute it and save the readme and post it here plz


thx folks



Link to comment
Share on other sites

  • 3 weeks later...

  • Create New...