Jump to content

AppleHDA HDMI Audio


toleda
 Share

101 posts in this topic

Recommended Posts

 

SSDT-HDEF-3.aml is loading but ignored

config.plist/ACPI/DSDT/Fixes/ - all properties set to YES, unusual.

Set: config.plist/ACPI/DSDT/Fixes/FixHDA_8000/NO

Save, restart, reply with new files.

 

Thanks for the quick response.

Some progress...

 

I set config.plist/ACPI/DSDT/Fixes/FixHDA_8000/NO 

And now the HDMI port shows up in system report. But still not available in the sound as an option for output.

 

​Edit: anyway to makee the SSDT-HDEF3.aml not be ignored? I see a message that says the patch was a success in the boot log.

post-254523-0-50946200-1511723592_thumb.png

Link to comment
Share on other sites

Also, I see that in IORegExplorer my monitor (Display0 - AppleDisplay) is connected to Port 0x6.

But the script says that HD4000 port 0x7 is a native HDMI port. 

 

Is there something special about my system that I need to manually correct? Given that this is an IVY bridge CPU on a 6-series motherboard.

Link to comment
Share on other sites

I see that in IORegExplorer my monitor (Display0 - AppleDisplay) is connected to Port 0x6.

 

No IOReg attached, no ideas. Ignored Post #25/"reply with new files."

See Post #1/IV. Problem Reporting; attach all requested files

Link to comment
Share on other sites

see attached terminal output

Apologies for the delay in replying.

Ignored "attach all requested files"

Edit config.plist/Devices/Audio/Inject/0 to 1

Save, restart, run cloverHDMI, restart, reply with all requested files.

Link to comment
Share on other sites

Apologies for the delay in replying.

Ignored "attach all requested files"

Edit config.plist/Devices/Audio/Inject/0 to 1

Save, restart, run cloverHDMI, restart, reply with all requested files.

 

Hi Toleda, here we are:

 

1. No HDMI audio output, no output devices found

 

2. macOS High Sierra 10.13.2 / Asus Z170-A / Bios 3504 (last) / Intel i7-6700K / Intel HD530

 

3. AppleHDA HDMI Audio / Post #1

 

4. Attached, AppleHDA.kext version 280.12

 

5. ‘my iMac’ attached

 

6.1 WARNING! Malware Detected, Download at your own risk

 

6.2 Attached screenshot system info

 

7. See 6.1

 

8. Attached MaciASL

 

9. Attached Terminal Saved Output

 

11.1 Attached config.plist

 

11.2  See 6.1

 

 

11.4 Attached SSDT-HDEF and SSDT-HDMI

 

 

if you need more ...

Attachments for Toleda.zip

Link to comment
Share on other sites

1. No HDMI audio output, no output devices found

 

Missed Post #1/V. Requirements/2. Native AppleHDA.kext/4. Remove/Disable Clover audio/HDMI audio patches ...

 

change HDAS to HDEF disables SSDT-HDEF-HDAS-1 ssdt

 

Remove config.plist/ACPI/DSDT/Patches/Item 0 (change HDAS to HDEF)

 

Restart, reply with new files

Link to comment
Share on other sites

Missed Post #1/V. Requirements/2. Native AppleHDA.kext/4. Remove/Disable Clover audio/HDMI audio patches ...

 

change HDAS to HDEF disables SSDT-HDEF-HDAS-1 ssdt

 

Remove config.plist/ACPI/DSDT/Patches/Item 0 (change HDAS to HDEF)

 

Restart, reply with new files

 

hope it helps

 

V. Requirements

 

2. Native AppleHDA.kext attached

 

2.4 Remove Item 0: done

Attachments_2.zip

Link to comment
Share on other sites

A few files, not helpful.

 

Post #1/IV. Problem Reporting; attach all requested files.

 

Hi Toleda, thanks for your support, here we go again

 

1. About this Mac / System Report / Audio -> no devices

    System Preferences / Sound / No output devices found

 

2. macOS High Sierra 10.13.3 beta 1 / Asus Z170-A / Bios 3504 (last) / Intel i7-6700K / Intel HD530 / Clover 4334

 

3. AppleHDA HDMI Audio / Post #1

 

4. Attached, AppleHDA.kext version 280.12

 

5. ‘my iMac’ attached

 

6.1 WARNING! Malware Detected, Download at your own risk

 

6.2 Attached screenshot system info

 

7. See 6.1

 

8. Attached MaciASL

 

9. Attached Terminal Saved Output

 

11.1 Attached config.plist

 

11.2  See 6.1

 

11.4 Attached SSDT-HDEF and SSDT-HDMI

Attachments_3.zip

Link to comment
Share on other sites

See V. Requirements/2. Native AppleHDA.kext/4. Remove/Disable Clover audio/HDMI audio patches

Edit config.plist as noted, save.

Restart, reply with new files

 

 

4.1 I do not have patches in my config.plist. Is that right?

 

 

 

1. About this Mac / System Report / Audio -> no devices

    System Preferences / Sound / No output devices found

 

2. macOS High Sierra 10.13.3 beta 1 / Asus Z170-A / Bios 3504 (last) / Intel i7-6700K / Intel HD530 / Clover 4334

 

3. AppleHDA HDMI Audio / Post #1

 

4. Attached, AppleHDA.kext version 280.12

 

5. ‘my iMac’ attached

 

6.1 WARNING! Malware Detected, Download at your own risk

 

6.2 Attached screenshot system info

 

7. See 6.1

 

8. Attached MaciASL

 

9. Attached Terminal Saved Output

 

11.1 Attached config.plist

 

11.2  See 6.1

 

11.4 Attached SSDT-HDEF and SSDT-HDMI

Attachments_4.zip

Link to comment
Share on other sites

4.1 I do not have patches in my config.plist. Is that right?

Your config.plist has lots of problems.

Unfortunately, all files attached are not helpful.

Ignored Post #36.

config.plist in next post is correct

Reply with new requested files.

What device is connected to what motherboard port?

Link to comment
Share on other sites

Your config.plist has lots of problems.

Unfortunately, all files attached are not helpful.

Ignored Post #36.

config.plist in next post is correct

Reply with new requested files.

What device is connected to what motherboard port?

 

Hi Toleda, here my 2 Cents,

 

1. About this Mac / System Report / Audio -> no devices

    System Preferences / Sound / No output devices found

 

2. macOS High Sierra 10.13.3 beta 1 / Asus Z170-A / Bios 3504 (last) / Intel i7-6700K / Intel HD530 / Clover 4359

 

3. AppleHDA HDMI Audio / Post #1

 

4. Attached, AppleHDA.kext version 280.12

 

5. ‘my iMac’ attached

 

6.1 WARNING! Malware Detected, Download at your own risk

 

6.2 Attached screenshot system info

 

7. See 6.1

 

8. Attached MaciASL

 

9. Attached Terminal Saved Output

 

11.1 Attached config.plist

 

11.2  See 6.1

 

11.4 Attached SSDT-HDEF and SSDT-HDMI

 

 

Device connected:

 

Display HDMI Philips 247E6 on HDMI port

 

Keyboard/Mouse Logitech MK270 wireless on USB port

 

Ethernet

 

PCIe 3.0 x4 ASUS HYPER M.2 X4 MINI adapter, Samsung 950 PRO M.2 NVMe SSD (Windows 10) 256GB

 

SATA HDD multi boot High Sierra, Sierra, El Capitan

 

 

Hope it helps.

Attachments_5.zip

Link to comment
Share on other sites

my 2 Cents

Clover is blocking SSDT-SSDT-HDEF-HDAS-1

set config.plist/ACPI/DSDT/Fixes/FixHDA/NO

cloverHDMI:

Confirm DP to HDMI connector edit on port 0x6 (y/n): n
Ignore port 0x6
No framebuffer edits requested

Answer y for display on HDMI connector

Edit config.plist, above, and save

Run cloverHDMI

Restart, reply with new files

Include Clover boot log

Link to comment
Share on other sites

Clover is blocking SSDT-SSDT-HDEF-HDAS-1

set config.plist/ACPI/DSDT/Fixes/FixHDA/NO

cloverHDMI:

Confirm DP to HDMI connector edit on port 0x6 (y/n): n
Ignore port 0x6
No framebuffer edits requested

Answer y for display on HDMI connector

Edit config.plist, above, and save

Run cloverHDMI

Restart, reply with new files

Include Clover boot log

 

To make things easier I removed  the PCIe mini adapter card.

 

 

1. About this Mac / System Report / Audio -> no devices

    System Preferences / Sound / No output devices found

 

2. macOS High Sierra 10.13.3 beta 1 / Asus Z170-A / Bios 3504 (last) / Intel i7-6700K / Intel HD530 / Clover 4359

 

3. AppleHDA HDMI Audio / Post #1

 

4. Attached, AppleHDA.kext version 280.12

 

5. ‘my iMac’ attached

 

6.1 WARNING! Malware Detected, Download at your own risk

 

6.2 Attached screenshot system info

 

7. See 6.1

 

8. Attached MaciASL

 

9. Attached Terminal Saved Output

 

11.1 Attached config.plist

 

11.2  See 6.1

 

11.4 Attached SSDT-HDEF and SSDT-HDMI

 

 

Clover Install log included

Attachments_6.zip

Link to comment
Share on other sites

1. About this Mac / System Report / Audio -> no devices

    System Preferences / Sound / No output devices found

To clarify, this thread is for HDMI audio only; advise if you are interested in 892 audio.

Problem with config.plist: Entry, ":KernelAndKextPatches:KextsToPatch:", Does Not Exist

Run cloverHDMI again, answer yes to connector edit

Reply with new files.

Link to comment
Share on other sites

To clarify, this thread is for HDMI audio only; advise if you are interested in 892 audio.

Problem with config.plist: Entry, ":KernelAndKextPatches:KextsToPatch:", Does Not Exist

Run cloverHDMI again, answer yes to connector edit

Reply with new files.

 

Hi Toleda, no, I'm not interested in 892 audio. I just need HDMI audio. I will change 1. to 'no HDMI audio'.

 

Answering 'yes' to connector edit, cloverHDMI replies

 

Entry, ":KernelAndKextPatches:KextsToPatch:", Does Not Exist

 

forever ...

 

Config.plist was damaged, switched to Sierra 10.12.6

Edited by Joshua60
Link to comment
Share on other sites

To clarify, this thread is for HDMI audio only; advise if you are interested in 892 audio.

Problem with config.plist: Entry, ":KernelAndKextPatches:KextsToPatch:", Does Not Exist

Run cloverHDMI again, answer yes to connector edit

Reply with new files.

 

here we go:

 

1. No HDMI audio

 

2. macOS Sierra 10.12.6 / Asus Z170-A / Bios 3504 (last) / Intel i7-6700K / Intel HD530 / Clover 4359

 

3. AppleHDA HDMI Audio / Post #1

 

4. Attached, AppleHDA.kext version 279.48

 

5. ‘my iMac’ attached

 

6.1 WARNING! Malware Detected, Download at your own risk

 

6.2 Attached screenshot system info

 

7. See 6.1

 

8. Attached MaciASL

 

9. Attached Terminal Saved Output

 

11.1 Attached config.plist

 

11.2  See 6.1

 

11.4 Attached SSDT-HDEF and SSDT-HDMI

 

X. Clover bootlog attached

Attachments_7.zip

Link to comment
Share on other sites

  • Allan unpinned and locked this topic
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...