Jump to content

Dell Precision Tower 5810 need help installing Sierra / High Sierra / Mojave / Catalina


109 posts in this topic

Recommended Posts

  • 2 weeks later...

Haven't had much time to mess with the built in audio too much. I will. Still need to work on making a guide.


I've been working on installing linux. I'm going to ask for some advice on the AVLinux forum also, but thought here would be a good place too. Here's what's going on. From what I've gathered when using Linux for Audio a Real-time or RT kernel is preferred. It allows for less overruns and lower latency. I had intended to run AVLinux, as it is set up to do just this. However the guy who puts it together, doesn't have any computers running UEFI. So support is somewhat lacking. From what I've gathered those who get it to work, have done so by turning on "Legacy Boot Support". I'm afraid to do this, as I don't want to break my OSX install. It's working great.


Would turning on Legacy Boot Support hurt, now that I've gotten MacOS running well? Would it do anything to Windows?


Every time I've installed AVLinux, when I reboot, it won't boot, and the computer doesn't see the drive. I think I tried to see if Clover would see it but it didn't. The creator of AVL uses systemback for his install method. I've read that I need to install Grub from Terminal before rebooting. I've done that also, and can't see to get it to work. So I've tried some other distros, but either they don't work (KXStudio, io GNU/Linux) or they aren't that optimized for audio (Ubuntu Studio). I have Ubuntu Studio installed now, but really want AVLinux to work.


So I've been thinking. I've installed Windows and each LInux OS by removing all other Hard Drives and using a USB stick set up via Rufus. Then once it's installed and working, I've put in the other hard  drives and set the MacOS one w/Clover as the boot drive.


Would it maybe work if I used Clover to load the USB drive to begin with? Would that maybe work? AVLinux is based on Debian Linux, and according to the creator "should" support UEFI. But as mentioned can't test it. So maybe clover could somehow provide the legacy support to allow it to boot? I've read about using clover to replace Grub. But honestly, it's still a bit over my head, and last thing I want to do is mess up my MacOS installation.


Anyway I'll keep doing some research and see what I can figure out. Let me know if there's anything you guys can't point me towards to figure this out.



Link to comment
Share on other sites

Great thread from you both , can i get a look at the clover options that you had the most success with.

Been trying to install sierra with clover uefi to a dell 5810 and t3610 .

had the t3610 on Yosemite some time ago but skipped el capitan due to the usb changes.

boot flags dart=0 , ncpi=0x2000 , latest dell bios in each .

quadro k4000 graphics with e5 1620v2 for the t3610 , e5 2630 v3 for the 5810

to be fair have been trying more with the t3610 but only because 10.10 was up an running.

Back then graphics was amd w7000 which I edited to work great.

Think the clover kexts / setting I used need tweaking .

can get to about 3/4 way on the apple progress bar then panic.

Link to comment
Share on other sites

Give me a bit and I'll get more for you. But there is one thing that made a big difference.




This is for the 5810, which uses the c612/x99 chipset. Not sure it will apply to the 3610. Once I got that working it was my video card that was causing issues if I remember. I finally got around them, but in the end got a gtx1050 ti card. Mine was a low end workstation card. It worked best in vesa mode. But that wasn't ideal. I would think the k4000 would be better supported. But no promises.

Link to comment
Share on other sites

Sorry I didn't get back yesterday. I started off with this Guide.




It's a bare minimum starting place. The most important/useful part for me was the SMBIOS configuration. Probably one of the more in depth ones I've found. I've used MacPro 6.1 throughout the process. I did at one point try the Haswell imac, just for kicks, but it didn't help.


I'm using Clover Configurator to look at my config.plist. I'll start on the first page and tell you what I see, and whether or not I think it was necessary to get Sierra installed. Some of this was done by MaldOn. Thanks again BTW. :)




    There are 3 patches, but not sure I had these during install. Change EHC1 to EH01, Change EHC2 to EH02, Change XHCI to XHC.


    Under fixes there are several ticked. But I know I didn't do that. So probably not necessary for install.  Must have been done when MaldOn edited my DSDT.

     Here's what's checked. (page 1) FIxIPIC_0040 (page 2) FIX_RTC_20000, DeleteUnused_40000, FixRegions_10000000


    Drop Tables has SSDT>TableId>CpuPM, SSDT>TableId:Cpu0lst, DMAR. I think I set one of those after running Piker Alpha's SSDTprgen.sh to get my CPU speedsteps working. Not sure which one, and again this was done after install.



      npci=0x2000, -xcpm, dart=0, and kext-dev-mode are all checked. Think -xcpm is done after generating an SSDT. The others were used during install.



   Usb has inject and FixOwnership checked.


Kernel and Kext Patches

     IOPCIFamily    (find) 4881fb00 000040 (replace) 4881fb00 000080 (comment) X99 patch by BraumBear. I know the first version I found of this was wrong. Don't remember where I found it, but it was mentioned later in the thread, and had these values instead.


    AppleAHCIPort (find) 45787465 726e616c (replace) 496e7465 726e616c (comment) External Icons patch. This one probably isn't needed for install


    AppleUSBXHCIPCI (find) 83bd74ff ffff10 (replace) 83bd74ff ffff16 (comment) Change 15 Port Limit To 22 in XHCI 10.12(x99-series). I originally had a different version of this, but it was more generic. MaldOn changed this to the X99 version. Probably not necessary to install, but probably wouldn't hurt.


    com.apple.iokit.IOAHCIBlockStorage (find) 00415050 4c452053 534400 (replace) 00000000 00000000 000000 (comment) Enable TRIM for SSD. Won't be necessary for a traditional HDD, and possibly not for SSD's in Sierra. I really don't know, but figure it doesn't hurt since I am using an SSD.


Rt Variables and SMBIOS

   This is covered in corpnewt's guide above.



     Inject System ID and NvidiaWeb are checked. But Nvidia isn't useful until Sierra is installed along with the web drivers. I was actually using the disable Nvidia flag during install.




Now as far as kexts and drivers I have installed. I've put my kext's in the "other" folder. I believe the must have's are FakeSMC, lilu.kext, NvidiaGraphicsFixup, USBInjectAll, XHCI-x99-injector. I also have AppleALC, CodecCommander, IntelMausiEthernet, VoodooTSCSync.


Drivers64 has FSInject, VboxExt2-64.efi, and VboxExt4-64.efi. I've been trying to get clover to boot linux, so that's why the Ext drivers are installed. Not sure about the other. And also not sure why these aren't in the Drivers64UEFI folder. Maybe that's why clover doesn't see my linux disc? Something to look into. Thanks. :)


Drivers64UEFI has FSinject-64, HFSPlus, NTFS (for my windows drive), OSXAptioFix2Drv-free2000, OSXFatBinaryDrv-64, PartitionDxe-64, SMCHelper-64. Again not sure about FSInject. However OSXAptioFix2Drv-free-2000 is absolutely necessary, HFSPlus is also needed. And not sure about the rest.



Anyway let me know if that gets you any further down the road. I really need to put this in a guide format. But I've already kind of forgotten exactly how I did a thing or two. So maybe you can remind me. Also I do remember when I first got to the gray screen where the installer normally appears it didn't. I had to force it. Don't remember what was necessary, but it's a few post back. Once I got that, and made sure I was there for the second boot, it was all downhill.

Link to comment
Share on other sites

Appreciate you taking the time to reply.

Just going to print this off and will let you know how I get on over the next couple of days.

Managed to pick up an amd donor card if the quadro is still giving issues.

At least until I can install web drives.

6.1 worked for me too on 10.10 and 5.1 but with some issues if I remember.

Will update here as things progress.


  • Like 1
Link to comment
Share on other sites

A quick update ..... so far I've not been able to reach installer on either machine .

Started from scratch and created usb installer using linked method , trial and error with clover 4097 settings and kexts have yet to get to installer.

Worked from your settings for the 5810 but my cpu e5 2620v3 and graphics are obviously causing issues.

Need to test further ,must be something simple but so far have not come up with the right mix.

i'm on latest  dell bios , not sure if that has changed anything. Will try with minimal kexts and see if I can work it out.



Testing on t3610 with e5 1620v2 has been no better, think usb ports may be the issue here .

again further testing needed.

Link to comment
Share on other sites

Could be processor related. I would tend to think it would be more the graphics card. At least that's what it was for me. Have you made it to the gray screen?


And yes I used one of the front USB 2.0 ports, and not the front 3.0 port.

Link to comment
Share on other sites

Stayed away from USB 3.0 ports when testing.Did make it to grey screen once on one of the early efforts with the 5810 but was unresponsive .Last attempt on the t3610 apple progress bar gets to about 3/4 way then restricted sign comes up.Any time I tried with -x flag process bar would fail to begin.From your earlier posts seems to be a clover issue.Will be a couple of days before I can try again.Will keep you updated , hopefully better news next time.

Link to comment
Share on other sites

Making progress now...... after various combo's within clover and not reaching installer I took a chance.....

Created usb installer using the method you linked above then copied your efi folder contents to the clover usb .

Removed custom patches from clover except for iopci

Now this along with more trial and error eventually got me to the installer screen.

# I've been testing with an amd w7000 instead of the quadro so added flags > dart=0 / removed flags > -xcpm , nv_disable=1 

also had to check haswell e cpu .

After first pass of installer on reboot could not get to complete install.

MacOS screen would only give the option to reinstall from online image - not ideal .Or a message saying macos is not compatible with this system.

Tried various options and eventually did the following....

I  reformatted the test drive using msdos / mbr settings to make sure it was completely erased .

Repeated the step above then ...

replaced the fakecpu.id kext with latest version from rehabman's repo , replaced tscsync with 8 core version , disabled all of pikeralpha's edits within clover ,

dropped ssdt  from table , unchecked haswell E cpu .

At last managed to finalise install and get to desktop.


Amd w7000 has 4x display ports , so far the 2 I've tried are displaying correctly .

Will custom edit to have all 4 working ( did this previously - might even have a copy of the file I used  )

Without injecting Ati card resolution is correct with card identified as 7xxx , injecting ATI  card displays 7600 series , boot is smoother  too .

Items to do...

Custom ssdt , usb 3 , audio .Also need to test sleep / wake. Amd cards seem to have issues in sierra , darkwake flag may be needed.

My cpu is e5 2630L 8 core es .Been a while since I worked on cpu pm .Need to read up a little.

I've got audio working on a machine previously with help from rehabman so confident I can do something with that,


Wouldn't have got this far without your help so thanks for that .

I am trying to keep track of my work so i'll detail a little clearer when i can sort the last few things.

Link to comment
Share on other sites

  • 2 months later...

Just recently I've had a chance to test further with the T3610 since  high sierra became available.

Did you get anywhere with audio for the 5810 ?

Last time I patched applehda the layout and platform paths seemed more straightforward ?

Anyway , I used linux to extract codec from T3610  Codec named ALC3220 but vendor id is ALC280 .

I need to do the same with the 5810 to compare nodes and inputs / outputs but I they should be the same for each model.

Then worked out verb commands and disabled unused nodes.

And then figured out path maps for inputs and outputs.

I'll upload my files in case you want to try yourself

The next part..... XML file patching.

layout.xml  - should be straightforward with codec output from linux.

platforms.xml patching - this is where i'm stuck.

i've compared sample platforms.xml against one from el capitan and there seems be be additional nodes within the strings , not sure if they are connector related , signal related or something else ?

link below to an excellent guide i've used before but the sample files there are from an earlier OS X.

I remember doing this some years back for a laptop that had an unsupported codec so I know the principle does work .

Attaching my files here , will see if MaLd0n  can offer any help also.


link >http://forum.osxlatitude.com/index.php?/topic/1946-complete-applehda-patching-guide/



MaLd0n , 

Can you help with some guidance on editing platforms.xml with applehda to suit ALC280 ?

final codec verb alc280.rtf



Link to comment
Share on other sites

  • 9 months later...
  • 4 weeks later...
On ‎7‎/‎2‎/‎2018 at 2:58 PM, supertuxi said:

Can Anyone help me with High Sierra for this machine ?

Not running mac os at the moment ,skipped High Sierra waiting to try Mojave .

5810 is compatible and stable  , if you read thru posts from Matte82 above you should be at least able to get Sierra running .

Try that and an in place upgrade to HS.

If you can , try with a compatible amd card when installing , once up and running you can install nvidia web drivers and swap out graphics cards.

I 've done this with the t3610 before and it worked fine . And installed Yosemite then did in place upgrades to El Cap and then to Sierra.

I've also had 5810 up and running in Sierra so should be possible.

Can you post your system spec ,cpu and gpu . Most of everything else should be common across machines.


Link to comment
Share on other sites

Man. It’s been a while. Honesty I’ve not been using my Mac partition lately. I’ve had a lot going on in my personal life. And somewhere in there something broke. It won’t boot into Mac OS. I can see everything is still there. I just haven’t taken the time to fix it. It’s probably something in my clover set up. If I remember, there was an update for the os. That caused a setting in clover to be wrong. So I fixed it. And all was well. Then the next os update came and broke it again. I tried changing back whatever it was I changed the time before, but that didn’t work. I hope to try and get it sorted sometime soon. But there’s no definite time I have to work on it. Just when I get a chance. And I’ll be tempted to try the newest Mojave when I do get back to it. Anyway once that happens I’ll post what I figure out.

Link to comment
Share on other sites

  • 1 month later...

Okay. So if anyone is still reading this thread. I have MacOS working again.


TLDR: I blocked Lilu, NvidiaGraphicsFixup, AppleALC kexts and got to the desktop. Installed all Clover, Nvidia, and OS updates. Installed the newest version of Lilu and replaced NVidiaGraphicsFixup with Whatevergreen, deleted AppleALC, and it works again. Except for built in audio.


Long Version


I was troubleshooting and booting with safe mode and verbose mode. I noticed an error with NVidiaGraphicsFixup Lilu and AppleALC kexts. So I blocked those and it booted. But didn't recognize my video card.


So when it did boot, it showed my NVidia web driver didn't match the OS. But there were OS updates also. So I did the OS updates first. Then downloaded the NVidia Webdriver update. There were also clover and clover configurator updates. So I did those. Rebooted. No joy. It would KP before the progress bar got halfway. So I blocked those 3 kexts again and got to the the desktop.


Then I decided to try and narrow down the culprit by blocking one kext at a time. Once I blocked lilu, it would boot, but it would be using the built in video driver and not the web driver and the graphics were glitchy.


Did some looking around and there was a newer version of lilu. Installed it and rebooted. This time I got to the progress bar and it didn't appear to have a KP, but about halfway through my screen would go to sleep and never got to the desktop. So blocked lilu and rebooted to desktop.


Checked for a newer version of NVidiaGraphicsFixup. Found it has been rolled into the Whatevergreen project. So installed it and removed NVidiaGraphicsFixup and rebooted. I also removed AppleALC. Viola desktop and the webdriver working. So I am mostly a very happy camper. :)


This time however I noticed it didn't recognize any audio devices. I'm not certain it ever did. I know I tried to get it to. I would like to get this sorted and be done with this build. I bought a 2013 MacBook Retina. So I can use it to keep up to date with the current MacOS. I'll use this tower for music only and stick with 10.12 until I have to update. I may get another drive and play around with 10.13/.14 at some point. But overall I'm happy here. So if anyone has any ideas of where to start to try and get this sorted, let me know.


I did some research and saw there is a new version of AppleALC. I also reread this thread and think it only ever partially worked. So I thought I would try the newer version and see what happens. Well it boots to desktop but no audio, and even worse back to the built in video driver. So I deleted it and rebooted. I'm back to the desktop and it appears all but audio is working. So if someone is willing to take a look at my EFI I'll post it. In the mean time I'll keep on searching and see what I can find.


And as to making a guide. If I can get this sorted I think I can make a fairly easy to follow guide. In fact I may get a new HD and recreate the steps necessary. And then play around with 10.13/.14.


As always Thanks in advance


P.S. I'm also considering upgrading my video card to a Vega 64 and trying out the AMD side, and hopefully getting rid of the Nvidia head aches.

Edited by Matte82
Link to comment
Share on other sites

Good to hear you're up and running again.

Have not been running mac os myself but have been reading up lately with a view to giving Mojave a go shortly.

I replaced the 8 core cpu in my 5810 with a 1620v3 , so perhaps we can compare notes once I get going again.

I did some work on the audio previously but need to revisit that .

If you can upload your latest EFI it might give me a starting point for my install. And are you still using a custom Dsdt?

I'm running Quadro k4000 at the moment but still have a firepro  if the nvidia doesn't play nice.

I'll reply again when I have made a start.






Link to comment
Share on other sites

  • 4 weeks later...

 Matt , have you tried 10.14 yet?

I've been working on it on and off for the last few days (DELL Precision 5810 with E5 1620v3 )

Not quite there yet but very close.

I managed to install to a blank ssd but only  after a lot of trial and error.

I did get a usable clover usb that will boot the installer and even installed once but second boot is still an issue.

Apple logo loading to 100% then hangs and will boot to a grey screen .

Not managed to complete install fully yet.

Hangs at ' AppleACPICPU ' then boots to grey screen -cursor visible but nothing else

Same thru dvi output or hdmi .

If you haven't tried yet , I can upload my starter files .

If you pick up on this post you might let me know.Thanks.



Edited by Úll Mac
Link to comment
Share on other sites


10.14 Mojave confirmed working from clean install 

dell precision 5810 ; xeon e5 1620v3 , 16gb ddr4 2133mhz (4gbx4) ,

nvidia quadro K4000 - full acceleration / metal supported / correctly identified

built in audio working , boot drive apfs file system

MacPro 6,1 - Dell Bios A27 - Clover 4700


Screenshot 2018-10-14 at 23.32.35.png

Screenshot 2018-10-14 at 23.33.33.png

Screenshot 2018-10-14 at 23.34.24.png

Screenshot 2018-10-14 at 23.35.32.png

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...
On 10/15/2018 at 12:38 AM, Úll Mac said:


10.14 Mojave confirmed working from clean install 

dell precision 5810 ; xeon e5 1620v3 , 16gb ddr4 2133mhz (4gbx4) ,

nvidia quadro K4000 - full acceleration / metal supported / correctly identified

built in audio working , boot drive apfs file system

MacPro 6,1 - Dell Bios A27 - Clover 4700



Would you mind sharing your clover folder? I've been trying for a few days but can't get out of a kernel panic just as it starts booting, and I can't even see much because it starts dumping all the registers and don't get to see the exact point where it begins crashing (think it's ACPI related but not sure). Having a config known to work would make it much easier to debug (my cpu is a xeon 2670 and I'm thinking that could be the issue)

  • Like 1
Link to comment
Share on other sites

I've got mine mostly working based on a handful of guides, even though this certainly is not my first rodeo. 

Still booting via USB3 external HDD that does actually get loaded as USB3.

I've got the Haswell 'Xeon E5-1650 v3' 6 core processor, just having issues getting speedstep / power management working. 

No turbo and stuck at 3.49GHz, so it is unable to underclock or turbo to 3.8GHz. 


These load, so I'm not sure why there isn't any speedstep for the CPU, it is always reporting at 3.50GHz via intel power gadget.

Mac-Pro:~ ludacrisvp$ kextstat|grep -i 86Plat
   93    1 0xffffff7f82570000 0x17000    0x17000    com.apple.driver.X86PlatformPlugin (1.0.0) 72A2953B-57EA-3F24-971E-8E5E6ED9EC3B <92 69 30 13 11 7 6 5 4 3 1>
  142    1 0xffffff7f82587000 0x7000     0x7000     com.apple.driver.X86PlatformShim (1.0.0) A3D9B3B0-81BF-3303-B75B-0E545399CC96 <93 92 13 7 4 3>

Used frequencyvectors to add  "Mac-DB15BD556843C820.plist (iMac17,1)" to the MacPro6,1 plist. 

booting with / without -xpcm doesn't seem to make a difference.


Mac-Pro:~ ludacrisvp$ ./ssdtPRGen.sh -xcpm 1

ssdtPRGen.sh v0.9  Copyright (c) 2011-2012 by † RevoGirl
             v6.6  Copyright (c) 2013 by † Jeroen
             v21.5 Copyright (c) 2013-2018 by Pike R. Alpha
Bugs > https://github.com/Piker-Alpha/ssdtPRGen.sh/issues <

System information: Mac OS X 10.13.3 (17D47)
Brandstring: "Intel(R) Xeon(R) CPU E5-1650 v3 @ 3.50GHz"

Override value: (-x) XCPM mode, now set to: 1!

Version: models.cfg v171 / Haswell.cfg v151

Generating ssdt.dsl for a 'MacPro6,1' with board-id [Mac-F60DEB81FF30ACF6]
Haswell Core E5-1650 v3 processor [0x306F2] setup [0x0507]
With a maximum TDP of 140 Watt, as specified by Intel
Number logical CPU's: 12 (Core Frequency: 3500 MHz)
Number of Turbo States: 3 (3600-3800 MHz)
Number of P-States: 27 (1200-3800 MHz)
Injected C-States for CP00 (C1,C3,C6)
Injected C-States for CP01 (C1,C3,C6)
Warning: 'system-type' may be set improperly (1 instead of 3)
	 - Clover users should read https://clover-wiki.zetam.org/Configuration/ACPI#acpi_smartups
Compiling: ssdt_pr.dsl
Intel ACPI Component Architecture
ASL Optimizing Compiler version 20140926-64 [Nov  6 2014]
Copyright (c) 2000 - 2014 Intel Corporation

ASL Input:     /Users/ludacrisvp/Library/ssdtPRGen/ssdt.dsl - 360 lines, 10726 bytes, 97 keywords
AML Output:    /Users/ludacrisvp/Library/ssdtPRGen/ssdt.aml - 2760 bytes, 40 named objects, 57 executable opcodes

Compilation complete. 0 Errors, 0 Warnings, 0 Remarks, 0 Optimizations
Do you want to open ssdt.dsl (y/n)? n



Nvidia Quadro M2000 4Gb card seems to work fine with nvidia web drivers installed, it is reported as Metal supported so I should be able to move to Mojave, also I moved the card to slot-4 instead of slot-2, not sure if that has any bearing. 

For what it is worth, the GPU power management is working fine, I see the clock speeds change for GPU core and memory ... down to 135MHz core / 810MHz mem up to 1.15GHz core / 6.61GHz mem


For sound I can only get the front panel audio to work using AppleALC if i inject layout 3 or 4 via DSDT (4 being preferred as it detects headphones being plugged in and mic input works, however it has to be a dedicated mic)


Attached DSDT/SSDT that I'm using, I've setup my DSDT to handle 2 GPUs but I wasn't able to get them both working correctly, probably due to something related to using MP6,1 ID based on some things I've read saying it will disable the first GPU, so maybe I have to add a 3rd fake entry to get both running, which seems to be the most likely scenario. 



  • Like 1
Link to comment
Share on other sites

Hey guys. Sorry I haven’t been more responsive. I’ve had a lot going on, and am no pro anyway. I have bought a Vega 64 and it’s working great in w10 and Linux. Hopefully Monday I’ll have some time to try and get something sorted. I may consider updating to Mojave. I’ve got it on my MacBook and like it.

  • Like 1
Link to comment
Share on other sites

  • 6 months later...

Alright. I'm back. At least to talk about my 5810, which isn't working again. I think it was right after I had it going again I decided to get a vega 64. Don't remember if I ever got OSX to work with it, or it was already broken before I swapped cards.


Anyway, I'm trying to get back booted one more time, and then I'll probably upgraded to Mojave. I've had it on my MacBook Pro and like it, so why not. However I have some software authorized to that hard drive I'd like to deauthorize first.


As to what it's doing right not, not much. Seems to be having issues with the aptiofix thing. It's crashing right after boot. I've copied the clover backups from the install, and have tried copying those over, but it's not getting anywhere with any of them. I know there's been some BIOS updates. Has something in there maybe caused issues? I'm about to download and retry the last EFI I uploaded here and see what happens.


I promise this time if I get it working I'll make a proper guide, with all the little details I did, and my reasoning why. Then delete my hard drive and follow the steps, one by one, and make sure it's repeatable haha. Because this has been a solid machine. I just keep breaking it.

Edited by Matte82
Link to comment
Share on other sites

Just a quick update. Not sure what's going on, but I can't get it past the very beginning aptiofix error. I've tried all the aptio drivers in the newest version of clover, one at a time. Then I tried the ones from nick woodhams site. Still no go. Guess I may need to tear it down to the basics and start over. :-/.

Link to comment
Share on other sites


  • Create New...