Jump to content
About Just Joined group Read more... ×
Sign in to follow this  
Followers 0

Leopard install error launchctl.c:2325

5 posts in this topic

Recommended Posts

Hi, All.


I tried to post this question on another website (which I will leave unnamed), who apparently do not support OS X Leopard anymore. Thank goodness InsanelyMac does!

Anyway. I'm trying to build my first hackintosh, and as stated, on boot of the OS X Leopard installer, I hit the following error:

Bug: launchctl.c:2325 (23930):30: (dbfd = open(g_job_overrides_db_path, 0_RDONLY | O_EXLOCK | O_CREAT, S_IRUSR | S_IWUSR)) != -1​

(see attached photo. I apologize for low quality image. Best I could get :/)

Booting with -s -v doesn't help. I get to the single user BASH shell, type exit as instructed to boot the system, and hit another hang. I assume it is the same error in the background.

Booting without -v simply shows the apple logo and the spinning loading circle indefinitely.

I am booting on an IBM X41 tablet computer (Screen is dead, however. I have to use VGA.) I am using Chameleon 2.1 r2069, and my boot disk is a USB which was 'restored' on a MacOS Sierra computer to contain the OS X Leopard install DVD, as well as Chameleon.

Originally, I attempted with A legacy version of an unnamed bootloader, however hit the following:

boot0: GPT
boot0: testing
boot0: testing
boot0: testing
boot0: error​

Which lead me to change bootloaders to Chameleon.

I had to delete all graphics kexts to get this far, and I have to use a USB keyboard, because the built in one doesn't work past chameleon (I.e. for single user mode).

As far as I'm aware, the BIOS is set up correctly, and the HDD is completely empty. The USB I'm booting with is on an MBR partition scheme, as GUID wouldn't work.

I also tried the Voodoo patched Kernel. No joy.

Finally, I have also attempted the install with OS X Tiger (same method for boot disk). That OS only manages to get as far as Darwin, before crashing.

Specs aren't pretty, but should be able to run Tiger and / or Leopard just fine:

Intel Pentium M LV 758 @ 1.2GHz
512MB DDR2 Ram
1.8" 60GB HDD @ 4200RPM
Intel PRO 2200BG WiFi​
Unlike the reply on the other unnamed website suggests, I know that WiFi and Graphics are both compatible if you poke around enough, because of the following YouTube video, however my VGA prediciment could break the graphics:

Hopefully someone can help with my ancient OS install :/
Hopes aren't high, but anyway.

Thanks in advance.


Share this post

Link to post
Share on other sites

Leopard is most definitely the best and latest version you can hope for. However, this is a really low-spec (not to say totally obsolete) laptop and it's highly likely to run like an old dog with that CPU, RAM and HDD (even latest Win XP is bound to run poorly on this). Ideally, you should consider upgrading to 1.5GB RAM (I think it's the X41 max.) + 5400rpm HDD (if that exists for 1.8" models). CPU is however soldered to the motherboard so you can't upgrade or overclock.


You may want to give iDeneb 10.5.x a go to see if this X41 can run Leopard. You'd have to experiment with options though, it's unlikely to be a straight boot to success. Not in my habit to recommend a distro but this is what I started with on my 2005 Dell Inspiron 6000 (Pentium M + GMA900 grahics) before switching to vanilla installations after gathering some experience and knowledge.


Expect no support for the mini-PCI Intel wireless card (OS X has never supported Intel wireless cards). You'll probably have to replace it; for instance, by a supported Broadcom model (e.g.: BCM4318-based cards such as DW1470).


Bottom line really is: is this worth any effort, especially on such an obsolete and broken laptop?

Share this post

Link to post
Share on other sites

Bottom line really is: is this worth any effort, especially on such an obsolete and broken laptop?


Point taken.

I was planning on upgrading the RAM. Wasn't aware that the Intel WiFi card needed replacing.


I'm really only messing around with this old machine, to see what I can do. Believe it or not, I did get Vista running rather smoothly on this thing, so it has a bit of life :/


I'll take your advice and check out iDeneb. Do you know of anywhere I can get it, or can't you say?



Share this post

Link to post
Share on other sites

I did a ton of searching, and fount copies of 1.5 and 1.5.1, however every single file I attempted to download (all the way back to 1.2) had either a broken link or was a torrent that hadn't been seeded for 10 thousand years.


Anyway, I've upgraded the RAM to 1GB, and installed windows 7 on it. If iDeneb is the last hope, and it can't be found, then win7 is the best I can hope for.


Thanks for your help. I'll keep looking for an iDeneb *.iso, however somehow I doubt finding anything.

Share this post

Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By Schlachtbank
      Hi. I need help if possible.
      I tried installing Big Sur on my Hackintosh with OC and Catalina working. Every time I try to boot it I receive a kernel panic relative to ACPI. The strange thing is that this kernel panic occurs only with Big Sur and High Sierra. Every other macOS version boots (I tried from 10.9 to 11).
      My build is:
      Motherboard: Gigabyte X79-UD3 CPU: Intel Core I7 4820K GPU: XFX Radeon RX570 I'm attaching the kernel panic and my EFI configuration (I still need to map the USBs 'cause I switched to OpenCore yesterday).
      PS. In the OC folder there's not a resources folder because I deleted it to upload it
      Kernel panic Big Sur.rtf
      OC configuration.zip
    • By MaLd0n
      -Donations with PayPal
      --Original Topic--

      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
      --Clover Folder--
      --OpenCore Folder--
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--

      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By utilman
      Hello 2 everybody

      Can someone give me helpfully links to an installation of Catalina on a Lenovo Thinkpad T510.

      Or what is the latest currently working macOS for an Lenovo T510 with an i5 and integrated GPU (Intel)?

      Because the Links in the old threads are not working anymore.

      Thank you very much
    • By jrbros1
      Hi there,
      So I have my Windows computer, used a USB with Clover setup to boot into Mojave OS that I installed on the SD card in the computer. The world was a great place and all was well!

      Then I did the steps to partition the pc system to now include the additional drive that I would put Clover on. Here's where I messed up: Instead of directly copying over the full Clover folder into the EFI folder of the new drive (which just had the Boot & Microsoft folders in it), I replaced the EFI's boot folder with Clover's boot folder. So the EFI folder now contains a Microsoft folder, a Clover folder, and Clover's Boot folder only.

      Now, I only can access the Clover boot up menu, the macOS, but no Windows at all. Even if I go into BIOS and pick Windows Boot Manager or Partition 1 for the start up, I get a black screen for both. I can still access the macOS as well as Shell, but I don't know what that does other than displaying all of the yellow text fly by..

      Is there a kind soul out there that can help me get Windows back to boot? Keep in mind I'm a bit of a newbie here so laying out the common-sense steps would be helpful!

      Thank you in advance!
    • By Higgie
      Hi all
      I've got a fully working install of Catalina 10.15.5 using OpenCore 0.5.9 and I've managed to get everything working perfectly. It's my first PC Build ever (Let alone Hackintosh) so I'm pretty pleased that I've managed to get everything up and running so far, including Thunderbolt 3 (with hotplug), Sidecar, onboard HDMI Audio, Wifi/BT pairing across both OS (Windows 10 and MacOS). The only thing that now bugs me is the time taken to boot from the Opencore picker to my login screen. It's not super slow by any means, but with my specs I believe it should be faster. Here is what I'm running:
      Intel Core i7 10700K
      Gigabyte Z490 Vision D
      Noctua NH-D15S
      Corsair LPX 3000MHz 32GB RAM (2x16GB)
      Adata XPG SX8200 1TB NVMe SSD (MacOS)
      Adata XPG SX8200 1TB NVMe SSD (Windows 10)
      Crucial BX200 1TB SSD (Storage)
      Crucial MX500 2TB SSD (Storage)
      Asus 8GB Dual Arez RX580
      Corsair RM650
      Fenvi HB1200
      Windows boot is pretty sharp - Usually under 10secs. MacOS on the other hand usually is in the region of ~70secs. When I first installed Catalina it would boot super quick, but it's gotten more and more sluggish over the last few weeks. Is there anything I can do to speed it up? I can attach my EFI if needed.