Jump to content
InsanelyMac Forum
Mikeas

Sin sonido ALC1150, ayuda, por favor.

Recommended Posts

Estoy en una instalación limpia, sin haber intentado ninguna solución, excepto la de esta página. En Guías, Usar Audio Nativo con AppleALC, etc. AppleALC.kext 1.0.18 versión, /EFI/Clover/kexts/Other. Solo eso. Antes había intentado otras pero para ir limpio borré mi disco y volví a instalar Sierra.

 

MOBO Gigabyte G1 Sniper B6 B85Chipset

GPU GTX 970

Audio Parlantes del monitor, Codec de la MOBO ALC1150

CPU i5 4590

 

Device for Sound Output

 

IORegister HDEF, 1B

http://imgur.com/dULC1zG

http://imgur.com/CcpLDzO

 

Config.plist

 

Por favor, ayuda. Es lo único que falta para poder terminar con esta instalación.

 

Edit1. Para conectar mi PC al monitor tengo HDMI–HDMI ó DVI–HDMI. Adicional a esto tengo los cables de audio de la MOBO. Con que logre audio con cualquiera de ellos, estaría feliz.

Edited by Mikeas

Share this post


Link to post
Share on other sites
Advertisement

solo utiliza la herramienta de audio de micky1979

http://www.insanelymac.com/forum/files/file/496-applehda-patcher/

que tiene soporte para ese codec de audio 

 

segun tengo entendido , esa herramienta parchea el apple hda kext que esta en system/library/extensions

por lo que no tienes que hacer nada en clover/kexts/10.12

solo asegúrate de no tener voodoohda instalado 

ni en clover / 10.12 / kexts. ni en system/library/extensions

ya que ambos kexts no pueden ser instalados a la misma vez ya que crean conflicto uno con otro

a menos que uses apple hda disabler

 

el apple hda kext es mejor que el voodoo hda ya que tiene mejor calidad de sonido

el voodoo hda se usa cuando uno no tiene soporte para el codec de audio

 

 

a ultima hora sino puedes hacer funcionar el audio con apple hda kext pues entonces usa el voodoohda 

descarga la ultima version que es la 2.8.9 y instalala

 

https://sourceforge.net/projects/voodoohda/files/

 

reinicia el sistema y listo

suerte

 

Este Patcher, solo crea o parcha ciertos archivos, no? Y los coloca en el escritorio para que yo los use según crea conveniente, es correcto?

 

O solo debo darle doble click, seleccionar Desktop y listo?

De ser la primera realmente no explica nada más. Definitivamente no es muy amigable con usuarios nuevos. Ya que asumen que sé donde irían todos esos archivos :P.

Gracias igual.

 

Ahora estoy usando un parlante externo, conectado mediante los cables de audio (MOBO a parlante externo) y sí consigo audio. Pero cuando ese cable lo conecto al monitor, no consigo audio. Para mi GPU estoy usando DVI-HDMI para video.

Share this post


Link to post
Share on other sites

si quieres yo lo parcheo para tu codec y te lo subo ya parchado 

cuando es apple hda siempre va en system/library/extensions

solo lo instalas usando kext wizard

lo que pasa es que el creador del app, supone que ya la persona tiene aunque sea conocimiento mínimo

que es la installation del kext usando kext wizard a system/library/extensions

 

ahora si usas clover y voodoohda entonces pones el voodoohda en clover/ kext y la version de tu sistema

igual si usas chameleon o enoch dependiendo de la version de tu sistema

pues también puedes poner voodoohda en system/library/extensions

 

el app es super facil dependiendo si tienes desktop o laptop

 

en tu caso seria desktop y buscas tu codec y lo parcheas

osea el alc1150 que de casualidad es el primero que sale en la lista

 

yo ya tengo mi versiones de audio ya parchadas pero si el app no te parchea el applehda directamente en S/L/E

y te crea la version parchada en el escritorio para que tu mismo la instales

pues verdad no se cual es el problema

 

si lo que quieres es audio en el HDMI de la tarjeta de video

pues te recomiendo el voodoohda

ya que el apple hda solo te va a var audio a el audio output del board

 

de casualidad yo tengo 2 Nvidia 970 overclock edition y tengo audio en hdmi y display port

creo que uno de los dvi tira audio pero no recuerdo si es el dvi-i o el dvi-d

 

si necesitas ayuda solo dilo y yo te preparo el audio ya parchado y te subo el kext wizard para que lo instales y listo

pero yo solo te dije porque pensé que tu sabias que hacer

 

ademas te di varias opciones dependiendo lo que tu decidieras

bueno suerte 

lo que decidas hacer me avisas

 

Hola, gracias. Sí por favor puedes ayudarme a parchearlo tú. Cómo haríamos? Necesito enviarte algo? Mi AppleHDA?

 

https://drive.google.com/open?id=0Bz5Ceen9PRhoVTN4TXlza21KOEE

 

Ahora mismo tengo instalado, como dije, solo lo de AppleALC.kext. Y mediante [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], el kext de Realtek ALC1150. Interfiere en algo? De ser así puedo eliminarlo el kext y de mi config.plist. Espero tu respuesta de eso.

 

Solo esas 2 modificaciones he hecho respecto al audio. Ninguna otra.

Cuanto estuve en /System/Library/Extensions/ pude notar que hay varios AMD ....kext.

AMD2400Controller.kext

AMD2600Controller.kext

AMDFramebuffer.kext

AMDRadeonVADriver.bundle

AMDRadeonX3000.kext

Entre otros...

Yo no tengo nada de AMD. Hay algún error en eso o perjudica en algo? Yo realicé mi instalación de 10.12.3 directamente desde el Apple Store, ya estando en 10.12.0 que descargue de una web (quizá ahí sea donde vino los kexts de AMD?)

 

Espero tu respuesta, por favor. Y gracias por la ayuda.

Share this post


Link to post
Share on other sites

aqui esta

http://www52.zippyshare.com/v/MDoUpHIY/file.html

espero te funcione, vuelvo mas tarde a ver cual fue el resultado o si no entiendes algo

suerte

 

Hola, tus instrucciones ayudaron muchísimo! :D Las imágenes.

Ahora tengo audio vía HDMI. Aunque no puedo controlarlo el Volumen vía Sistema. Como solía hacerse cuando tenía mi parlante externo. Aún así esto es muchísimo mejor que tener mi parlante al costado. 

 

Muchas gracias! :D

 

Hay alguna manera de solucionar lo del Volumen? Por cierto, tuve que buscar el VoodooHDA.kext 2.8.9 por Google e instalarlo. Lo busque ya que hice lo que dijiste pero salía error en Preferencias/VoodooController. Así que supuse que faltaba el kext y si era eso. Gracias :)

Share this post


Link to post
Share on other sites

http://imgur.com/utRvNc5

 

Hola, gracias por todo :). Si ves la imagen sí pude hacer lo que me dijiste pero no consigo audio. 

 

He notado que cuando salga a Preferences, y vuelvo a ingresar a VoodooHDA configuraciones, todo continúa igual. Pero si cierro Preferences y vuelvo a abrirlo e ingreso a VoodooHDA, nuevamente está en la tarjeta de video.

 

http://imgur.com/r8957lT

 

El kext de VoodooHDA solo lo puse en Clover/kexts/10.12. No en otro lado.

 

PD. Sí puedo conseguir audio mediante HDMI o DVI. Así que de todas maneras audio ya consigo, muy agradecido por tu ayuda.

Share this post


Link to post
Share on other sites

Hola yo lo tengo con el kext de la guia que has puesto en clover/kext/10.12 luego tambien mi layout es el 1 ,averigua cual es el tuyo y modifica el config.plist ,a mi me funciona el integrado con ese kext.

 

un saludo.

Share this post


Link to post
Share on other sites

Utilice DSDT o inyectar por Clover id 1 o 7

Device (HDEF)
            {
                Name (_ADR, 0x001B0000)  // _ADR: Address
                Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
                {
                    If (LEqual (Arg2, Zero))
                    {
                        Return (Buffer (One)
                        {
                             0x03                                           
                        })
                    }

                    Return (Package (0x10)
                    {
                        "AAPL,slot-name", 
                        "Built In", 
                        "name", 
                        "Realtek Audio Controller", 
                        "model", 
                        Buffer (0x21)
                        {
                            "Realtek ALC1150 Audio Controller"
                        }, 

                        "device_type", 
                        Buffer (0x11)
                        {
                            "Audio Controller"
                        }, 

                        "layout-id", 
                        Buffer (0x04)
                        {
                             0x07, 0x00, 0x00, 0x00                         
                        }, 

                        "MaximumBootBeepVolume", 
                        Buffer (One)
                        {
                             0x01                                           
                        }, 

                        "PinConfigurations", 
                        Buffer (Zero) {}, 
                        "hda-gfx", 
                        Buffer (0x0A)
                        {
                            "onboard-1"
                        }
                    })
                }
            }

+ AppleALC en Clover/Kexts/10.xx

AppleALC.kext 2.zip

AppleHDA sin modificación

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By LarryKu
      Hi everyone,
      I am new, I hope I am posting in the correct forum.
      My specs:
      Processor: Core i5 6500 Skylake 3.2ghz
      Mobo: Gigabyte h170-d3h
      M2SSD: WD Black 256gb PCIe (Mac OSx)
      SSD: Samsung 860 Evo (WIndows 10)
      HDD: WD Blue 1TB
      GPU: Radeon RX 480
      Monitor: BenQ RL2460 24"


      I was able to install High Sierra on a new m2 drive, that I added to the above configuration with windows 10 already installed.
      I had a few issues during install, including the monitor turning off at boot screen.

      Unfortunately, this persists even now. It turns off at about 60% of the progress bar, and to turn it on again I have to unplug/plug back my hdmi.
      Additionally, while all of the usb ports worked during install and while running it out of the clover I had on the usb stick, only the rear ones appear to work now.
      The audio doesn't work either, though I added the correct patch according to my mobo

      Lastly, my other drives are not recognized in the bios anymore. They run fine from boot override but they don't show up in the boot priority (while multiple entries of mac OS do, and they seem to increase in number at every reboot)

      Thanks in advance for the help
    • By ITzTravelInTime
      KX AUDIO DRIVER MOD
       
      Hi guys i am a small developer, i really like to use my sound blaster cards on my machines and i love also coding, so when i find the source code for the kx audio driver on git hub and then Eugene, the creator of kx audio driver decided to no longer maintain the project, i decided to start working on a mod of this driver. 
       
      With my mod, created starting from the sources of the last version of kx audio driver, and also by using apple developer documentation for pci and audio drivers as reference, i am working to achieve 2 things mainly: get all the cards supported by the driver to work with all the recent versions os macOS and add support for other cards that are not officially supported by the driver that works or could, but needs to be more properly supported.
       
      This driver is made to support cards based on the E-mu 10k1, 10k2 and similars (like what is used by audigy rx and audigy 4 cards).
       
      Supported cards are:
       
       - most of the sound blaster live!, live! 5.1 and live! 5.1 digital series
       - sound blaster 512
       - sound blaster 256
       - other creative and e-mu sound cards based on the 10k1 chip (cards with the ES1370/ES1371/ES1372/ES1373 chips are not supported)
       - sound blaster Audigy series (1 st gen)
       - sound blaster Audigy 2  and audigy 2 zs series
       - E-MU cards based on the 10k2 sound chip
       - Some Audigy 4 cards (SB0610 only) and the audigy 4 pro
       - Sound blaster Audigy RX (sb0155)
       - other creative and e-mu cards based on the (10k2, 10k2,5 and CA10300 based cards)
       
      NOT supported cards:
       
       - Any ISA Sound card
       - ES1370/ES1371/ES1372/ES1373 based sound cards
       - CMI8738/CMI8788 based cards
       - Any CA0106 based card and cards with similar architectures (like sound blaster live! 24 bit, sound blaster audigy SE SB0570, audigy LS and similars, but audigy SA is supported)
       - Any sound blaster x-fi (some of them works on macOS using a modified version of voodoo hda)
       - Any sound blaster recon3D
       - Any sound blaster Z/ZS/ZX and similar series
       - Any sound blaster AE5 series
       
      In the time being the things i have modded or added with this mod are:
       
      - increased the simple buffer frames number with different values for emu10k1 based cards and emu10k2 based cards (including recent audigy 4 and rx) to reduce and all the audio cracking issues and possibly fixing all of them on a lot of cards
       
      - added a more proper support for the pci express sound blaster audigy rx (which basically is an audigy 4 with a pcie bridge chip) 
       
      - added more fancy names for the cards in the settings and other menus (so the name will be, for example, SB live! 5.1 SB0060 instead of kx SB0060 [e880] witch was shown in the original driver)
       
      - added support to sample rate chaning and added lots of sample rates (from 8 khz to 176,4 khz) to accomodate any possible usecase (note that 10k1 sound cards are limited up to 48khz sample rate, and 10k2 based cards for now are limited up to 176,4 khz and because of issues getting 192 khz to work, for now the driver goes up to 176,4 khz for supported cards) 
       
      - added boot args to manage the driver:
       
      Boot args to use with the kx audio driver mod: -kx_disable or -kxdisable or -kxoff This will prevent the driver from doing any initialization work, so the driver is basically disabled, use it to boot your ssytem in case the driver is giving you issues and kernel panics while you are trying to boot/using your system, so you are able to remove this driver or replace it with another version of it or to do some truble shooting. -kx_debug or -kxdebug or -kxspec Will show more debug info about the card, mainly the i/o port address and the kind of bus that it uses -kx_exp_deb or -kx_beta or -kxbeta Will enable experimental and probably not working or unstable features like showing inputs for the card or 192 khz sampling rate, use it only for testing and debug purposes, this may likely cause instability and problems in the everyday usage! Use it at your own risk! -kx_original or -kxoriginal This will basically turn off almost all the mods of this mod, so the driver will come to work as it was before modding it, this can be usefoul as a "safe mode" like feture to have a working driver in case of problems with features of the mod, so using this means no crsking issues improvements, only 48 khz sample rate and only features of the non-modded kx audio driver for mac os x  
      - created a script file to use with the driver for debug and also installer replacement, it can be also used to unload and reload, replacement of the driver without rebooting
       
      What i'd like to implement but i don't know how to do:
       
       - I'd like mainly to add a more proper support to the pci bridge chip of the audigy rx,
       
       - have audio inputs working,
       
       - fix the support when using more than one card, to get all the cards shown in the settings and other menus,
       
       - have the gameport/gameport midi port of older cards to be used in mac os as a midi in/out
       
      If other developers would like to join and help me, you can, and also an hand from other people with testing and feedback will be nice.
       
      link for the kext only (if you have clover put it in [your clover efi folder]/clover/kexts/[your macOS version]/ so it will not be deleted when updating macOS):
               - download from the downloads section:          kX Audio Driver Mod by ITzTravelInTime 1.01                                                                                    - external download:                                      https://dl.dropboxus...Driver.kext.zip   link for the installer pack (the best way to install it, but you have to reinstall it when you upgrade macOS, remeber to fix kext permitions and rebuild the kernelcache if you want to remove the kext from it's install directory without using the unistall feature of the provvided script):              - download:                                                   https://dl.dropboxus...aller pack.zip   Source code from Git Hub:          -  github repo:                                               https://github.com/ITzTravelInTime/kx-audio-driver   NOTE: Some system because of some problems with the HPET may need to use FixHPET in clover and to install the kext in /System/Library/Extensions  






    • By ITzTravelInTime
      This driver is a mod of the popular kx audio driver for mac os x, the project goal is to still maintaining it for the future releases of mac os and to include as much cards as possible and to get all the features of the cards to work.
       
      Currently the only features not supported are audio inputs and integrated midi and synth capabilitues of the cards, and some minor things like creative remote controllers or software controlled volume gears on creative external drives and bays)
       
      It supports most the sound blaster live! series cards, the sound blaster PCI 512, most of the audigy (emu 10k2 based) series, audigy 1, audigy 2, audigy 2 zs, audigy 4 (SB0610), audigy 4 pro, audigy 5 and audigy rx (sb1550) and some e-mu edsp audio cards with all the recent versions of mac os, tested to work with mac os yosemite, el capitan, sierra and high sierra on intel based machines from socket 775 to 1151 (including enthusiast platforms like x58, x79, x99, x299) and also confirmed to work on mac pros.
       
      reference topic:
       
      Kx audio driver mod [sound blaster live!, audigy 1/2/4/RX emu edsp]
    • By sect0r5
      Hello guys I need help for tuning my system for better working possibilities.
       
       
      What works:
      Sleep/Wake Audio Ethernet App Store  
      Problems:
       
      CS:GO not working (other Steam games are OK) Bad GPU performance 40 fps on OSX Cinebench vs 85 fps on Windows Cinebench Big audio latency when using line input      //edit : problem is gone  Slow start of Viber Desktop, OBS and some web pages  //edit : OBS is slow on native MacBook too Sometime random mouse freezings            Huge lags on latest NVidiaWeb drivers(158, 159) Sometimes can't awake and stuck on black screen after restart   //edit : now is alright. magic! Sometimes sound start crackling when watching online video     //edit  : magically gone edit : she come again  
      It's happens on a both Kernel's :
       
      Shanee 13.3.3
      Bronya
       
      Clover 4392
       
      What info i can provide for better results?
       
      Thanks!
      With best regards, Stan.
      Send me stanMacs-Pro.zip
    • By Antonio95
      Buonasera a tutti, ho installato con successo macOS High Sierra 10.13 su un notebook Toshiba C660 con le seguenti caratteristiche:
       
      Intel Core i5 2410M Ram 4 GB Chipset Intel HM65 Wi-Fi + BT Atheros AR5B195 (AR9285+ AR3011 Combo) Geforce NVIDIA 315M 1024MB Audio Realtek ALC269 Funziona più o meno tutto, o meglio funzionava poiché ho effettuato l'aggiornamento da macOS 10.3 a macOS 10.3.3 e non ha più funzionato l'audio. Fino alla versione 10.3 ero riuscito a farlo funzionare grazie ad AppleALC.kext cui dipende da Lilu.kext. Ovviamente entrambi i Kext sono aggiornati alle ultime versioni disponibili, ed inutile dire che ho provato più volte a reinstallarli. Si trovano sia in S/L/E che nella partizione EFI dedicata di Clover. Prima durante il boot in verbose vedevo qualcosa come "Sound assertion in AppleHDAController at line 451", cosa che non vedo più dopo l'aggiornamento. Una volta avviato, l'icona dell'audio è praticamente grigia, mentre dalle impostazioni dice "Non è stato trovato nessun dispositivo di uscita".
       
      Ringrazio chiunque voglia aiutarmi.
×