Jump to content
Mikeas

Sin sonido ALC1150, ayuda, por favor.

7 posts in this topic

Recommended Posts

Estoy en una instalación limpia, sin haber intentado ninguna solución, excepto la de esta página. En Guías, Usar Audio Nativo con AppleALC, etc. AppleALC.kext 1.0.18 versión, /EFI/Clover/kexts/Other. Solo eso. Antes había intentado otras pero para ir limpio borré mi disco y volví a instalar Sierra.

 

MOBO Gigabyte G1 Sniper B6 B85Chipset

GPU GTX 970

Audio Parlantes del monitor, Codec de la MOBO ALC1150

CPU i5 4590

 

Device for Sound Output

 

IORegister HDEF, 1B

http://imgur.com/dULC1zG

http://imgur.com/CcpLDzO

 

Config.plist

 

Por favor, ayuda. Es lo único que falta para poder terminar con esta instalación.

 

Edit1. Para conectar mi PC al monitor tengo HDMI–HDMI ó DVI–HDMI. Adicional a esto tengo los cables de audio de la MOBO. Con que logre audio con cualquiera de ellos, estaría feliz.

Edited by Mikeas

Share this post


Link to post
Share on other sites
Advertisement

solo utiliza la herramienta de audio de micky1979

http://www.insanelymac.com/forum/files/file/496-applehda-patcher/

que tiene soporte para ese codec de audio 

 

segun tengo entendido , esa herramienta parchea el apple hda kext que esta en system/library/extensions

por lo que no tienes que hacer nada en clover/kexts/10.12

solo asegúrate de no tener voodoohda instalado 

ni en clover / 10.12 / kexts. ni en system/library/extensions

ya que ambos kexts no pueden ser instalados a la misma vez ya que crean conflicto uno con otro

a menos que uses apple hda disabler

 

el apple hda kext es mejor que el voodoo hda ya que tiene mejor calidad de sonido

el voodoo hda se usa cuando uno no tiene soporte para el codec de audio

 

 

a ultima hora sino puedes hacer funcionar el audio con apple hda kext pues entonces usa el voodoohda 

descarga la ultima version que es la 2.8.9 y instalala

 

https://sourceforge.net/projects/voodoohda/files/

 

reinicia el sistema y listo

suerte

 

Este Patcher, solo crea o parcha ciertos archivos, no? Y los coloca en el escritorio para que yo los use según crea conveniente, es correcto?

 

O solo debo darle doble click, seleccionar Desktop y listo?

De ser la primera realmente no explica nada más. Definitivamente no es muy amigable con usuarios nuevos. Ya que asumen que sé donde irían todos esos archivos :P.

Gracias igual.

 

Ahora estoy usando un parlante externo, conectado mediante los cables de audio (MOBO a parlante externo) y sí consigo audio. Pero cuando ese cable lo conecto al monitor, no consigo audio. Para mi GPU estoy usando DVI-HDMI para video.

Share this post


Link to post
Share on other sites

si quieres yo lo parcheo para tu codec y te lo subo ya parchado 

cuando es apple hda siempre va en system/library/extensions

solo lo instalas usando kext wizard

lo que pasa es que el creador del app, supone que ya la persona tiene aunque sea conocimiento mínimo

que es la installation del kext usando kext wizard a system/library/extensions

 

ahora si usas clover y voodoohda entonces pones el voodoohda en clover/ kext y la version de tu sistema

igual si usas chameleon o enoch dependiendo de la version de tu sistema

pues también puedes poner voodoohda en system/library/extensions

 

el app es super facil dependiendo si tienes desktop o laptop

 

en tu caso seria desktop y buscas tu codec y lo parcheas

osea el alc1150 que de casualidad es el primero que sale en la lista

 

yo ya tengo mi versiones de audio ya parchadas pero si el app no te parchea el applehda directamente en S/L/E

y te crea la version parchada en el escritorio para que tu mismo la instales

pues verdad no se cual es el problema

 

si lo que quieres es audio en el HDMI de la tarjeta de video

pues te recomiendo el voodoohda

ya que el apple hda solo te va a var audio a el audio output del board

 

de casualidad yo tengo 2 Nvidia 970 overclock edition y tengo audio en hdmi y display port

creo que uno de los dvi tira audio pero no recuerdo si es el dvi-i o el dvi-d

 

si necesitas ayuda solo dilo y yo te preparo el audio ya parchado y te subo el kext wizard para que lo instales y listo

pero yo solo te dije porque pensé que tu sabias que hacer

 

ademas te di varias opciones dependiendo lo que tu decidieras

bueno suerte 

lo que decidas hacer me avisas

 

Hola, gracias. Sí por favor puedes ayudarme a parchearlo tú. Cómo haríamos? Necesito enviarte algo? Mi AppleHDA?

 

https://drive.google.com/open?id=0Bz5Ceen9PRhoVTN4TXlza21KOEE

 

Ahora mismo tengo instalado, como dije, solo lo de AppleALC.kext. Y mediante [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], el kext de Realtek ALC1150. Interfiere en algo? De ser así puedo eliminarlo el kext y de mi config.plist. Espero tu respuesta de eso.

 

Solo esas 2 modificaciones he hecho respecto al audio. Ninguna otra.

Cuanto estuve en /System/Library/Extensions/ pude notar que hay varios AMD ....kext.

AMD2400Controller.kext

AMD2600Controller.kext

AMDFramebuffer.kext

AMDRadeonVADriver.bundle

AMDRadeonX3000.kext

Entre otros...

Yo no tengo nada de AMD. Hay algún error en eso o perjudica en algo? Yo realicé mi instalación de 10.12.3 directamente desde el Apple Store, ya estando en 10.12.0 que descargue de una web (quizá ahí sea donde vino los kexts de AMD?)

 

Espero tu respuesta, por favor. Y gracias por la ayuda.

Share this post


Link to post
Share on other sites

aqui esta

http://www52.zippyshare.com/v/MDoUpHIY/file.html

espero te funcione, vuelvo mas tarde a ver cual fue el resultado o si no entiendes algo

suerte

 

Hola, tus instrucciones ayudaron muchísimo! :D Las imágenes.

Ahora tengo audio vía HDMI. Aunque no puedo controlarlo el Volumen vía Sistema. Como solía hacerse cuando tenía mi parlante externo. Aún así esto es muchísimo mejor que tener mi parlante al costado. 

 

Muchas gracias! :D

 

Hay alguna manera de solucionar lo del Volumen? Por cierto, tuve que buscar el VoodooHDA.kext 2.8.9 por Google e instalarlo. Lo busque ya que hice lo que dijiste pero salía error en Preferencias/VoodooController. Así que supuse que faltaba el kext y si era eso. Gracias :)

Share this post


Link to post
Share on other sites

http://imgur.com/utRvNc5

 

Hola, gracias por todo :). Si ves la imagen sí pude hacer lo que me dijiste pero no consigo audio. 

 

He notado que cuando salga a Preferences, y vuelvo a ingresar a VoodooHDA configuraciones, todo continúa igual. Pero si cierro Preferences y vuelvo a abrirlo e ingreso a VoodooHDA, nuevamente está en la tarjeta de video.

 

http://imgur.com/r8957lT

 

El kext de VoodooHDA solo lo puse en Clover/kexts/10.12. No en otro lado.

 

PD. Sí puedo conseguir audio mediante HDMI o DVI. Así que de todas maneras audio ya consigo, muy agradecido por tu ayuda.

Share this post


Link to post
Share on other sites

Hola yo lo tengo con el kext de la guia que has puesto en clover/kext/10.12 luego tambien mi layout es el 1 ,averigua cual es el tuyo y modifica el config.plist ,a mi me funciona el integrado con ese kext.

 

un saludo.

Share this post


Link to post
Share on other sites

Utilice DSDT o inyectar por Clover id 1 o 7

Device (HDEF)
            {
                Name (_ADR, 0x001B0000)  // _ADR: Address
                Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
                {
                    If (LEqual (Arg2, Zero))
                    {
                        Return (Buffer (One)
                        {
                             0x03                                           
                        })
                    }

                    Return (Package (0x10)
                    {
                        "AAPL,slot-name", 
                        "Built In", 
                        "name", 
                        "Realtek Audio Controller", 
                        "model", 
                        Buffer (0x21)
                        {
                            "Realtek ALC1150 Audio Controller"
                        }, 

                        "device_type", 
                        Buffer (0x11)
                        {
                            "Audio Controller"
                        }, 

                        "layout-id", 
                        Buffer (0x04)
                        {
                             0x07, 0x00, 0x00, 0x00                         
                        }, 

                        "MaximumBootBeepVolume", 
                        Buffer (One)
                        {
                             0x01                                           
                        }, 

                        "PinConfigurations", 
                        Buffer (Zero) {}, 
                        "hda-gfx", 
                        Buffer (0x0A)
                        {
                            "onboard-1"
                        }
                    })
                }
            }

+ AppleALC en Clover/Kexts/10.xx

AppleALC.kext 2.zip

AppleHDA sin modificación

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By tom666
      osx10.14
      i5-4250u
      i have added "irq hdef hdau  mutex osys10" patch
      and install acpibettery on clover ,but the battery management still donot work

      my audio card is alc269vc ,i try to use applealc,and tried all the layoutid, all of those colud not work.
      2019-03-31 20:18:23.389590+0800  localhost kernel[0]: (kernel) AppleALC:     alc @ failed to find IOHDACodecVendorID, retrying 0
      i have also use linux to find the codec
      i uploaded the clover , dsdt,codec.
      This problem has been bothering me for two days.
      thanks
       
       
      all.zip
      2019-03-31 20:18:17.997435+0800  localhost kernel[0]: calling mpo_policy_init for Lilu
      2019-03-31 20:18:18.003796+0800  localhost kernel[0]: Security policy loaded: Lilu Kernel Extension 1.3.5 (Lilu)
      2019-03-31 20:18:23.389590+0800  localhost kernel[0]: (kernel) AppleALC:     alc @ failed to find IOHDACodecVendorID, retrying 0
      2019-03-31 20:18:23.398483+0800  localhost kernel[0]: (kernel) Lilu: patcher @ lookup patching applied only 0 patches out of 1
    • By noisegate
      Hi,
       
      I use AppleALC v1.3.5, I can see the device in system info but no sound. Any idea?
       
      Thanks!
       
    • By grisno
      Hi people,
       
      Installer to activate the sound card REALTEK ALC282-v2 (10ec:0282) with LayoutID 1 or 3 in MacOS. This installer does not contain AppleHDA patched Kext. To work properly, it must be installed over vanilla AppleHDA.kext.
       
      I want to thank the whole community for their efforts and content provided, because without these it would not be possible to create this installer.
       
      I would appreciate comments and suggestions!!
       
      Status:
      Speakers : OK Headphones : OK HDMI Audio : OK (Intel HD4K Tested) LineIn : N/A (Model Without LineIn) MicInt : OK MicIntNoiseReduction : OK MicExt : N/A (Model Without MicExt) AutoDetectLineIn : N/A (Model Without LineIn) Sleep : OK WakeUp : OK AutoSleep : OK Hibernate : OK Siri : OK   Tested Laptops:
       
      - HP Pavillion 15-D002SS
       
      Coming Soon:
       
      - Unified installer for the different supported operating systems.
      - Support model with LineIn jack.
       
      Modified Verbs:
      01271C20 01271D00 01271EA0 01271F90 01471C10 01471D00 01471E17 01471F90 01871CF0 01871D00 01871E00 01871F40 01E71CF0 01E71D00 01E71E00 01E71F40 02171C30 02171D10 02171E21 02171F00 01470C02   DSDT:
       
      Patch to apply with MaciASL in your DSDT
      ######################################### HDEF v1.00######################################## into method label _DSM parent_label HDEF remove_entry;into device label HDEF insertbeginMethod (_DSM, 4, NotSerialized)\n{\n If (LEqual (Arg2, Zero)) { Return (Buffer() { 0x03 } ) }\n Return (Package()\n {\n "layout-id", Buffer() { 0x01, 0x00, 0x00, 0x00 },\n //"layout-id", Buffer() { 0x03, 0x00, 0x00, 0x00 },\n "hda-gfx", Buffer() { "onboard-1" },\n "PinConfigurations", Buffer() { },\n })\n}\nend;  
    • By grisno
      Hi people,
       
      This is a preliminary installer to activate the sound card IDT 92HD87B2/4 (111D:76D9) in MacOS. This new version of the installer does not contain AppleHDA patched Kext. To work properly, it must be installed over vanilla AppleHDA Kext.
       
      I want to thank the whole community for their efforts and content provided, because without these it would not be possible to create this installer.
       
      I would appreciate comments and suggestions!!
       
      Status:
      Speakers : OK Headphones : OK HDMI Audio : OK (Intel HD3K/4K Tested) LineIn : OK MicInt : OK MicIntNoiseReduction : OK MicExt : OK AutoDetectLineIn : OK Sleep : OK WakeUp : OK AutoSleep : OK Hibernate : OK Siri : OK   Tested Laptops:
       
      - HP Pavillion G6-2209SS
      - HP Probook 4440S
       
      Coming Soon:
       
      - Unified installer for the different supported operating systems
       
      Original Verbs:
      00a71cf0 00a71d00 00a71ef0 00a71f40 00b71c1f 00b71d10 00b71e21 00b71f04 00c71c20 00c71d10 00c71ea1 00c71f04 00d71c10 00d71d01 00d71e17 00d71f90 00f71cf0 00f71d00 00f71ef0 00f71f40 01171c30 01171d01 01171ea3 01171fd5   Modified Verbs Layer ID 3 & 12:
      00A71CF0 00A71D00 00A71EF0 00A71F40 01371C40 01371D10 01371E21 01371F04 00C71C20 00C71D10 00C71E81 00C71F04 01471C10 01471D01 01471E17 01471F90 00F71C50 00F71D00 00F71EF0 00F71F40 01171C30 01171D01 01171EA0 01171F90  
      Modified Verbs Layer ID 2:
      00B71C10 00B71D10 00B71E21 00B71F04 00C71C20 00C71D10 00C71E81 00C71F04 00D71C30 00D71D00 00D71E17 00D71F90 01171C40 01171D00 01171EA0 01171F90  
        AppleHDAHardwareConfigDriver.kext > Info.plist (Layer ID 2, 3 & 12): <key>HDAConfigDefault</key> <array> <dict> <key>AFGLowPowerState</key> <data> AwAAAA== </data> <key>Codec</key> <string>IDT 92HD87B2/4</string> <key>CodecID</key> <integer>287143641</integer> <key>ConfigData</key> <data> AKcc8ACnHQAApx7wAKcfQAE3HEABNx0QATce IQE3HwQAxxwgAMcdEADHHoEAxx8EAUccEAFH HQEBRx4XAUcfkAD3HFAA9x0AAPce8AD3H0AB FxwwARcdAQEXHqABFx+Q </data> <key>FuncGroup</key> <integer>1</integer> <key>LayoutID</key> <integer>2</integer> </dict> <dict> <key>AFGLowPowerState</key> <data> AwAAAA== </data> <key>Codec</key> <string>IDT 92HD87B2/4</string> <key>CodecID</key> <integer>287143641</integer> <key>ConfigData</key> <data> ALccEAC3HRAAtx4hALcfBADHHCAAxx0QAMce gQDHHwQA1xwwANcdAADXHhcA1x+QARccQAEX HQABFx6gARcfkA== </data> <key>FuncGroup</key> <integer>1</integer> <key>LayoutID</key> <integer>3</integer> </dict> <dict> <key>AFGLowPowerState</key> <data> AwAAAA== </data> <key>Codec</key> <string>IDT 92HD87B2/4</string> <key>CodecID</key> <integer>287143641</integer> <key>ConfigData</key> <data> ALccEAC3HRAAtx4hALcfBADHHCAAxx0QAMce gQDHHwQA1xwwANcdAADXHhcA1x+QARccQAEX HQABFx6gARcfkA== </data> <key>FuncGroup</key> <integer>1</integer> <key>LayoutID</key> <integer>12</integer> </dict> </array>   DSDT:
       
      Patch to apply with MaciASL in your DSDT. You must change the value of the layout-id before applying the patch. In MacOS Mojave should always be 0x02
      ######################################### HDEF ######################################## into method label _DSM parent_label HDEF remove_entry; into device label HDEF insert begin Method (_DSM, 4, NotSerialized)\n {\n If (LEqual (Arg2, Zero)) { Return (Buffer() { 0x03 } ) }\n Return (Package()\n {\n "built-in", Buffer () { 0x00 }, \n "hda-gfx", Buffer() { "onboard-1" }, \n "layout-id", Buffer () { 0x03, 0x00, 0x00, 0x00 }, \n "PinConfigurations", Buffer () {}, \n "MaximumBootBeepVolume", Buffer () { 0x4d } \n })\n }\n end;  
    • By RogerDodger93
      Salve a tutti ragazzi,
      Mi sono appena iscritto e innanzi tutto vorrei esprimere la mia gratitudine per l'aiuto offerto. Il mio problema come da titolo riguarda il mio Pavilion Power 15 più precisamente il modello cb015nl. Ho notato che c'era un altro topic su un modello simile ma immagino che anche se i modelli sono simili non è detto che siano compatibili quindi ne ho creato uno per il mio modello. Per arrivare al dunque, sono riuscito ad installare con successo Mojave 10.14 ma ho riscontrato diversi problemi una volta avviato l'OS. Quello che non riesco a far funzionare è l'indicatore della batteria, il power managment (Stop non funziona e la luminosità), la porta ethernet e credo che la scheda wifi sia incompatibile, le gesture del trackpad, e l'audio che con una scheda audio esterna funziona a meraviglia e l'ultimo grosso problema è che non riesco a far partire clover senza la usb di installazione, ho installato clover bootoader sull'hd dove ho mojave ma niente senza la usb mi parte il bootloader di hp/windows. Premetto che sono partito con una copia di mojave scaricata dall'appstore. Vi allego il report di HackInfo sperando che possa essere d'aiuto per il troubleshooting
      HackInfo_Report.zip
×