Jump to content

[need help] B75M-D3H with i7-3770 reboots when injecting graphics via DSDT


7 posts in this topic

Recommended Posts

The title pretty much sums it, but here it goes:

 

I upgraded an otherwise fully working hackintosh from Yosemite to Sierra. Now I'm stuck, already for two days. It will boot only in Safe Mode, or if I removed my DSDT from the appropriate Clover folder (and in this case I need to inject the HD4000 with Clover's Graphics Injector). What happens is the boot goes fine until the last stage, crash-rebooting at the exact instant the Desktop should appear. If I use verbose, I see a quite messy screen before the sudden reboot. No panic message. If I set Clover to prevent reboot on kernel panics, the said messy screen stays frozen until I do a hard reset.

 

At first I thought my old DSDT became corrupt, so I deleted, restarted with no DSDT (injecting the intel graphics via Clover) and created a new one, using macIASL and Pjalm's patches for my board and a HD4000 patches. Surprise, surprise: the problem didn't go away.

 

Then I deleted the new DSDT, restarted the computer in safe mode, and I tried again, this time using Toleda's Clover audio HDMI command tool, which created two SSDTs in the Clover ACPI/Patched folder - I need HDMI audio, and that's why I cannot settle with simply using Graphics Injector - and, as I feared, it didn't solve anything.

 

I already ruled out the basic mistakes: lack of FakeSMC, VT-D being enabled in the BIOS, wrong SMBIOS for the build etc.

 

The specs are: i7 3770 (non K), HD4000, Gigabyte B75M D3H, macOS Sierra 10.12.1, Clover (legacy mode) rev 3923 and SMBIOS set to iMac 13,1. All these settings worked fine since Mountain Lion (I started using

Clover with Yosemite though).

 

Any help would be much appreciated!

 

All the best.

Hey, vusun123: thank you for the answer. Unfortunately, I don't have this option in my config.plist, so no, I'm not injecting EDID. To be honest, I double checked everything, and it really should be working.

P.S.: just tried with a barebones config.plist, it failed to boot even in safe mode, so I had to revert to the old one and delete again my patched DSDT via single user.

P.P.S.: now with an appropriate Mac Mini SMBIOS! Same results with the patched DSDT (I just created a new one from vanilla, usial macIASL and Pjalm's B75M D3H and GFX HD4000 patches). Only boots in safe mode!!!!!

Hey, vusun123: thank you for the answer. Unfortunately, I don't have this option in my config.plist, so no, I'm not injecting EDID. To be honest, I double checked everything, and it really should be working.

P.S.: just tried with a barebones config.plist, it failed to boot even in safe mode, so I had to revert to the old one and delete again my patched DSDT via single user.

P.P.S.: now with an appropriate Mac Mini SMBIOS! Same results with the patched DSDT (I just created a new one from vanilla, usial macIASL and Pjalm's B75M D3H and GFX HD4000 patches). Only boots in safe mode!!!!!

Check in Safe Mode, DPCI Manager, see if you have the MEI chip listed in the PCI Device or not. If not then you can not get graphics acceleration

I deleted the DSDT and managed to get to the Desktop by selecting "inject Intel". This doesn't solve my problem, since I need HDMI audio, but at least I could run DCPI Manager. Unfortunately, it detected the MEI chip just fine. I don't know what more to do, but thank you for the support. I'll upload my DSDT and the screenshot of the DCPI manager chipset list, and the config.plist I'm using (without the SMBIOS and MBL values, but it's set to iMac 13,1, and I already tried Mac mini as well). Thank you very much indeed!

Archive.zip

  • 4 weeks later...
  • 2 weeks later...

Try to build your DSDT avoiding the multiplex patch (if you want to use FakePciid + FakePCIID_XHCIMux, rename EHC1/2 to EH01/2). If you want post your clean DSDT and config to take a look. Are you using an SSDT and the -xcpm Arguments? If yes delete it (no more support fo xcpm in Sierra), uncheck -xcpm, reboot and build a new one with the latest SSDTPrgen with th option -turbo 3700.

 

EDIT: Happy New Year

×
×
  • Create New...