Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


New way to check SpeedStep! Maybe the best way!

5 posts in this topic

Recommended Posts

How to check your CPU's SpeedStep more simple and more accurate? Use MSRDumper.kext? isata menus?

Maybe you have other ways, but I like to do it myself. So I created this application—"CPU-S".
It is very simple to use—Just open the application, click the button, then you get the information you want.
I can't wait to share it with you. :D And here are some screenshots:

click "SpeedStep Test" to check your CPU's speedstep

one of hint messages

SpeedStep state

one of hint messages

build and copy ssdt.aml to your desktop

Some drivers need to make the app running.
If your system does not have these drivers, the application will install them.​

1.I'm Chinese, so there may be a time difference between me and you. And I may not be able to answer your question in a timely manner.  :blush:
 2.I'm not good at English...... ^_^



  • Intel ARK site for CPU info
  • Pike R Alpha's SSDT generator and AICPUPMInfo kext.
  • Kozlek/Rehabman/Slice HWMonitor
Edited by Allan
Author's credits added

Share this post

Link to post
Share on other sites

Better stick to known & existing tools (that this app actually uses internally without telling, just look at the contents of the dmg and read the script).

  • Intel's ARK site for CPU info
  • Intel's PowerGadget app (and its API)
  • Pike R Alpha's SSDT generator script and AICPUPMInfo kext
  • Kozlek/Rehabman/Slice's HWMonitor app

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By swordsx48
      Hello, happy new year and I hope you're doing well!
      I upgraded to High Sierra despite my intentions not to, and I've encountered some general lag and slow speed with my CPU. Often, Logic Pro X will present a "System Overload" popup that I had only ever seen before when returning from sleep. Now it will frequently occur in between songs.
      I have an MSI Gaming 7 and a i5-4690K. Any help will be appreciated. I'm sure many of you are having issues similar if I am.
      Thank you for your time.
    • By YannisKrp
      What is the best Mini-ITX motherboard for my i5-4460 (replaceable Broadcom chip, if it's possible m.2)? I'm planning to make a Mini-ITX hackintosh inside a Streacom F1C. Is the F1C Evo taller than the F1C and is there any way i can fit a GPU inside it (PCIe raiser etc.)?
      Thanks in advance.
    • By iapple0520
      My CPU is Intel i7-3770 (3.4 ghz) and it can turbo to 3.9 ghz. And my OS version is Sierra 10.12.6 install by clover and #####.
      At first, my CPU block at 3.4 ghz due to XCPM of ivy bridge is disable in Sierra.

      Then I open XCPM in Clover Configurator - Kernal and Kext Patches - KernelIvyXCPM
      I use the and boot clover with argument -xcpm and i7 3770 can turbo to 3.9 ghz successfully.

      However, there are only 6 channel at all, 1.6, 3.4,    3.6,3.7,3.8,3.9.
      I'm wondering is this correct or there should be any method open the channel between 1.6 and 3.4
    • By TechieMac
      Hello, I am attempting to setup a Virtual Machine for Mac Os Sierra and I am having some trouble setting up the operating system to boot on VMware. I had already tried CPU masking which made the kernel panic on the picture and without says the CPU is Disable by the Guest Operating System. I had tried researching this problem but everything dates back to Snow Leopard or it does not work for me. 
      Intel Q6600 
      4 Gbs Ram
      P5G41T-M LX PLUS Motherboard
      GTX 1050 Ti
      Vmx file:


    • By ITMythbuster
      Trying to install on a Lenovo A740 Dualbooting macOS Sierra / Windows 10.
      Stuck on installing macOS Sierra. Once choosing the USB Boot able Disk, Showign up the Appel Logo getting following message:
      panic(cpu 0 caller 0xffffff801a6d6db4): "Unable to find driver for this Platform: \"ACPI"\".\n"@/Library/Caches/com.apple.xbs/Sources/xnu/xnu-3789.70.16/iokit/Kernel/IOplatformExpert.ccp:1672
      Debugger called: (panic)
      Backtrace (CPU 0), Frame : Retunr Address
      BSD Process name corresponding to current thread: Unkow
      Boot Args: dart=0 nv_disable=1
      Mac OS Version:
      not yet set
      Kernel Versino:
      Darwin Kernel Version 16.7.0: ...
      System uptime in nanoseconds: 767758761
      What I already Tried:
      Boot Args: acpi=off
      Checkboxing/DeCheckbosing ACPI Patches...
      ready tons of Forums and Article about this issue... Until now nothing worked.
      Anyone has an Idea to solve this problem?
      Thanks in advance for your Preciouse time!
      System Spec:
      Intel Core i7-5557U Processor (4M Cache, 3.1GHz), Turbo Boost 2.0 (3.4GHz) 8GB, PC3-12800 1600MHza7 DDR31, 2 x 204-pin SODIMM sockets, 8GB Intel Iris 6100 in processor and NVIDIA GeForce® GTX 950A, 2GB memory 27" Quad HD (2560x1440), frameless, 300 nits, 16:9 aspect ratio, 1000:1 contrast ratio, wide viewing angle (from -5 to 90°) multi-touch  
      1 x USB 3.0 Power connector Ethernet (RJ45) Audio combo jack HDMI-in, HDMI-out 2 x mini PCIe 3 x USB 3.0 Media card reader HDMI connector