Jump to content
Sign in to follow this  
Followers 0
flyinghackintosh

[HELP] Compiling in MacASL: spits out 6 errors

1 post in this topic

Recommended Posts


SOLUTION: Found out I was using the wrong version of MaciASL (1.4). The correct version is 1.31 RM.

 

Hi everyone,

 

So my end goal is to disable USB wake from sleep by applying either "usb_prw_0x0d_xhc.txt" or the "usb_prw_0x6d_xhc.txt" patch from RehabMan's repository. But before the (patched) DSDT.dsl can be compiled the following errors need to be cleared.

 

So far I did the following:

  • Used Clover + F4 to get DSDT.aml and the SSDT.aml files
  • Used iasl in Terminal (iasl -da -dl DSDT.aml SSDT*.aml) to decompile DSDT.aml and SSDTs
  • Opened DSDT.dsl in MaciASL
When trying to compile the (unmodified, for testing's sake) DSDT.dsl file MaciASL spits out 6 errors. Tried both the 5.0A and 5.1 compiler: same result. 4.0 causes even more errors.

  • 13920 6126 syntax error, unexpected PARSEOP_ARG0
  • 15571 6126 syntax error, unexpected PARSEOP_NAMESEG, expecting '('
  • 15733 6126 syntax error, unexpected PARSEOP_NAMESEG, expecting '('
  • 15746 6126 syntax error, unexpected PARSEOP_STORE
  • 15748 6126 syntax error, unexpected PARSEOP_STORE
  • 15757 6126 syntax error, unexpected PARSEOP_METHOD, expecting $end and premature End-Of-File
How can these errors be fixed? I don't have enough knowdledge on the subject to fix it on my own. Help is greatly appreciated!

 


 


 

Update: Managed to get rid of 1 error by using refs.txt in the disassembly process as described in this thread.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By james2058
      Hello guys!
      I have a Asus Zenbook with the following characteristics:
      Model: ASUS Zenbook UX310UQ
      CPU: Intel Core i7-7500U CPU @ 2.70GHz
      IGPU: Intel HD Graphics 620
      RAM: 8GBx2 => 16GB RAM Bus 2133
      Wifi: Replaced with DW1560.
      Clover: Clover 5120
      OS: 10.15.6
      UEFI/LEGACY: UEFI
      Storage: SSD Crucial 500GB
      Everything works fine!

      I have the WiFi/Bluetooth chipset DW1560 (DCM20702A) and a Logitech K380 Keyboard and magic mouse. My Hackintosh is sleeping fine only problem is that it won't wake from sleep on key presses. I already tested this USB port with a normal keyboard and the result was that it wakes up my Hackintosh on key presses. And in system settings the Bluetooth wake option is enabled, too.
      Has someone an idea where the problem could be or which additional settings I have to verify?
      Thank you all
       
    • By amin321
      hello there, I have finished almost everything in my laptop Dell G3 15 3590 intel core i7 9750h UHD630, and everything is okay right now followed dortania (Open core guide) with all my ssdts patches including the USB port, the strange problem that I am facing which is in sleep awake functioning 
      sometimes it sleeps okay and when I am trying to wake it wakes properly, and sometimes it does not wake from sleep at all and then I have to force shut it down with the power button, and it gives me that Report, I wish anyone can help me please as I almost finished everything about 2 months ago and from then I am trying to figure out what makes that issue, please anybo dy help me 

    • By k.panic
      Hi to all, i've installed High Sierra (with Clover) on:
       
      Asrock H110 BTC+
      Intel G3900 (with FakeCPUID 0x0106E0)
      GeForce 710
       
      but he can't go in sleep. what should i fix? Thanks!
    • By Preet
      I am getting only one syntax compile error after patching with the rehab man Skylake generic and hp g6 2221ss.
      Error: syntax error, unexpected PARSEOP_ARG1
      Error example on Tony Mac ( Link - https://www.tonymacx86.com/threads/solved-unable-to-compile-dsdt-syntax-error-unexpected-parseop_arg1.201774/)
      I found a guide on using refs.txt but I do not know how to use it with the new maciASL on this GitHub (link -https://github.com/acidanthera/MaciASL/releases). 
      System Info Pavillion AU003tx. (Skylake i5, intel HD520)
      Please respond, I would love to have the battery status working. Thanks in advance!!
×