Jump to content
Welcome to InsanelyMac.com - No more ads! And some exciting news... Read more... ×
Sign in to follow this  
Followers 0

Config.plist causes Blackscreen on desktop

1 post in this topic

Recommended Posts

Hi guys,


wanted to install OS X El Capitan on my desktop PC using the Clover bootloader.

That worked with a slightly modified standard config.plist from TonyMacx86 guide for Yosemite with Clover.


Just for your information, my hardware components:



CPU: Intel Core i5-4440 @ 3,10 GHz | CPU-Cooling: Matterhorn -PURE- | RAM: 2 * 4GB Crucial Ballistix Sport DDR3-1600 DIMM CL9-9-9-24 | Motherboard: ASRock B85M Pro4 | GPU: Sapphire Radeon R9 390X Nitro 8GB GDDR5 | SSD: Samsung SSD 840 Evo 500GB | Power Supply: 550 Watt Corsair CS Series Modular 80+ Gold | Case:beQuiet! Silent Base 800


The used config.plist is appended.


The installation worked, but when I come to my desktop after a short period of time always the screen turns black (not when I am in safe mode, but I can not mount partitions in this mode, etc.).

Well, obviously this seems to be a GPU related problem so I tried already different things to solve this issue:

 1. In Clover configurator I added the Fake ID "0x67B01002" under devices in "ATI".

 2. Under "Graphics" I enabled "LoadVBios" and pasted my .ROM (I exported that for my video card approx. 1 week ago with GPU-Z under windows) under EFI/CLOVER/ROM in the right format (in my case 1002_67B0.rom) (also attached).


Unfortunately, all of this measures could not solve my issue.


Would appreciate your help, thanks!


EDIT: I could solve that issue. For my GPU it was necessary to insert under "Graphics" in "FBName" "kBaladi" and now it works.



Edited by L0g4n

Share this post

Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Similar Content

    • By 5T33Z0
      Background: Since the Pre-Release of Clover v5123, OpenCore Momory Fixes have been integrated into Clover in the form of OpenRuntime.efi. It replaces previous AptioMemory Fixes. Since v5126 AptioMemoryFixes are obsolete and no longer supported, so an upgrade to v5126 is mandatory in order to be able to install and boot macOS BigSur with Clover.
      This guide is for everyone trying to update to the latest Clover version or having issues while updating from previous versions, so they can install and run BigSur on their Machines. While updating to the latest iteration of Clover, there are several obstacles one can come across along the way. This guide is here to assist users trying to make the switch from the "old" Clover version with AptioMemory Fixes to the new one with OpenRuntime and Quirks Settings in CloverConfigurator.
      Problem: If you update your existing Clover installation by either installing the clover.pkg file or manually updating it the way you used to this will most likely result in an inoperable bootlader due to missing boot parameters.
      Approach: In order to avoid the dilemma of your system not wanting to boot, you have to know that the following files are obsolete and are no longer necessary, so they should eiither be disbabled/deleted when updating Clover from a built prior to v 5123 or omitted altogether when setting up a new EFI Folder:
      AptioMemoryFixes: AptioMemoryFix.efi, OsxAptioFix3Drv.efi, OsxAptioFixDrv.efi and everyhing else containing "memoryfix". Unnecessary Drivers (for UEFI-based Systems): DataHubDxe.efi – enables DataHub Protocol Support if it is missing from the BIOS. Modern UEFI BIOSes support this. So it's probably only necessary for Legacy Systems. FSInject.efi – For Kext-Injecttion. But pretty much obsolete since it's fully integrated in Clover nowadays. Might be necessary for Legacy Systems, though. SMCHelper.efi – Necessary when using FakeSMC.kext and ONLY FakeSMC. If you use it in combination with VirtualSMC.efi, it leads to an instant Kernel Panics. So, in other words: when using VirtualSMC – which is higly recommended over FakeSMC – DON'T use SMCHelper, use it in conjunction with VirtulSMC.efi (although unnecessary in most cases). EmuVariableUefi.efi – necessary for emulating NVRAM, if NVRAM is either not available (legacy systems) or working incorrectly. OcQuirks.efi and OcQuirks.plist – delete if present. OcQuirks is a relict from earlier attempts to include OpenCore Booter Quirks into Clover up until version 5122. Incompatible Kexts – wherever possible, you should use the latest available kexts provided by acidanthera (one of the devs behind OpenCore). Because incompatible Kexts are a source for Kernel Panics. I had an issue with my Laptop where VoodooPS2Controller.kext would cause a kernel Panic when used alongside VoodooPS2Mouse.kext, VoodooPS2Trackpad.kext and VoodooPS2Controller.kext. At the time I updated clover from 5122 to 5123, I didn't know that these 3 kexts are now includes as plugins inside of VoodooPS2Controller, so having them twice would cause a panic.

      In general, having Kexts wich have depedencies to oher kexts can cause a KernelPanic if not loaded in the correct order. In OpenCore, you can and have to set up the correct loading order of kexts manually by yourself, but in Clover only a few essential kexts like Lilu and Fake/VirtualSMC are hard-coded in, so they are always loaded first. It took me a while to figure this out. So when you update Clover and you are using lot of Kexts (usually on Laptops), try to update all Kexts first using Kext-Updater which is incredibly useful tool to download all sorts of bootloader-related files, have a look inside of them so see if they include more kexts as plugins and make sure nothing is present twice – HID, Wifi and Bluetooth kexts come to mind here. If you get panics you can not isolate, just move all unnecessary kexts to the "off" folder to temporarily to work around the issue by starting with a minimal set up to get the system running. Then put the disabled kexts back one by one to find the culprit for the panic.  
      Updating your EFI
      Prepare an USB Stick. Format it to FAT32 (MBR). We'll use it for testing our updated EFI Folder first, before copying it to the ESP on the HDD. Download the latest Clover Release  as a .zip archive for a manual update (currently "CloverV2-5126.zip"): https://github.com/CloverHackyColor/CloverBootloader/releases Extract the .zip. We'll create our EFI based on the one insides of it. Have a look at the "EFI > Clover > drivers > off > UEFI" Folder – you find the following Files: Copy the following files over to EFI > Clover > drivers > UEFI: ApfsDriverLoader.efi, VBoxHfs.efi and OpenRuntime.efi Now we have a minimal set of Drivers which looks like shown below. The files tagged in gray are in the drivers Folder by defautl and are most likely unnecessary on UEFI-based systems. As mentioned earlier, SMCHelper MUST be deleted when using VirualSMC.kext! I would turn of each of the gray drivers one by one and chick if the system still boots without them.
      Next, copy over your kexts (updated to the latest available version, of course), your ACPI > patched folder and your config.plist form your existing EFI Folder Open CloverConfigurator and update it to the latest Version. It should now include a new section at the bottom called Quirks, as mentioned earlier Now open your config.plist you copied over from your working EFI and click on "Quirks". It should look like this (without the descriptions of course):
      Head over to the OpenCore Install Guide and pick the guide for your CPU Family and Platform. Jump to the "Booter" Section. It contains all required Booter Quirks tinted green in the screenshot. Make sure to unfold the "more in-depth info" box to see what they do. Find the options for your system and tick them away in Clover Configurator. Next, jump to the "Kernel" section of Dortania's guide and copy over the settings from "Quirks" and "Scheme". Again, make sure to unfold the "more in-depth" section to find all necessary settings. NOTE: some of the settings Located in "Kernel > Quirks" have different names and are located in the "Kernel and Kext Patches" section of Clover Configurator. These include:

      In most cases you have these set up correctly already, otherwise your system wouldn't have started before. But it's good to double check if you have settings enabled which may be unnecessary. Once you've ticked all the necessary quirks, save your configuration, copy the new EFI Folder to the root of your USB Flash Drive and try booting from it. If everything was set up correctly, the system should boot as expected. If it does boot, you can mount the ESP partition of your hard drive, backup your EFI Folder, delete it and put in the one from your USB Flash drive to make the changes permanent.  
      TROUBLESHOOTING: If you get Kernel Panics take a note of them and head over to the OpenCore Troubleshooting Guide and have a look at the "OpenCore Boot issues" and "Kernelspace Issues" sections to find your error message and possible fixes to resolve it. Another great resource to check if your Clover config is set-up correctly in general (excluding Quirks) is the Hackintosh Vanilla Desktop Guide For more info about how OpenCore differs from clover and see which settings, drivers and features are compatible, check out the Clover Conversion Guide.
      Good luck!
      PS: If you run into trouble after following this guide you can upload your config.plist and I can have a look at the quirks.
      PSS: When running BigSur, you need to remove the PreBoot Volume from the "Hide" Section of the GUI because if I understand correctly, BigSur requires booting from it.
      PSSS: if your system boots correctly you can upload a screenshot with your quirks with additional Info like your Board and CPU which might be helpful for other users.
    • By HenryV
      Need clarification.
      Updating to next version of OC requires config.plist from the new or can I just copy over the existing/working config.plist to file tree?
      Itlwm and AirportItwlm issues with OC 0.6.3?
      load and function with clover.
      Appear loaded but not functional in BS 20B29.
      ps ax | grep itlwm
        658 s000  S+     0:00.00 grep itlwm
       ~ % ps ax | grep AirportItlwm
        679 s000  R+     0:00.00 grep AirportItlwm
       ~ % ps ax | IO80211Family     
      zsh: command not found: IO80211Family
       ~ % ps ax | grep IO80211Family
        705 s000  S+     0:00.00 grep IO80211Family
       ~ % kextstat | grep itlwm
      Executing: /usr/bin/kmutil showloaded
      No variant specified, falling back to release
         74    0 0                  0xa28000   0xa28000   com.zxystd.itlwm (1.2.0) 24027440-40FB-30FF-863E-26A05711B096 <48 14 6 5 3 1>
      ~ % kextstat | grep AirportItlwm
      Executing: /usr/bin/kmutil showloaded
      No variant specified, falling back to release
         79    0 0                  0xa39000   0xa39000   com.zxystd.AirportItlwm (1.2.0) EA6F0015-674E-3237-94F1-08F341829B59 <78 48 14 6 5 3 1>
      ~ % kextstat | grep IO80211Family
      Executing: /usr/bin/kmutil showloaded
      No variant specified, falling back to release
         78    1 0xffffff8001c3a000 0x13a000   0x13a000   com.apple.iokit.IO80211Family (1200.12.2b1) EBD11055-A4E6-3243-A60C-0AAAD85C12E3 <77 75 48 30 10 8 7 6 5 3 1>    
    • By MaLd0n
      iMac20,1 Hackintosh 
      A good build for professional audio and video processing.
      We love silence and Cooler SCYTHE Ninja 5 is mandatory in this case!
      A very custom DSDT for best experience under macOS. Removed all unused devices, injected all Apple devices, essentials, cosmetics, real improvements.

      -OpenCore Vanilla TUTORIAL-
      -USB Port Mapping TUTORIAL-
      -Bios/UEFI Settings-
      CSM Support - Disabled
      Internal Graphics - Enable
      -Thunderbolt Configuration-
      Security Level - No Security
      GPIO3 Force Pwr - Enabled
      Mobo - Ga Z490 Vision D

      Processor - i7 or i9 10th Intel

      GPU - RX 580, 590, VEGA 56, VEGA64, 5700XT or RADEON VII

      Cooler - SCYTHE Ninja 5 

      NVME - WD Black SN750 NVMe SSD
      -EFI folders- 
      Clover - https://tinyurl.com/yxzftuyr
      OpenCore - https://tinyurl.com/y3lt8t9l
      Just paste EFI folder into EFI partition, reboot and extract one SendMe. Post this dump here for full ACPI solution!
      Download RunMe.app dumper
      -If you want to buy me a beer - Donations with PayPal
      -DSDT- Complete Solution
      DSDT.Z490 VISION D MaLd0n.zip
      -SSDT- Not complete solution
      -DSDT Patches-
      -USB Solution-
      USB SOLUTION.zip
      -Boot Time with Clover or Opencore is same-

      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thx to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By VortexisTV
      So I've been trying to update to Big Sur from Catalina but I get stuck at the +++ message at the beginning. I made sure I have all my kexts and drivers updated. Updating to Clover revision 5126 would only get me kernel panics. Am I doing something wrong? Any response would be greatly appreciated. EFI
      ASUS Zenbook UX331FN
      Intel Core i5-8265U
      Intel UHD 620
      Clover 5120

    • By amadeusex
      Hey guys - how are you holding up?
      Because of a lot of free time and after abandoning the idea to get Catalina installed i tried to run Mojave on my beloved z820v2.
      Everything went fine except power management.
      I've used @WoodCabin's EFI folders to install and later on run Mojave (14.6).
      Here's a glimpse of what i get as soon as i put the patched (from 10.13 as suggested on stinga's X79 power management topic) AppleIntelCPUPowerManagement.kext into S/L/E

      I tried also @stinga11 s kext patches for Mojave but still either PM's not working or KP.
      Here's my my EFI folder