Jump to content
Sign in to follow this  
Followers 0
api1973

Impossibile avviare con HD 4000 dopo installazione gtx 970 - NVDIA PATCHING ERROR FAILED -

4 posts in this topic

Recommended Posts

salve a tutti

 

ho mavericks 10.9.0 con bootloader chamaleon

 

ho sempre regoalrmente avviato il sistema con accellerazione hardware grazie alla mia integrata Hd 4000

 

nel sistema prima avevo una amd 6950 che, non volendone sapere di avviarsi, se in modalitá provvisoria, mi ha portato a disabilitarla mediante un trucco letto su questo forum ovvero, disinstallare i driver amd di default della Apple.

 

quindi pur essendo installata ed alimentata la amd, dal bios potevo impostare l'avvio con la grafica integrata hd 4000 e tutto filava liscio.

 

Ho acquistato recentemente una gtx 970 nvdia.

 

Ho letto molte discussioni ed ho appreso che la gtx 970 non é compatibile con mavericks, esige almeno yosemite e l'installazione di web driver.

 

non volendo passare a yosemite né tantomeno a el capitan, ho cercato un modo per avviare il sistema apple, senza dover ogni volta staccare i cavi video dalla 970, con cui uso regolarmente windows, per attaccarli all'integrata quando decido di usare il mio hackintosh.

 

ho fatto varie prove cambiando i flag di avvio

 

quindi ho provato prima

 

GraphiscEnabler=No  nv_disable 1

 risultato loop infinito

 

poi

PCIRootUID=0

loop infinito

 

poi PCIRootUid=1

loop infinito

 

ncpi=0x3000

loop infinito

 

npci=0x2000

loop infinito

 

-f

loop infinito

 

UseKernelCache=No

 

poi ho provato ad avviare in modalitá provvisoria con -x ma niente

 

poiché ho due monitor tutte queste prove le ho svolte tenendo il monitor principale collegato alla scheda grafica integrata , previamente impostata nel bios e tenendo collegato il secondo monitor alla gtx 970

 

il fine ribadisco era quello di trovare una soluzione per non attaccare e staccare cavi video dalla grafica discreta alla integrata allorché decidevo di usare maverick

 

Adesso anche quando stacco il cavo video dalla gtx 970, lasciando solo il monitor principale collegato alla grafica integrata ed impostato nel bios l'avvio in IGD, maverick non parte piú

 

mi esce questo errore

 

Nvdia patching error failed

 

non trovo soluzioni mi aiutereste?

 

 

ripeto il sistema non parte in modalitá provvisoria con il flag -x

 

Share this post


Link to post
Share on other sites
Advertisement

La flag giusta da usare è nv_disable=1

E comunque potresti passare a Clover, che permetterebbe di attivare l'iniezione grafica Intel disabilitando la nVidia

grazie mille ha funzionato, l'unico comando da usare é quello di cui sopra

 

tutto funzionare regolarmente ed avvio con accellerazione

 

per quanto riguarda il passaggio a clover, potresti spiegarmi un pó meglio cosa dovrei fare, non conosco clover, ci ho messo una vita a capire chamaleon

 

grazie per la disponibilitá concessami

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×