Jump to content
legot28

SMBus device

14 posts in this topic

Recommended Posts

bonjours 

je viens de remarquer que mon device SMBus n'est pas listé dans DPCIManager

laptop asus N71VG core2duo

du coup il n'est pas present dans ioreg et AppleSMBusPCI.kext ne se charge pas

le laptop est fonctionnel a 100 pour 100 , mis a part l'autosleep sous el capitan ( ok avec yosemite )

 

post-433412-0-66918600-1449993175_thumb.png

 

quelqu'un peut m'orienter sur ce probleme

merci a tous

Share this post


Link to post
Share on other sites
Advertisement

Salut

into method label _DSM parent_adr 0x001F0003 remove_entry;
into device name_adr 0x001F0003 insert
begin
Device (BUS0)\n
                {\n
                    Name (_CID, "smbus")\n
                    Name (_ADR, Zero)\n
                    Device (DVL0)\n
                    {\n
                        Name (_ADR, 0x57)\n
                        Name (_CID, "diagsvault")\n
                        Method (_DSM, 4, NotSerialized)\n
                        {\n
                            Store (Package (0x02)\n
                                {\n
                                    "address", \n
                                    0x57\n
                                }, Local0)\n
                            DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))\n
                            Return (Local0)\n
                        }\n
                    }\n
                }
end;

test ça

 

bonne hack

Share this post


Link to post
Share on other sites

hello

toujours pas de smbus 

je post divers fichiers de rapport

merci 

 

attachicon.gifn71vg.zip

 

Slt

 

Dans ta déclaration LPCB remplace

                   Method (_STA, 0, NotSerialized)  // _STA: Status

                    {
                        If (ELEN)
                        {
                            Return (0x0F)
                        }
                        Else
                        {
                            Return (Zero)
                        }
                    }
 
par 
 
                  Method (_STA, 0, NotSerialized)  // _STA: Status
                    {
                            Return (0x0F)
                    }
 
Fred

Share this post


Link to post
Share on other sites

Hum...

 

C'est la première fois que je vois le device SBUS ou il est placé dans ta DSDT.

 

SBUS devrait être placé dans _SB _PCI0 au même niveau que LPCB SATA USB0 etc.

 

LPCB

SBUS

SATA

etc.

 

Fred

Share this post


Link to post
Share on other sites

hello

je post ma dsdt origine avant toute modification et pas de smbus

 

attachicon.gifDSDT.aml.zip

 

Salut,

 

Peux-tu aussi mettre les fichiers ssdt..

Tu as renommé les devices dans ta dsdt, il faut s'assurer d'avoir les noms correspondants dans les ssdt. (Si c'est utilisé)

Autre chose la DSDT a été extraite par un OS il faut absolument mettre l'option clover fixed region, sinon cela posera problème un jour ou l'autre quand tu modifieras ta config dans le bios.

 

As-tu essayé de déplacer SMBUS comme je t'ai suggéré ?

 

Fred

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×