Jump to content

Has Anyone Managed ALC892 (MSI X99A SLI PLUS) to Work as Native AppleHDA on El Capitan 10.11?

9 posts in this topic

Recommended Posts

Hello, guys! 

I was wondering if anybody had managed to get a working AppleHDA.kext for MSI X99A SLI PLUS (ALC892). If so, would you share the method you used, please?


Share this post

Link to post
Share on other sites

thats not possible, because of other path maps, and other hardwareconfig...


Same Realtek Chip, but different^^


I know stupid... but its how it is :-)

Actually, I'm stupid because I never noticed that it said "for Intel motherboards". Lol

Share this post

Link to post
Share on other sites

Working applehda is not a problem, you need just to patch it :-)

x99, use native 10.9.5 AppleHDA.kext (v2.6.3) with x99 AppleHDAController fix.

Share this post

Link to post
Share on other sites

x99, use native 10.9.5 AppleHDA.kext (v2.6.3) with x99 AppleHDAController fix.

Oh, that i didn't know, sry...

In theory vanilla applehda works on x99 boards with the controller fix? (i mean not only the 10.9.5 version)


Cheers :-)

Share this post

Link to post
Share on other sites
On 10/19/2015 at 1:13 PM, Ramalama said:

But you can patch your AppleHDA :-)




Look there, its an easy script to do that :-)


Working applehda is not a problem, you need just to patch it :-)

Vanilla AppleHDA would not work, that what i wanted to say :-)



I know it's been almost 3 years, but I looked at my reply and yours, and I was like, "What an Idiot I was!" Hahaha
I did the trick on High Sierra (found the script on some other website whose name I don't recall) only because the mic was the only thing that wasn't working, and now everything works perfectly! :D
Even back then, I was looking for a way to patch the AppleHDA instead of using a different kext like VoodooHDA or something similar. The word "native" is what caused the confusion. 

Share this post

Link to post
Share on other sites

Any chance you could post your clover files and any other tricks you used? I'm running X99A SLI Plus with 5820K and could use some help with the install.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Gorec
      I apologize in advance if I didn't post in the right category and if my title and description aren't specific enough :c
      My config in a nutshell:
      CPU: i7 5820k GPU: MSI GTX 1060 3GB RAM: 16 GB MOBO: MSI X99 SLI PLUS I attached RunMe output with all the details of my built.
      Some background:
      I have my Hackintosh for about half a year. That time I managed to make it works and fix major issues, but some of them left unresolved since then and I ignored them until now.
      I use my Hackintosh for Adobe projects (PR, AE, PS, IL, AU and a lot more) - most of them connected with video editing of course browsing with Chrome and other small tasks.
      Random restarts - this is the biggest one. I'm starting to work on bigger and bigger projects and at this time I think I can't allow this to happen that often. In the past, they happened like once a day or a couple of times a week. However, now it's just frustrating when it happens even 5 or more times a day. I've tried to observe and find out what can be the cause but I haven't managed to find any connections. I thought it happens when Premiere or another app is using GPU, but I haven't seen increased usage when it restarts. I think that it can be connected with GPU, memory or PSU or... meh, anything else. I don't have resources to check if it'll work with other components. There should be some fix for this. I will really appreciate any help with this :c Restart instead of shutdown & sleep doesn't work. I've tried to look through some Google results for this and tried many solutions (as you can see in attached Clover folder), but I think the right one for many of these issues is to make my own DSDT. Glitches, freezes and other things while encoding a video. It happens very often when I try to do this. Maybe it is an issue with GPU or (hopefully) only with GPU drivers which can be fixed with some patch. Today my headphones stopped working. I have a multi-output device configured in the Audio MIDI Setup app which includes my headphones (HyperX Cloud via USB) and Soundflowerbed virtual audio device for capturing system audio. Today while I was trying (like 15 times) to encode a video in Media Encoder in the background and watch video on YouTube I stopped hearing anything from my system. Of course, it restarted a couple of times as always, but even this didn't solve this. If I plug them directly with mini jack (not via USB Soundcard which was in the box and which I always used) in the front IO or the back I only hear some loud noise It takes EX-Fat formatted volumes a few minutes to mount after each restart. I found a workaround to format it with NTFS since I have Tuxera installed and I will reformat these volumes when I will find time for this, but maybe there is some fix for this. GPU is a little bit hot. HW Monitor shows it is only 45-55 degrees, but for my hand is a little bit hot, idk. Also related to GPU - glitch after POST but before entering Clover boot menu. It is a black screen with little white squared glitches for a few seconds. Maybe it indicates the GPU drivers are loading, but maybe it shouldn't be like this. And if I can ask about that - I can't make all applications hide on startup. I, obviously, have "Hide" checkbox checked on every login item in settings, but it doesn't work, none of the apps is hidden in the dock. Is there a way to fix this? Also a small but annoying problem - I can't turn off permanently Mojave update notification (since I tried to install it, and I had to reverse to High Sierra because I had a black screen and I didn't have time for repairing all of them. Tags are not working in Finder - every time I tag a file or folder and make a change in it (for example save a text file) the tag disappears.  
      So, with knowing all of that, is there a way to make a proper DSDT file for my Hackintosh? I tried to look through some guides on how to make it but I think I reached my abilities to understand how Mac OS works and what all of these things are, so I'm asking you guys politely, would someone like to help me? At least with these random restarts? :/
      I really begin to think that I'm a newbie in configuring all of that Clover things - even after what I managed to do with my PC. Help me, pleease... :c
      If you have any questions post it below, I will really appreciate any help <3
      Send me MBP-Gorec.home.zip
    • By sennn

      I just upgraded to a vega 64 (sapphire 8 gb reference edition) from my 980 ti, to run mojave and overall have better performance in macOS, however I'm running into problems.
      I managed to get dual monitor working with lilu and whatevergreen, and even managed to stop my fans from simulating a helicopter with vgtab, no matter what I setup in vgtab in terms of the higher p clocks, and power target (tried between 40% and 100%) as soon as I start valley or heaven my pc just shuts down. On windows i can run both of them without problem, so it's not a PSU issue as I originaly thought.

      The only progress I managed to "make" was by using RadeonVegaLowFansSpeed.kext which allowed me to run geekbench without crashing, but still crashes at valley/heaven.

      I was mostly experimenting with just using the vgtab kext in kexts/other, initially I tried it with SSDT, and injecting it into the config.plist, but none of them seemed to make any difference, should I continue experimenting with those too or it should work as a kext too?

      I attached my current EFI (I know it has 3 aptio fixes, my board is finicky with that, I'm also experimenting on that at the moment).
      msi x99a sli plus
      i7 5820k
      sapphire amd radeon vega 64 8 gb
      mojave 10.4.4

      Anyone got any idea how can I make it run propely?

    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&amp;t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
        --Install Follow my tutorial and use my Clover folder http://www.insanelymac.com/forum/topic/323052-guide-sierra-high-sierra-on-intel-5-6-7-8-and-9-chipset-series-nehalem-sandybridge-ivybridge-haswell-broadwell/ CLOVER Install.zip   --Post Install --Install Clover bootloader and replace with my folder CLOVER Post Install.zip   Bingo!   Now you need a fine tune! DSDT time!   If you need edited DSDT... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer IORegistryExplorer.app.zip -Run it, post files generate in your desktop RunMe.app     -DSDT bios F23 My DSDT  DSDT.MaLd0n GA X99-UD3P.zip   -Patches -FIX ERRORS AND WARNINGS -HPET -SATA -sSATA -DMAC -SLPB -DARWIN -LPC -XHCI -EHCI -PLUGIN TYPE -ALZA to HDEF -HDEF -RTC -IRQs -SBUS -BLC0 -BUS1 -MCHC -ALS0 -IMEI -SHUTDOWN -LAN -SPSR -EC -PNLF -HDMI


      -Clover https://sourceforge.net/projects/cloverefiboot/files/Installer/ -FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek -Audio https://github.com/vit9696/AppleALC -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads -LAN https://github.com/Mieze/IntelMausiEthernet   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, nmano and many, many, many others!   We're all here to have fun and learn from each other!  
    • By X99SUser
      Hi there, I'm an Italian student who wants to try out Hackintosh. I'm struggling on this odissey since 3 weeks ago and now I decided to ask for your help. My aim is to get macOS High Sierra up and running on my X99 build.
      The specs are as follows:
      Intel Core i7 5820K@3.3GHz Overclocked to 4.2GHz; MSI X99S SLI Plus; Corsair Vengeance LPX DDR4@2133MHz Overclocked to 2400MHz (16GB); DeepCool Assassin II (Cooler); MSI GTX960 2GB OC Edition; SSD Samsung 850EVO 250GB; HDD Seagate Barracuda 2TB. As I said before I was struggling on this machine for 3 weeks with other guys that helped me a lot, but we can't get past the Reloc Block. With the most "successful" attempt we made, I eventually got it to the point you see in photo, after which it reboots in something like 2 or 3 seconds.
      In the attatched files you'll find the photo of the point where I was stuck (I apologize for the quality, if you need a more redable photo just ask and I'll take a shot) and the EFI used for that attempt.
      Thanks a lot to all of you for your help and support, if you need any additional information about my computer or the EFI Folder that you can't find in this post or its attatched files, don't hesitate to ask me, I'll be happy to answer.

    • By fietipaldi
      Hi there,
      I had to reinstall El Capitan on my Hackintosh, as it was installed in Clover Legacy Mode before (with everything working just fine).
      Now I installed it again in UEFI mode and since then, Audio (ALC892) is not working anymore (Neither in UEFI or Legacymode).
      I tried to install the same 2 Kexts as before (AppleHDA modified and HDAEnabler1) using Kextutility (wich was working fine before as well).
      It always fails to install AppleHDA, as it cannot Backup or modify the Original AppleHDA in System/Extensions (Can't copy sourcefile).
      I also tried the same, using the root Account, using terminal with kextunload / load and even a script for clover.
      They all fail to modify / delete the Original AppleHDA. Trying to rename / move or delete the Original file with Terminal or Finder is not working as well, I get an Error, saying that the file cannot be modified because OS X requires it.
      So how can I install the Kext to get my audio working again? System is El Capitan (10.11.6)...

      Thank You!