Jump to content
drone4zone

Intel DX79SR system board Clover Install almost 100%

25 posts in this topic

Recommended Posts

Followed clover guide installed Yosemite 10.10.3 made post changes from rampaged files X79 system runs nice ,just needs more fine tuning ,Speed step seems to work ,but it throttles max at 3.5 not 3.8(i73930k 3.2-3.8 turbo,not sure why ,sleep works ,but does not wake once it' sleeps,remains black screen,have win8.1 on another drive it runs well sleep works wakes ,I'm new to Clover and UEFI bios type setups ,If pointed in correct direction I would like to figure this out ,after looking into Clover's Glossary it's not clear what all settings are for ,I guess I'm not in the know ,I thought about Chameleon ,but seems to be limited as with Clover setup.

The Intel board DX79SR bios is updated to latest 6.50 version ;I try to keep bios setting simple but it's bit hard to follow with various settings power settings C4,C5,C6,it remains default at C4 directed at S3,not sure what that means exactly,also speed step is enabled as well as custom power which is also default. I'm thinking I need to tweak the kernel in Yosemite and or SSDT to get turbo native and sleep working correctly. I generated an "f4" DDST from clover and that did something but not entirely sure as Clover works with on the fly patching process sounds cool ,but no joy in making my rig work 100%.i know it's capable just need more info on the final tweaks .
open for any suggestions 
Drone4zone
my rig
DX79SR system board TWO Crucial DDR3 1600 1.35 RAM 8x2
i7 3930K 3.2 - 3.8 Turbo native 
LiteOn SSD sata3 256 Master
sata3 3TB storage 
SATA RAID stripe 0 storage 
ClubRoyal R9 280X 3 GB vram
termaltake 600PSU
Koolance Homebrewed setup two 120MM fans Radiator 
system board readings,adjust fan speed

post-202487-0-80205800-1432587929_thumb.png

Share this post


Link to post
Share on other sites
Advertisement

Updated  used  SSDT to over clock  seems to work nicely ,all ports work 3.0 USB SATA 3  ALL Natively, with Clover  method ,and patched AppleIntelCPUPowerManagement.kext ,what I've learned is that  these X79 boards do not support OsX86  Vanilla CPUPM,from 2011socket LGA ,bummer...after having been spoiled with the "BadAxe2" board i was hoping to have same results ,only thing I can Not get working is waking from SLEEP function ..and Clover website state you may need to patch the DDST in the "GPE" section ,or not proper initialized PCI dev,AppleHDA, which I  have patched HDA kext and injector kext ,i tried  removing  them and still No wake function  ;and last there is  another beta GenericUSBXHCI_1.7_yoseite_14A329 that may prevent wake from sleep fix ,no joy  anyone  know how I could patch GPE section of Clover extracted DDST file ?

Dre4zone 

Share this post


Link to post
Share on other sites

I just need sleep to wake to have it all working  tried SleepEnablerKEXT and it KP ,In Clover I tried to tweak it  with conjugator but  not sure  all the  items  to use ,I tried Dark Wake 0 till 8 setting and no joy hmmm  anyone suggest anything ?

Share this post


Link to post
Share on other sites

Hello gengike84 thanks for your reply.

I did try darkwake=0 also FixShutdown ( think that was your request ) and the system sleeps perfectly but will not wake  even after pressing power button.


on the Clover website  under glossary I think they mention  Sleep problems, there the go on about   "http://clover-wiki.zetam.org/Sleep-problems" a group of _GPE methods.I can not say I know how to study my methods table and look for  an  problem.I can say I know how to apply a patch given the correct code,I hope someone could advise me on which table needs if any kind of patch is applied in order to get ,My system to wake from a sleep mode .Not sure of what exact settings need to be applied in Clover Configurator,and mother board's  Bio's.I do know that sleep works perfectly in window's 8.1,and window's 10 versions OS,with currents bios setting which is default . here is  my "DSDT" extracted  from clover during boot while pressing  f4

 

 

http://www.filedropper.com/dsdt_1

Share this post


Link to post
Share on other sites

Hello, in clover configurator, try putting the device section flag Add clockID.

Sometimes the problem of sleep depends on usb problematic, for example hub etc ...
Try, if, to start with just a keyboard and mouse and see how it behaves.
If it goes well, add a device at a time, by doing so you can figure out in stages which may be the cause.

Share this post


Link to post
Share on other sites

@gengike84

I notice when i went into clover Configurator I had "ClockID" clicked I have OEM apple keyboard and mouse Aluminum series connected in usb port 2.0 in back ,that seems to work ,mouse turns on red laser but screen remains black,will not wake ,power button flashes to alert me s3 state enabled ...It's frustration ,cause I can not seem to get to the root of the problem ,with so many ,bios settings,and Clover settings,I tried very basic settings in both areas,and still nothing ,sometimes I get one screen wakes but ,have to force reboot ,with reset button ,or hold power button 

Share this post


Link to post
Share on other sites

It seems a paradox, on some motherboards, people I know, the sleep awakens with mouse and keyboard without flag AddclockID.

I saw that the flag was already present, try to remove it and see how it goes.

Some kext installed can give problems to sleep.

test all darkwake, and see if a particular one is better.

Share this post


Link to post
Share on other sites

 I can not make out  what your reply is I speak English , I only got your last part of the post  something about Darkwake.

I tried Darkwake options it's not waking from sleep ,the most i got was by pushing power button and I get screen and desktop but can't move mouse  ,I have to hard reboot or shutdown 

Drone4zone

Share this post


Link to post
Share on other sites

Hi, I really apologize for the misunderstanding.

I had written in English, but I do not know why the browser, has retranslated badly in Italian.
I happened yesterday, in two three post, honestly I had not noticed.
I apologize again, even as I write in English.
I edited my previous post.

Share this post


Link to post
Share on other sites

@gengikw84   hey man that did it it !! without ClockID I wake from sleep  with keyboard  screen pops on ,but  not control with mouse ...It's a leap forward 

it's about getting the setting correct now  here is what I have  clicked   under sections clover conjugator  Acpi SSDT Enable C2: Fixes Rtc8Allowed SlpSmiatWake :Arguments  Darkwake 10 slide=0 npci=0x2000 kext-devmode=1 :Devices USB inject FixOwership,SMBIOS Mac Pro 6.1

Share this post


Link to post
Share on other sites

I'm happy to help and a little 'time we make progress.

Try to remove the following flags, one at a time.
Reboot and see how it goes.
Flag that I will not serve: NPCI = 0x2000 slide = 0
You have applied the patch for the trim?
I saw that you have a SSD.
You have created the SSDT power management?

Share this post


Link to post
Share on other sites

I need npci=0x2000 slide=0 to boot ...I'm using  SSDT in patched folder clover from  x79 files from rampaged website overclocked  3930k  and trim for my SSD  when enabled cause my HD  corruption  ,it's a glitch I have with this Litton SSD it's made for Dell ,i read up on it has firmware locked  OEM  overtime i try TRIM setting I lose data and have to use windows to recover my drive correctly (shaking my head) that was a nightmare  so it off and runs ok 

Share this post


Link to post
Share on other sites

you have to create your own unique SSDT specific to your hardware.

If you nullcpupowermanagement.kext you should remove it.
You have installed OsxAptioFixDrv-64.efi?
I honestly do not think you need it to slide = 0
Even npci = 0x2000 unless you boot is stationary PCI Configuration begin.

Share this post


Link to post
Share on other sites

it would not boot at all without  slide=0 and npci=0x2000,I looked  in other install guides that's how I figured out how it would boot .i Don't know really what those boot flags are for ,but they actually make it possible for my system to boot other wise it will stall and or hang or restart loop .This board with X79 chipset are problematic but once you dial it in they are very smooth and fast .I got it all working except this wake up from sleep issue  which I could use it I leave the system on for rendering at long periods of time .

so far I have " unchecked ClockID " and It wakes up with dark wake set at 8,but I get one screen and mouse that is frozen ,I have to hard restart button or hold power .I really think this board will sleep and wake when I figure out all the settings .You mentioned  some kexts may be the cause of the problem,I have "RehabMan's version of USB3.0 driver and that seems to be solid and working without any issues like the other one's Ive used ,also the Audio is kexted injection and patched HDAkexti tried removing HDAkext and injector audio kext and still no wake ,so I think they are ok ,I have voodoo sync kext for the i7 cores to work .

Share this post


Link to post
Share on other sites

so far I get the system to wake  but sometimes i get a screen and desktop but that's about it  mouse curser is frozen ,have to hard restart or power down 

anyone at all have this board  running  osx86 ? DX79SR  ???

Share this post


Link to post
Share on other sites

@ gengike84,

I was going through clover configurator settings Acpi is there any sitting that I may  click ,and not sure about "New way" ,"Old way" ? I have  patched  SST in patched folder,with  "Drop OEM" checked 

Share this post


Link to post
Share on other sites

I have same MB but i'm trying now. Do you extracted and edited your DSDT? You can post all your files? I'm " frying my breans " to install here. And I try to edit the DSDT and unsuccessfully!

Share this post


Link to post
Share on other sites

@ NelsonF...

i got  most of things working  all but "wake from Sleep"....i have  custom  SSDT's to get USB's 2.0 working ,and  generics kext to get  3.0 usb ports  kinda working you have to hot plug them  to work ,but they work  blue ports..my DDST works  somewhat  good ,only having issues with Clover  settings to  get my system to  boot at a steady  time ,what I mean is that  sometimes  i will  hit space bar and  the system will not boot it will hang  when , select debug or  no cache selected,have to hit reset button  and then it will boot  perfectly,it may be the firmware in my SSD drives not sure ..your welcome to try my files to get el captain  working on your  DX79SR ..let me know I can upload you my efi folder .

Drone4zone

Share this post


Link to post
Share on other sites

Thank you for your response and if you can upload your files I appreciate immensely.

NelsonF

Share this post


Link to post
Share on other sites

Drone4zone, You can up your EFI folder, please?

Share this post


Link to post
Share on other sites

hey just wondering if you can share your files used to boot up with this board. Ive tried using the x79 file from rampagedev but i alwasy get a panic after installing the patched AppleIntelCPUPowerManagement.kext. Not sure if i have my settings wrong or what.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

×