Jump to content

[Guide] Asus G73JH using Clover UEFI


16 posts in this topic

Recommended Posts

Asus G73JH-X1 Functional clover installs and upgrades tested from 10.9.4 to 10.13.3

(10.9.4 is when i switched to Clover UEFI not the minimum OS supported)



  • I could only get the installer to boot by going into the bios and selecting the UEFI USB device
  • Custom Fusion Drives supported but not worth it.
  • You can't push button OC but you can still OC with Turbo Mode BIOS Setting
  • I am using APFS on my SSD but this guide does not cover usage
Hardware -

  • Processor:Intel Core i7-720QM - Bios Setting Asus Overclock to Turbo supported
  • Chipset: HM55 - config.plist
  • Battery: Status Indicator - Works ACPIBatteryManager.kext, SSDT-BATT
  • Graphics: AMD Mobilty Radeon 5870M Works Clover config.plist kext patches, SSDT-GFX0
  • Wifi: Atheros 9285(AR5B95) - SSDT-WLAN
  • Ethernet: Atheros 8131 - Works AtherosL1cEthernet.kext
  • Bluetooth: ASUS BT-270(BRCM1043) - Works BRCMNonPatchRAM2.kext
  • Card Reader: Alcor USB - Works OOB
  • Camera: ASUS UVC - Works OOB
  • Audio: Realtek ALC269 - Works G73JH.kext(contains dummy HDA), SSDT-HDEF
  • Keyboard & Trackpad - Synaptics Touchpad: Works VoodooPS2Controller.kext
  • Fn Keys - Works AsusHotKeys.kext
  • Keyboard Backlight - Works SSDT-MISC
Setup -

  • Bios settings

    • Enable UEFI Boot
    • Disable Intel Virtualization
    • Disable VT-D
    • Add New Boot option
    • Name: Clover
    • Disk: Select the drive with Clover and macOS installed
    • Path type "EFI\Boot\Bootx64.efi"
  • Create Clover UEFI USB macOS installer

    • EmuVariableUefi-64AptioMemoryFix driver required
  • Extracted DSDT/SSDT's(Boot Clover press F4 stored in \EFI\Clover\ACPI\Origin\)
  • MaciASL for SSDT's
  • Clover Config.plist - https://github.com/Maromi-/G73JH-OSX

    • SMBIOS serial# is not configured
    • Clover Hotpatch
Kexts - https://github.com/RehabMan?tab=repositories

  • Place files in EFI/CLOVER/kexts/other (remove all numbered folders)
  • FakeSMC
  • VoodooPS2Controller
DSDT/SSDT - https://github.com/Maromi-/G73JH-OSX/tree/master/Hotpatch

  • Download Hotpatch files
  • Open Hotpatch files in MaciASL save each file as filetype aml binary to \EFI\Clover\ACPI\Patched
  • Copy DSDT.aml from \EFI\Clover\ACPI\Origin to patched folder
Post Installation - Use kext installer to install below kexts to /S*/L*/Extensions

  • FakeSMC
  • VoodooPS2Controller
  • G73JH - https://github.com/Maromi-/G73JH-OSX
  • CodecCommander
  • ACPIBatteryManager
  • AsusHotkeys(Fn Keys) Not open source and not really needed
  • AtherosL1cEthernet
  • BRCMNonPatchRAM2
  • Like 2
Link to comment
Share on other sites

  • 2 weeks later...

Are you stalking me :)

Could you tell me where you installed the AppleHDA5Series.kext?

The USB key installer does not have S/L/E. 

post-install S/L/Extensions

also you should not use your old patched DSDT...i know that it won't get audio working

make a fresh patched one using the above instructions

Link to comment
Share on other sites

  • 5 months later...

hey looking to install El Capitain  which type of install is best option ,not sure why my bos will not boot "UEFI" mode  I try  settings create "Clover" as described but  all I get is a blinking  curer...will not boot

could non UEFI work as well ?


the Drone 

Link to comment
Share on other sites

  • 3 weeks later...
  • 3 weeks later...
  • 2 weeks later...

Hello. I have just finished installing Yosemite 10.10.5 on my ASUS G73Jh, but my screen color turns this:





I use the above config.plist


Edit: I have fixed it by enable LoadVBios and InjectEDID. It's working perfectly now.


you have to have a functioning proper SMBIOS otherwise your screen will do that.

Link to comment
Share on other sites

  • 11 months later...

Hi! First of all, big thanks to Maromi.

I`ve just installed successfully Yosemite+Clover (UEFI) @ g73jh, but my sound isn't working at all (no output sources).



I have installed g73jh.kext in SLE using KextWizard, but it doesn't show as `running` after reboot.


I`ve tried to:

1. Fix permissions and caches

2. Use nocaches in config.plist

3. Use some kexts to make it run (AppleALC, for example) ---- << I`ve already erased the kexts




Can you guys help me, please??? Thanks!


Cheers from Brazil.


Link to comment
Share on other sites

  • 6 months later...
  • 6 months later...
  • 1 month later...


-Switched Guide to Clover Hotpatching

-Removed OsxAptioFixDrv*+Emulated NVRAM drivers

-Use AptioMemoryFix(Clover can now boot with without emulated nvram and now has functional native nvram)

-Update reflects latest macOS version

Link to comment
Share on other sites

  • 1 month later...

Hi Maromi,

first want to say thanks for your work on this.

ive been trying to get to the clover boot screen, but only see a blinking cursor.  I’ve followed the guide perfectly, not sure what could be wrong.

only thing I can think of is my clover install maybe doesn’t have the right options ?

i selected clover for UEFI booting.  Installed aptiomemoryfix. As well as fakesmc and voodoops2touchpad


any ideas?

Link to comment
Share on other sites


  • Create New...