Jump to content
Sign in to follow this  
Followers 0
wildfire twister

Bioshock Infinite issues with 10.10.2

6 posts in this topic

Recommended Posts

Trying to run this game on 10.10.2 and it immediately crashes. Anyone else having issues with 10.10.2 and this game? I'm using latest Nvidia web drivers 343.02.02b04. I'm playing original game and downloaded from Steam. I have tried in off-line mode as well. I have also installed the latest security update 2015-3 though not sure if that would make a difference.

Thanks for any help!

Share this post


Link to post
Share on other sites
Advertisement

I have recently downloaded this from steam and it runs on my hack. The game may have to be launched from the steam app. The steam app needs to be listed in System Preferences>Security & Privacy>Privacy>Accessibility. I am running this on a system with 10.10.2 and an ATI graphics card.

 

-MH

Share this post


Link to post
Share on other sites

I have recently downloaded this from steam and it runs on my hack. The game may have to be launched from the steam app. The steam app needs to be listed in System Preferences>Security & Privacy>Privacy>Accessibility. I am running this on a system with 10.10.2 and an ATI graphics card.

 

-MH

Thanks for the reply! I will give this a try. I also worked through Aspyr support today and they told me to verify integrity of game cache in Steam.

Share this post


Link to post
Share on other sites

Verifying integrity of game cache worked. If anyone else has this issue right click (ctrl+click) Bioshock Infinite from the Steam Library menu and select Properties. Under the Local Files tab, select Verify Integrity of Game Cache. Once that completes, relaunch the game.

 

Loaded game up and while it looks very good I'm quite bummed the High and Ultra texture detail and texture filtering settings do not seem to be available on mac version. The highest setting is "Normal". Is there a work around for this? I searched the internet and could not find anything. My hardware is more than capable of playing the game at maxed out settings (though I understand that the mac does not have DX 11 and performs significantly worse than Windows in open GL).

I was really looking forward to having another game to play when I boot to OS X. It looks like I will have to move to my Win 8.1 drive. If anyone knows a fix please let me know.

Thanks!

Share this post


Link to post
Share on other sites

There is no "fix", the higher quality textures, shaders and whatever else probably isn't even in there.

 

It's a perfectly sound business decision and you'll see the same thing in every Mac port. When Aspyr ports a game to OS X of course they aim for high compatibility with consumer-grade Macs. That means lowering the system requirements for the game.

 

The only Macs with powerful video cards anywhere near PC "gamer" cards are Mac Pros and those are typically used for business purposes, not gaming. Mac Pro owners are not part of Aspyr's target audience, much less PC owners running OS X.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×