Jump to content

Need help. Keyboard acting weird post installation Dell XPS L501x


4 posts in this topic

Recommended Posts

I installed 10.10.1 with clover. Installation went fine and there no errors. During installation my keyboard was not getting detected, so I used external USB keyboard. 

Now post installation, I am booting with the same installation USB and keyboard is not working properly:
1. Sometimes it works fine. Or I have press some keys twice 
2. It doesn't work at all
3. It acts weird, if I press any one key it starts putting some random character many times and then it stops working. 
Usually trackpad never worked without kexts, but it sometimes it also works. Once I move it, it stops working.
I think this could be because of my wrong clover config and may be clashing kexts. (Note: I have not installed any kexts and not installed clover also). However I have patched AppleGraphicsControl.kext with my Board ID.
I have got some kexts which have been working since Lion, ML and Mavericks. I don't know why they stopped working. Earlier I was using Chameleon, now switched to Clover. So I guess I did something wrong with clover config.
Following are those kexts, note that these are modified/patched kexts which work with Dell XPS L501x:
and then I download latest FakeSMC and add it.  
Currently all these kexts reside in Clover/kexts/10.10 (and I when boot with Clover, these also should get loaded right?)
So, here is my clover setup:
ACPI > patched > DSDT.aml
drivers64 directory:
drivers64UEFI directory:
Kexts > 10.10: kexts I listed earlier
Kexts > Other: Empty
One of the mistakes I spotted was, I have mentioned patch for AppleRTC in config.plist and also have the kext patch for it in kexts/10.10, so I guess I should not do that. 
Do you see any more mistakes with my config which could be conflicting with keyboard/trackpad behaviour?
Link to comment
Share on other sites

It looks like @tuxuser has a similar machine to you and has already posted his Clover config files & kexts in the Dell L501x/L701x thread.  Also @whitegerry in post#435.


Some suggestions for your issues:


Re Internal Keyboard & Touchpad not working

@tuxuser recommended disabling USB Emulation in BIOS to get VoodooPS2Controller.kext working.  Try the VoodooPS2Controller.kext in his kext bundle instead of the AppleACPIPS2Nub & ApplePS2Controller kexts you are currently using.



Have you tried the updated GenericUSBXHCI.kext from this post by @Victor Vos?


Re Audio

Have you tried VoodooHDA.kext with HDADisabler instead of patched AppleHDA?


Audio kexts usually need to be installed in /S/L/E due to other kext dependencies.  For Yosemite, any patched kexts (including patched AppleHDA) will have invalid signatures so you will need to boot with kext-dev-mode=1 kernel flag.


Other recommendations

  • Only install kexts you really need and some of your kexts maybe too old/incompatible with Yosemite.  I would leave only the essential kexts like FakeSMC.kext, VoodooPS2Controller.kext in /EFI/Clover/kexts/10.10. 
  • For all the other kexts, ask yourself the question: what does this kext do and do I really need it?  I would install them one by one in /S/L/E using kext wizard, making sure each kext functions properly in Yosemite and doesn't harm booting. 
  • Clover patches the native AppleRTC.kext on the fly so no need for patched kext here.
  • Clover can patch IOAHCIFamily.kext on the fly and enable Trim automatically - see @Marchrius's guide.
  • You can delete VBoxHFS-64.efi from /drivers64 and /drivers64UEFI folders since you have HFSPlus.efi
  • You can remove

    since your CPU is not IvyBridge or Haswell.

  • Like 1
Link to comment
Share on other sites

^ thanks for the advice!


I checked the thread and looks like I have to try disabling USB Emulation, however if I do that I can't boot USB drives. So first I will install clover on my SSD and try that and report back


And I will also follow other general advice you gave!

Link to comment
Share on other sites

I downloaded @whitegarry's kexts as mentioned herehttp://pan.baidu.com/s/1mgKEu4w



So I loaded kexts/config as instructed, but display doesn't appear at all. It gets stuck after 'Missing bluetooth controller transport'. I followed every instructions as given. 


1. I am using hardware uuid as Custom UUID:




2. I generated EDID and added in config:




However screen gets stuck. So I used my earlier config and booted. It works. Then I started changing each field of my config to match that of Whitegarry's. And I guess I got almost identical. And it still works! I am comparing each field in Clover Configurator and they are identical. So I don't know why it doesn't work :-/


I am attaching three files. 


1. The whitegarry given, but edited according to my system, i.e. added EDID and GUID. -- Doesn't work

2. My config which I started from scratch, matches with #1. So it is same as 1. -- WORKS! 

3. Same as #2, without EDID/Graphics section.


I don't understand why #1 wouldn't work :|


With #2, laptop turns on and works. however graphics performance is not quite right, i don't find it snappy enough and it turns off after few mins of usage. So I tried removing EDID/Graphics and now it seems to be fine. This is third config. Does wrong EDID can result in laptop shutdown?




Link to comment
Share on other sites


  • Create New...