Jump to content
InsanelyMac Forum
ACDindia

Intel HD4000 QE/QC weird issue

Recommended Posts

Hey guys!

 

I have been struggling with this weird issue since last 15-20 days..!

 

Now I think I have narrowed down the error..

 

My system:

 

Dell Inspiron 7720 Laptop

Intel 3rd Gen Core i7 3630QM

Intel HM77 7 series chipset

Intel HD4000 + nVidia GT650M DDR5 2 GB optimus (Never works, I know) 

Using Clover UEFI Bootloader on UEFI system

I have a DSDT for my laptop. But have tried with and without it too.

 

What happens:

The Intel HD4000 works with QE/QC for a couple of times after fresh install. Then suddenly it stops working, although it is detected as usual. AGPM Capri and HD4000 kexts are loaded still I get no QE/QC... AGPM says "Unknown Platform"... I used a LegacyAGPM.kext to get around with that.
 
Now when the QE/QC is broken, I reboot the computer and in Clover deselect "GeneratePStates" and "GenerateCStates".... QE/QC is back!!! Again after couple of reboots, it is broken!!!
Now again i select "GeneratePStates" and "GenerateCStates", QE/QC starts working for few reboots!
 
What is my problem???
Please help!!
Anyone????

Share this post


Link to post
Share on other sites
Advertisement

about agpm, use the original and just replace gfx0 for igpu in the dsdt.

Hmm... The problem is that I use MacBookPro9,1 SMBIOS which is closest to my laptop's configuration.. And AGPM kext doesn't have an entry for MAacBookPro9,1....

Share this post


Link to post
Share on other sites

it doesnt matter. replace on dsdt gfx0 for igpu.

 

Hey! It doesn't make any difference!!! :(

Thank u for the suggestion anyways!!!

 

What the hell is wrong!!! :(

QE QC Works for a couple of times with GeneratePstates and GenerateCstates then stops working.... then if I disable GeneratePstates and GenerateCstates, starts working again!

then stops again... repeat the method by enabling GeneratePstates and GenerateCstates and it starts working for a couple of times... then again disable them both....

This cycle!!!!!

 

Any clues ????????

Share this post


Link to post
Share on other sites

No clues anyone??
Nothing at all??

I'm still facing this issue even after 10.10.3 update...

 

Doesn't anyone have any clue about this issue?? :(  :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By Soeren_DK
      Hi there.
      I'm new to this site but not totally new to hack. I've had a hack since 10.4 and the latest version I ran was 10.9, not totally fixed but it worked to what I needed. Now I want to make the machine run as good as it can. I can see there has been a lot of changes/upgrades/new solutions since I installed my hack and I have a hard time to catch up.  
      I've been able to boot and install macOSX and now I need the POST installation.
      I tried to install the clover EFI boot loader with these settings:
       
      and found the DSDT.aml and SSDT-0.aml from HERE
      found the apfs.efi
      and placed it in EFI -> EFI -> CLOVER -> driver64
      and these kext in here:

       
       
      But when I boot it up this is the first bootscreen I have. No partions, no mouse control, no nothing.

      if I exit clover this screen appear.

      and now everything works. 
       
      What is wrong?
      Cheers
      Soren
    • By jojo2203
      Hallo,
      habe versucht nach der Anleitung von http://x220.mcdonnelltech.com/  auf einen X220 i7 zu installieren, bisher leider erfolglos. kann mir jemand die angehangenen Log Meldungen interpretieren und einen Tip geben an welcher Stelle ich weiter probieren muss. Habe es schon mit den folgenden Bootparametern probiert
      -v -x -s -f cpus=1 maxmem=4096 GraphicsEnabler=No -no-zp
      Es war ein 8 GB Speicherriegel gesteckt und die "neue" WLAN Karte, außerdem ist zusätzlich zur MSATA eine weitere HDD installiert.
       
       


    • By xuzhin
      System:
      Asrock X79 extreme6 p2.50
      Nvidea GeForce gtx 770
      i7-4930K @ 3.40ghz
       
      i'm trying to start fresh. i have a working mavericks, but i want to install sierra and not high sierra, because some pro tools plugins don't work on high sierra yet.

      either way, i created the usb boot stick with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and dragged [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] on there, i get to the clover boot screen, and can't get any further, i see the black screen, apple logo, loading bar appears, but doesn't start moving at all. i guess some boot settings are wrong, for the old mavericks system chameleon used:
      <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict>    <key>SSDT</key>    <string>Yes</string>    <key>GraphicsEnabler</key>    <string>No</string>    <key>PciRoot</key>    <string>1</string>    <key>EthernetBuiltIn</key>    <string>Yes</string>    <key>Kernel Flags</key>    <string>npci=0x2000</string>    <key>UseKernelCache</key>    <string>No</string> </dict> </plist> now i don't have any idea how to get those settings into the boot options of the clover bootloader, i've been trying to change a few settings, but i've gone through 10 different clover boot settings combinations, with no luck.
       
      anybody that can help me?
       
      i couldn't find a guide on this site, not even one that explains how to create a sierra usb stick to boot with. sorry guys i'm really not good with this.
    • By shockforcetx
      I finished my hackintosh a couple of days ago. I am a gamer, but I'm also a web programmer. For years i've struggled with the dilemma of running 2 different (and sometimes more) computers for work and for play. Anyone who's gone through this understands that pulling all your monitor cables, mouse, keyboard, headset and other peripherals out of one computer and into another is a gigantic pain. So my goal here was to build a bad ass gaming PC that would allow me to push the limits of my Acer 144hz gaming monitor (so 140 - 160fps @ 2560x1440 resolution), but also have FULL native compatibility with Mac osX with as little hacking as possible.
       
      I can say after having used this for several days for web development and all of my routine mac osX tasks, it is an absolute dream mac. It's by far the fastest, most awesome mac computer I've ever used. The windows 10 gaming side is just as bad ass and I'm achieving 125 - 150fps in Battlefield one on high settings at max resolution. It's a beauty. You just restart and choose your OS and you're on your way. 
       
      As far as the install goes, I didn't have to do anything special except use the nvidia web drivers flag when booting. The bluetooth on the ASUS rog Maximus Viii Formula works out of the box, the tp-link n900 wifi card works out of the box and all other hardware, so this was a completely painless osx install and so far I have not crashed or had a kernel panic even once.
       
      Hardware:
      Motherboard - ASUS ROG Maximus VIII Formula Motherboard
      Processor - Intel i7 6700K @ 4.0Ghz
      RAM - G.Skill DDR4 PC2133 64GB (4 x 16GB)
      GFX - Gigabyte Aorus Nvidia GTX 1080 TI 11GB
      WI-FI - PCI-E TP-Link N900 Wireless Card
      Cooling - Thermaltake Pacific Liquid Cooling with Thermaltake RGB Waterblock and Dual Radiator with RGB 120 Fans
      PSU - 850 Watt Thermaltake RGB Power Supply - Gold Certified
      USB 3.0 - Working!
      USB C - Working!
      SSD - Samsung 850 Pro 256GB SSD
      HDD - Western Digital Hybrid 3TB / Flash HDD X 2
       
      Made a video about this here: https://www.youtube.com/watch?v=lyEqpFR12KE
       
       












    • By asdfjklsemicolon
      I have successfully set up my HP Pavilion 15-p051us as a hackintosh with Sierra 10.12.5. I have an AMD A10-5745M APU with Radeon 8610G Graphics. The OS boots and is usable, however there is no graphics acceleration which makes icons in finder and notification bar look strange and launchpad is really slow.  
       
      How can I enable QE/CI acceleration on my APU?
×