Jump to content

voodoo hda temporarily fix lost sync after couple minutes

Go to solution Solved by Roxasss,
5 posts in this topic

Recommended Posts

btw my first post so sorry if this is not perfect

so, my acer 4738 got no compatible applehda (at least yet)
so in the mean time i use voodoohda which is keep crackle after couple of minutes

and to fix it i must manually refresh the audio format in MIDI to make it better (repeatedly) 

yesterday i got an idea from some comments in a post that said maybe we can automatically refresh the audio format from terminal
so i search it in the internet and manage to make some terminal command that did the job
here it is:
sudo killall coreaudiod

just type it in terminal and your audio will be good as new

and then i read in some website there is a comment that can repeat a command in some interval 
it is called "watch" ,but you need to disable password in sudo command because with pass in sudo

the loop will stop to ask for pass input.
here is the way to install watch :


instal watch :

We are using “curl” a command line “broswer”
"curl -O http://ktwit.net/code/watch-0.2-macosx/watch"(copy to terminal without quotes)

Make “watch” executable
By doing this we tell Mac OS that this is a program that can run
chmod +x watch

Test the program
Let’s make sure everything is in working order.

Install “watch”
Optional: By following this next step we are placing watch into a system location that will allow you to run it from any location in the Terminal (You will be prompted for your password)
sudo mv watch /usr/local/bin/

Congrats, you have added the watch command to your Mac OS X System.


here the way to disable sudo pass


first show hidden file with this command in terminal :

defaults write com.apple.finder AppleShowAllFiles YES

and then  follow this



and here if you don't know how to login as root

and after making the pass logout and login as other with the name "root" and the root is your root pass


after you finish making password-less sudo here the command

watch -n 900 sudo killall coreaudiod ==> comand automatic every period of interval

900 is interval = 900s


sorry if my english not that perfect
i'm just typing without thinking the grammar ;) (Asian ^^)



any1 is welcomed to help me making some script to make it run at star up  :drool:

  • Like 1
  • 1 month later...
  • 1 month later...

your problem exactly same like my pc, only with different number, my pc is 4739, and the sounds only takes 20 minutes  to work fine, but after that it starts tu crakcles,,.. and need to change the bitrate in AUDIO MIDI.. .. btw this is a nice oh sorry great post :D :D

  • 4 months later...

I have this exact problem in 10.10.3, except it lasts 1 second before desyncing. VOX does work, but VOX can't change bitrate fast enough. I have 2 0.5-second silent WAVs of 44.1/48kHz on a looping playlist.


And after a while even VOX method stops working...

  • 1 year later...

I have exactly the same problem with the same acer 4739!!! And I just find out that the problem is with IOAudioFamily.kext. You need replace with this one

Don't use AppleHDA use the last voodoohda 2.8.8 and if you have the same codec as me you can try my info.plist here 


patche para minha placa Info.plist.zip

  • Create New...