Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
Sign in to follow this  
Uboss

voodoohda auto-switch problems

Recommended Posts

Hey guys!,

 

There 2 weeks now i did a success install of voodoohda on my hackintosh running osx 10.9.4, all my outputs (exept hdmi one) are working and the sound appears to be in a good quality. Actually the only probleme i have is about auto-switch: when i plug in headphone into my laptop the sound should go out from my headphone output but it stuck on the speaker one.. Im always forced to manually switch outputs.. 

Does anyone have a suggestion to solve that?

PS: sorry for being lame at speaking english but im french in real.

Hopefully you guys will bring me a solution :)

Share this post


Link to post
Share on other sites
Advertisement

Hello!

 

It is hard to give you support without knowing your hardware, install method, used bootloader and smbios and especalliy about your soundchip.

 

Please put your hardware in your signature, like many others have done here.

 

For solving the voodooproblem by yourself, you need a dump and correct the the headphone node.

 

Have fun.

Share this post


Link to post
Share on other sites

Hey styrian,

 

Indeed i forgot about posting my HW specs, 

 

there my ioreg and my dump.txt uploaded from dropbox:

 

https://www.dropbox.com/s/83kz1460i1rxlxs/MacBookProdeUgo.iojones

 

https://www.dropbox.com/s/up25big0ebyc7eh/dump.txt

 

My boot loader is clover EFI and this is a

 

MacBookPro 8,1 intel i3 1,4GHz, my mb is a x201e. (laptop mb)

 

My sound chip is HD Audio controller alc269vb, codecID 0x6902EC10

 

Yes i tried to edit my headphone node in the NodeToPatch section in the info.plist but nothing.. 

 

But i ve heard that voodoohda didn't support auto-switch as applehda, did it?

 

Hopefully this will help you more finding a solution :)

Share this post


Link to post
Share on other sites

Hello!

 

Try to find a working patched AppleHDA.kext for your alc269VB for an other device for your device brand. For laptop it is here common usual to tell also it´s brand and device specifier. You can also try to switch over to version 2.8.6 of voodoohda. Here you go for it: http://ourceforge.net/projects/voodoohda/ In any case you need an untouched original ioaudiofamily.kext to get voodoohda fully working.

 

And one again: Please put your hardware in your signature, like many others have done it here.

 

Have fun.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×