Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Help Mavericks won't start mac os version not yet set

5 posts in this topic

Recommended Posts

Hi everyone I have in 4 HDD Windows 7, ML and on another HDD Mavericks installed and must say all was running just great
Today wanted to start Mavericks and I got a panic mac os version not yet set
So wanted to check the disk in Mountain lion which was working fine as well and the same mac os version not yet set came up.
Just wanted at the end to check the diskutil from the DVD and again even the DVD is showing mac os version not yet set

I checked the bios but all is just fine there and no changes were made.

I am using a Asus P5Q Pro with Nvidea G210 4GB DDR

Did not make any hardware changes...
tried to boor with PCIRootUID=0 and also with -s


Any ideas?

Thanks in advance

Share this post

Link to post
Share on other sites

Thanks for the reply but I just did that and at the install the same (as I wrote above) messages panic comes up

A format is the last resort just wonder why and Mavericks and Mountain lion suddenly does not work anymore
Its a original Mavericks DVD and installed Mavericks over 4 months ago without any problems

Share this post

Link to post
Share on other sites

ok no one can give me any idea as with re-installing Mavericks with all the right flags the panic also comes..I tried to reset the bios, deleted from the bios all user data but can't get into the Mavericks setup...

Share this post

Link to post
Share on other sites


For any one that does have the same problem and panic here is the solution, just did it and all my OS again are working with no problem at all


The problem is caused by the bios of your PC this when you use dual boot, in my case windows 7 64, Mavericks and Mountain lion each operating systems on a different Hard drive.

Windows goes and stays inside the memory of you motherboard

So make the bios again clean (in my case a patched bios)



Hit the power switch

Now put the battery back inside


Do a new setup inside the bios like AHCI instead of IDE


reboot your hackintosh and you will see all is ok again

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.