Jump to content
Sign in to follow this  
Followers 0
majuss

Strange display issues - external monitor listed as internal (Asus K73sv)

7 posts in this topic

Recommended Posts

Hello there, 

here is my spec:

 

Asus 15" K73sv

1600x900 internal screen is completely destroyed

i5 Sandy 2410M

NVidia 540M 1GB

Display output via HDMI & VGA

 

Using 10.9.3 and latest Chameleon (78)

 

No custom DSDT

----------------------------------------

 

I have really strange display issues.

When I connect a display via HDMI everything just works perfect and I can use a resolution up to 1080p on my BenQ.

Put I'am setting this Asus up for a friend and he only got a VGA Screen with a reso auf 1600x1050. When I connect the laptop via VGA the screen is stretched and flickering like hell. This does not appear with a HDMI display. After I started looking where the problem is coming from I noticed that in the systemsettings the external monitor is listed as an internal so I can set a maximum resolution of 1600x900. While the bootloaders GUI is shown in the native resolution of 1600x1050 but as soon as the loading sun disappears the resolution is setted to 1600x900.

 

So there are different ways to help me. First thing will be to set the internal resolution easily to 1600x1050 or say the bootloader to load the whole system in this resolution. Second thing is to get the 540M fully functional (what is impossible i think?). Third thing would be loading a custom EDID into the system. (I could extract the EDID via VGA with a other Mac)

 

Here is the EDID from the external screen extracted with the Asus and the screen is clearly listed as "AppleDisplay":

ioreg -l | grep -5 IODisplayEDID
    | |   | | |     {
    | |   | | |       "IOClass" = "AppleDisplay"
    | |   | | |       "CFBundleIdentifier" = "com.apple.iokit.IOGraphicsFamily"
    | |   | | |       "IOProviderClass" = "IODisplayConnect"
    | |   | | |       "DisplayProductID" = 721
    | |   | | |       "IODisplayEDID" = <00ffffffffffff0030e4d1020000000000140103802615780a88a59d5f579c261c5054000000010101010101010101010101010101012f2640b860840c30303023007ed710000019000000000000000000000000000000000000000000fe004c4720446973706c61790a2020000000fe004c503137335744312d544c4e32002b>
    | |   | | |       "IODisplayPrefsKey" = "IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/GFX0@2/AppleIntelFramebuffer@0/display0/AppleDisplay-30e4-2d1"
    | |   | | |       "IOPowerManagement" = {"MaxPowerState"=3,"CurrentPowerState"=3}
    | |   | | |       "IOProbeScore" = 2000
    | |   | | |       "IODisplayParameters" = {"bgsc"={"min"=0,"max"=65536,"value"=65536},"rgsc"={"min"=0,"max"=65536,"value"=65536},"bklt"={"min"=0,"max"=1808,"value"=0},"ggsc"={"min"=0,"max"=65536,"value"=65536}}
    | |   | | |       "IOMatchCategory" = "IODefaultMatchCategory"

Thanks to everyone who read my rock of a post :)

Share this post


Link to post
Share on other sites
Advertisement

Yeah I mean "read" ^^ It's not my native language.

 

I will try out the injected EDID tomorrow but I don't think that this will change anything, cause problems caused by wrong EDIDs doesn't show this behavior. 

Share this post


Link to post
Share on other sites

Hmm maybe look for internal screen code in DSDT and strip it?

 

And/or try using a non-laptop model identifier..? Except that could have undesirable side effects on power management..

 

Thanks for your reply. Where can I find the internal display in the DSDT? Sorry I'am a newb at editing the DSDT.

The power management is not that important because a external screen is necessary so the "mobility" is not there :D

 

 

Here is a patched DSDT (patched with rehabmans patches and others found in the download of "DSDT Editor") and the raw one.

 

Raw DSDT

Patched DSDT

Share this post


Link to post
Share on other sites

IF there is code for the screen in DSDT (I guess there is - have never hackintoshed a laptop) you can try to find it with IOJones or IORegistryExplorer (comes with Apple dev tools). Find the GPU in the device tree, the screen will be attached to that.. obviously.. then try to find a three or four letter abbreviation for the screen "device" and look for that in your DSDT.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By rxfx
      So I’ve been working at trying to get the wifey’s [HP Envy Recline 23-k310 All-in-One]’s display to properly wake from sleep for months now. I’m kinda at my wits end; It’s probably something so simple and I’m overthinking it.
       
      The computer sleeps properly, but when it wakes, I get no display (no backlight either). The keyboard and peripherals seem to work after wake; able to key in the passcode/password and sound works when I use the volume up/down buttons. But I get absolutely no display. I’ve done 3 other successful hackintoshes (though, none had any dGPUs/eGPUs). But I’m somewhat confident that I’ve disabled the Nvidia Optimus (NVIDIA GeForce 830A)/N15S-GM) I couldn’t find any _ini when I poll the SSDT’s and no signs of Nvidia In System Report, Hackintosh, or IOReg. It’s disabled via the Frame Buffer patch in clover (I use 0x0D220003 for platform ID. I definitely have the Lilu and Whatevergreen kexts in L/E. I’ve tried a plethora of Clover settings, changing SMBIOS’s, darkwake bootflags, and AppleBacklightfixup.kext in both Clover/Kexts and L/E to no avail. Power management has been set using the Pike R. Alpha ssdtPRGen implementation. I’ve gone through and setup the proper SSDTs for the USB patching. Besides adding the HDMI audio output patch (which I don’t use/or have anything plugged into since its an AIO), everything else works on point. But…
       
      “Help me Obi-Wan[’s], you’re my only hope!!”
       
      I’ve attached an “Error Report.zip” including an IOReg report, config.plist, and a generated report form black.dragon74’s tool. I would love any recommendations or possible fixes/files/patches to these files to resolve this issue that has been stumping me for months.
       
      HP Envy Recline 23-k310 AIO
      Intel i3-4330T
      Intel HD Graphics 4400
      8GB 1600 MHz RAM
      Intel H87 Chipset [HP/Quanta Laurel2-1G mainboard]
      macOS Catalina 10.15.3 (with iMac 14,3 SMBIOS)
      Error Report.zip
    • By JTSaysWhat
      My rig is working great driving a single display from Vega 64 via DisplayPort, but I'm having a devil of a time getting a TV monitor working via HDMI on the same card.
       
      My TV lights up an input icon when I plug it to the Vega (see attached--notice the next port w/ nothing plugged in is grayed out). So I know some electrons are flowing (maybe EDID?), but it never gets a signal. I've tried several HDMI 2.0 cables.
       
      I'm running a vanilla install of 10.14.6, as iMac19,1, with just Lilu (1.3.8) + Whatevergreen (1.3.1). System recognizes the Vega and seems to be correctly using the UHD630 headlessly. I just can't get HDMI out of the dGPU...
       
      I've tried the "-raddvi" and "agdpmod=vit9696" boot args, no dice. I've tried the kext patch workaround for disabling board verification, also no go (not surprising as I think that method is now obsolete for my setup).
       
      I hit the same wall running 10.14.2 as iMac18,3 with a different platform-id before updating.
       
      Here's my whole EFI.
       
      Any assistance at all is hugely appreciated!! Thanks y'all.


    • By tragediana150
      Hi everyone!
      Long time no see guys!
      As you can see I am not new user of Insanely and do not want to post in incorrect section, but I can not find any similiar topic at all. I,ve searched the forum and the web and I can't find a solution.
      My question is that is there any possibility to install Mavericks 10.9.5 on external drive on the newest Macbook Pro 13 from 2018? I know that the Intel Coffee Lake is new generation of CPU's and there is no drivers in Mavericks system to run this CPU, but I was thinking about it alot and I decided to write here. Because if we can install all the newest OSX, macOS on older machines then maybe we can install older systems on newer builds?
       
      P.S. If I wrote in incorrect topic then please move this thread to the right section, I will be grateful
    • By dannymozzer_
      Hi,
       
      I've been trying to install Mavericks 10.9, I know it's older now, but It's honestly the version I want to use, the specs of the PC are:
      Asus P8H61-MX USB3
      i3-3220
      8GB DDR3 Memory
      GTX 750 ti
      500GB HDD
       
      I've been following this guide: https://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners-updated-for-yosemite/
      But, after booting, this is the error screen I get, any guidance on what Kexts, SMBios settings, etc. I need? I can tell I'm probably missing something here.

      Thanks,
      Dan
×