Jump to content

Issues with Mavericks on a Gigabyte GA-H87N-WIFI Motherboard


3 posts in this topic

Recommended Posts

Hi all,


So I am trying to get a hackintosh running for a friend of mine and I am running into some issues.   Here is my hardware setup

  • Gigabyte GA-H87N-WIFI LGA 1150
  • Intel Core i5-4430 Quad Core Haswell @ 3.0 Ghz
  • 16GB Corsair Vengeance DDR3 1600 MHz PC3-12800
  • 240GB SSD

I used the CustoMac Mini Deluxe build, the only thing I left out of the list was the video card, which was listed as optional


So, I originally tried to follow tonymac's tutorial which did not get me very far. During bootup after finishing the OS install, I would get a whole screen full of distorted lines and the process would not go any further.


So I decided to try another tutorial to try and get mavericks installed. The second time around, I used this tutorial for installing a vanilla OS X 10.9




This tutorial seemed to be much better, but after I do the initial install of OSX onto my SSD (btw, the only way I could get the installer to load was via the –x  -f –v flag during boot) I am getting a kernel panic.   I have quite a bit of experience with UNIX/Linux so I am not at all afraid of the command line, but I have to admit some of the messages that get spit out in verbose boot make it sound like your computer is just about to commit suicide in some graphic and dramatic way.    Here is a screenshot of the kernel panic that I am running into (btw, this is also when I use the –x –v –f boot flags – for some reason it worked without issue the first time, but at the point of the tutorial where I am supposed to boot back into the installer and run a few things in terminal, I am not able to get back into the installer to load up the terminal application).




I should mention that when I view the boot process with the –v (verbose) flag, I do see some error messages that say something about the CPU not being compatible with the system, even though this processor is listed on the site that specs out hackintosh builds.

Occasionally the boot process seems to get hung up on something related to Bluetooth as well, but I do not have a picture of the output readily available.   I can upload a pic when I get home from work tho (that is, if I can get it to fail in the same way)..


Any idea what is going on?

Edited by fantomas1
Post edited, tonymac's links deleted! We don't support his tools!
Link to comment
Share on other sites


but me not understand your boot......arguments :hysterical:

npci=0x3000 -v -x -f........?????????

what is this?maybe any secret?

BootCasheControl is not a your problem... :(........

We need more.... :D

Edited by fantomas1
Topic cleaned!!!
Link to comment
Share on other sites

First, I'm absolutely not super knowledgeable about this stuff... but my recommendation would be:

A) check BIOS settings. I would start here http://www.insanelymac.com/forum/topic/294837-vanilla-mountain-lion-install-intel-hd4600-onboard-graphics/

b )While you're in your BIOS, change it to boot the USB stick first. It appears to be trying to boot from your main drive, and you have diskutility/terminal from the installer. 

Link to comment
Share on other sites


  • Create New...