Jump to content

Intel HD Graphics (Haswell GT1) QE/CI

12 posts in this topic

Recommended Posts

My brother's asked me to install os x on his rig. First I've tried mavericks, and I couldn't get any graphical installer. Last week I've tried 10.8.5 and it worked. I made a good progress sound and network works like a charm. The only remaining problem is the lack of qe/ci. I know it is not supported by default since there's no real macs with pentiums or celerons.


CPU: Intel Pentium G3220

Mobo: Asus B85M-G


Has anyone got it work yet? Any ideas how to make it work? (I know problem can be solved by buying a cheap video card, but first I ask here if anyone has made it work.(

Link to comment
Share on other sites



try to put this in your chameleon.org.Boot.plist







X => a_value from 0 to 15


Hi, Thanks, tried them all. All gave black screen except 15, it gives gui, but still no qe/ci. I have set 64MB igp ram in bios before. AppleIntelFramebufferAzul kext is loaded, but AppleIntelHD5000Graphics is not. Could that be a problem? Is there anyway to force the latter to load?

Link to comment
Share on other sites



The graphics unit of your Pentium should have device id 0402 (vendor id is 8086 for intel as usual ;) ). Unfortunately there is only device id 0406 (GT1 mobile) present in AppleIntelHD5000Graphics.kext. You could try to swap the 0406 to 0402 in the info.plist and cross your fingers the device id isn#t present in the driver itself (could also be swapped using a hex editor like 0xED) and there are no difference between the desktop and mobile version of GT1/HD4200.


Keep in any case an untouched copy of AppleIntelHD500Graphics - if it doesn't work or you don't dare to modify the driver itself, you could restore the original kext and give Clover boot loader a try. Maybe it's FakeID function will do the trick.


Good luck!

  • Like 1
Link to comment
Share on other sites


  • Create New...