Jump to content

R9 280x HDMI audio


Voodoo90
 Share

2 posts in this topic

Recommended Posts

Hello,

 

I switched my graphics from a gtx 460 to a R9 280x. The card is working OOB except the HDMI audio.

I'm using VoodooHDA 2.8.4 and this made even the HDMI Audio from my GTX 460 work, but now it doesn't with the R9.

 

I'm using Ozmosis and therefore no DSDT. I haven't been lucky with any guide so far.

In system information it detect an audio controller from ATI and marks it as unknown device.

 

Any help here?

This is really the last thing not to work. After this everything works just fine.

 

Thanks a lot.

 

Link to comment
Share on other sites

Hello,

 

I switched my graphics from a gtx 460 to a R9 280x. The card is working OOB except the HDMI audio.

I'm using VoodooHDA 2.8.4 and this made even the HDMI Audio from my GTX 460 work, but now it doesn't with the R9.

 

I'm using Ozmosis and therefore no DSDT. I haven't been lucky with any guide so far.

In system information it detect an audio controller from ATI and marks it as unknown device.

 

Any help here?

This is really the last thing not to work. After this everything works just fine.

 

Thanks a lot.

That is very strange. Try these steps to see if you can get it to work:

Go into System Preferences, then select Sound, and then select output. Make sure that your HDMI device is selected. If that doesn't work try doing the steps below.

 

Add device id into ATI7000Controller.kext. Go into System/Library/Extensions and right click ATI7000Controller.kext and select "Show Package Contents" Proceed through the contents folder and open info.plist.

Edit the info.plist and add this device id:

<key>IOPCIMatch</key>
<string>0x67981002</string>

Save the file as ATI7000Controller.kext to the desktop and replace the file in S/L/E/ after words run kext utilitiy to repair permissions.

Link to comment
Share on other sites

 Share

×
×
  • Create New...