Jump to content

Help Mavericks on MSI 760GM-P23


13 posts in this topic

Recommended Posts

I managed to install Niresh's Mavericks on my PC.


First, here's my specs:


Motherboard: MSI 760GM-P23 (FX)

CPU: AMD Athlon II X2 250 3.00GHz

Chipset: AMD 760G

RAM: 2GB PQI DDR3-1333

Graphics: (Integrated) AMD 760G/ATI Radeon HD 3000


I have Windows 8.1 and Linux Mint in 1 disk.

And, I installed OS X on the same disk with already 6 partitions.

Partitions layout is:

disk0s1 = System Reserved.

disk0s2 = Windows NTFS <-- C: drive.

disk0s3 = Windows NTFS <-- D: drive. Where my main files are.

disk0s4 = Start of Extended Partition.

disk0s5 = Linux <-- Where Linux Mint installed.

disk0s6 = Linux Swap Space.

disk0s7 = OS X.


What I did was:

  1. Boot to Niresh-Mavericks with the boot flags: amd -v
  2. Thought it was stucked on "[AGPM Controller] unknownPlatform;" but it booted after a while.
  3. Went to Disk Utility to erase the partition where I'm going to install OS X.
  4. Default kexts/and other options on Customize. (Didn't changed anything.)
  5. I let it install.
  6. After installation I have boot0:done.
  7. Booted the installed OS X using USB with the flags: GraphicsEnabler=No -v (I can't manage to boot with GraphicsEnabler=Yes)
  8. Sounds/Ethernet are okay.



I need help on my display as I am stucked on 1024x768.

Also with the boot0:done, I tried reinstalling Chameleon, Chimera. Even installing the binaries manually didn't help.


If you need anything else, just ask. Thanks in advance.

Link to comment
Share on other sites

Thought it was stucked on "[AGPM Controller] unknownPlatform;" but it booted after a while.

If you want to have full QE/CI you need to edit your Vendor ID and Device ID in proper section of AGPM.kext (depends on which smbios you are now).

This is for Radeon HD 3000 because integrated graphics will not work (propably) but I don't know. Try to switch to PCI Graphics in your BIOS settings and then boot the OSX.


P.S. I don't trust any of distros so I will recommend to you to use original Mavericks image from App Store and myhack.app.

Any information about kexts in your Extra folder? ;)

Good Luck

Link to comment
Share on other sites

Can you link me how to edit Vendor/Device ID?

Also it was when I was booting to the USB.


I might try downloading original Mavericks but, how can I boot it with amd kernel?



EDIT: It seems I can't try original Mavericks for now as I don't have a Mac. :(

EDIT2: I managed to know how to edit kexts for my ID's. Don't know which kext I will edit though. I tried AMD2600Controller and ATIRadeonX2000, no luck.

Link to comment
Share on other sites

You can download mavericks.dmg from torrents or another hosting and then manually make an usb installer by the MacDrive or some other apps :)
You need to edit AppleGraphicsPowetManagement.kext and find your smbios you are using right now. Below there should be VendorID and DeviceID and you paste your numbers (your graphics card).


And if it not work, you should ue the graphics kext from Developer Peview 8 - working for me :)

Or you can install 10.9.2 beta update with the graphics support for some cards :)

Link to comment
Share on other sites

Alrighty. I'm downloading Mavericks Retail now and I'm going to continue tomorrow.

Before I use the Retail installer, I'll try to edit your said kext.

I'll get to you again after trying editing and installing with the Retail version. :)

  • Like 1
Link to comment
Share on other sites

Man, even with the Retail version, can't solve my display problem.

Maybe I should try Snow Leopard as a kext for my integrated card is compatible.

No QE/CI though but can change resolution.


Is it still good to have Snow Leopard these days?

Also, if I can make my display work and then upgrade to Mavericks, will it stay?

Link to comment
Share on other sites

Snow Leopard is very good but old. I still have SL on another drive, but Mavericks is a lot faster than SL. And Mavericks use much less RAM - working space is much more comfortable.

If you install Snow Leoprad and then upgrade to Mavericks, I don't know if it's working like that but you can try. Don't forget to paste new kernel for mavericks before restart (and the new FakeSMC.kext and other kexts for your specification).

You can try the kexts from Snow Leopard but I tried in my graphics and it's not working.

If the Mavericks don't work still you can stay on snow leopard, becuase it's very good system :)

  • Like 1
Link to comment
Share on other sites

Thanks for the clarification. I'll install Snow Leopard for now. And when I'll buy a discrete card by March, I'm gonna upgrade to Mavericks.

One last question, if I can make my integrated graphics work on Snow Leopard, how can I enable QE/CI?

Link to comment
Share on other sites

Just add GraphicsEnalber=Yes. You can use GE=Yes and PCIRootUID=1 and should work. But!!! On Snow Leopard you can additionaly (if the flags not help) download the unlocked drivers for your card or for whole series. I had a GT430 and on Snow Leopard not working at all. Then I downloaded the unlocked drivers for GeForce 4xxx-5xxx-6xxx and voila - works with two displays. You can try to search some drivers on google or OSX86 forum.

If you want to buy a new card you should pick a card, which working in 100% on Mountain Lion/Mavericks if you do not want to be problematic for you again :) Iv'e got now GT640 and with 10.9.2 working perfectly. Why? Because iMac 2012/2013 has this graphics onboard (GT640M) so the drivers are inside the system :)

Edited by tragediana150
  • Like 1
Link to comment
Share on other sites

Hey, Me again. Managed to install SL and updated to 10.6.8.

Managed to work all of my devices except Graphics.


I can boot with GE=Yes and reach Desktop after updating to 10.6.8.

Even System Profiler detected 256MB of graphics memory. And on PCI devices section, it detected that I have Megalodon framebuffer.

With QE/CI...maybe. (I can play Chess and I can test Screensaver.) but I can't change resolution.


However, after updating Chameleon using Chameleon Wizard, I can only boot with GE=No.

System Profiler detected 3MB, no more detected in PCI section.

But I can still play Chess. (IDK how.) Also, still no resolution.


Any ideas?

Link to comment
Share on other sites


  • Create New...