Jump to content

Guys, need help for a wrong vbios!

5 posts in this topic

Recommended Posts

Hi guys! I need help!

Firstly excuse my English please!

So: I have a gf 240m GT, there are two mxm flavours of this card, my mistake was using the bios for mxm 3 on my mxm 2 card, now my screen is black!

I'm able to blind flash it with another wrong bioses, I'm shure of it cause I can read to a file flashed bios with nvflash -b old.rom command!

But I can't flash back original bios! Don't know why! I've tried

nvflash -4 -5 -6 old.rom

And then twice Y and an YES in various combination but no luck! This is the log I have:


Nvflash version 5.141


Command: flash FindDevices: Device:00:00:00=8086:2A40:1462:7220 Device:00:01:00=8086:2A41:1462:7220 Device:00:1A:00=8086:2937:1462:7220 Device:00:1A:01=8086:2938:1462:7220 Device:00:1B:00=8086:293E:1462:7220 Device:00:1C:00=8086:2940:1462:7220 Device:00:1C:01=8086:2942:1462:7220 Device:00:1C:02=8086:2944:1462:7220 Device:00:1C:03=8086:2946:1462:7220 Device:00:1D:00=8086:2934:1462:7220 Device:00:1D:01=8086:2935:1462:7220 Device:00:1E:00=8086:2448:1462:7220 Device:00:1F:00=8086:2919:1462:7220 Device:00:1F:02=8086:2929:1462:7220 Device:01:04:00=1217:00F7:1462:7220 Device:01:04:02=1217:7120:1462:7220 Device:04:00:00=10EC:8168:1462:7220 Device:05:00:00=14E4:4315:103C:365E Device:07:00:00=10DE:0A34:1462:7220 GPU Device:07:00:01=10DE:0BE2:10DE:0688 One to one mode Testing adapter: GeForce GT 240M (10DE,0A34,1462,7220) H:--:NRM B:07,PCI,D:00,F:00 Action: Read image head. Action: Identify EEPROM. Atmel Serial EEPROM Identify. Reported Manufacturer Code (JEDEC): 00 Reported Device Code (JEDEC): 0000 Reported Manufacturer Code (SST): 00 Reported Device Code (SST): 00 Reported Manufacturer Code (Atmel): 1F Reported Device Code (Atmel): 65 EEPROM ID (1F,0065) : Atmel AT25F512 2.7-3.6V 512Kx1S, page Action: Read EEPROM image. Reading EEPROM bytes. Start: 0x00000000 Count: 4096 Read complete. Testing Image: m.rom IFR image mode Mismatch Type: Computed: 0x0000010E WARNING: Firmware image PCI Subsystem ID (1462.2031) does not match adapter PCI Subsystem ID (1462.7220). WARNING: Firmware image Board ID (C909) does not match adapter Board ID (C930). Overriding PCI subsystem ID mismatch


ERROR: Update aborted Exit Code: 2


Guys please help me, this is the third day I can't do anything!

Link to comment
Share on other sites

If you have a backup of your original rom, try it to flash back, renamed to the name of one of your wrong roms, you have been able to flash. If this does not work, you should google for the name oft the original rom, if nobody here can tell it you.

If you have not done it til now, you should add to your flash stick (I think it is a bootable dos one) an autoexec.bat with the flash command syntax and correct params.


By the way it is hard to tell you this name, because you don´t tell the details of the hardware, your wrong fashed card is sitting in.


Have fun.

Link to comment
Share on other sites

Thanks Stygian for your help!
So,what I did:

1. Tried flashing my backuped rom back but nvflash hangs /stops at some point, I can't see what happens there, have only that log... Will try naming rom like a wrong one, but can't undarstand why it can cause problems...


2. ok, already done a google search for the name of my rom ( but all I can find is techpowerup.com (gpu-z) validations...btw, it is an Asus board.


3. already done some tentatiuves with autoexec.bat but it is the same like typing by hand this command, and gives me same log...


My hardware is in my sign!

Thanks again!!!

Link to comment
Share on other sites

Sorry for that, I have not seen it very well. I don´t want to buy a new pair of glasses.


Have you seen this Acer rom for the GT 240m: http://www.techpowerup.com/vgabios/66820/acer-gt240m-1024-090730.html


I dont know if the Acer one has the same specs as your card.


I  hope for you, that your rom is has not got so corrupted, that reflashing with soft flash does not work anymore.


I think, flashing with autoexec.bat is saver, because, you must not type in blind flight and typing mistakes are easier to dedect.


I  know,  that you do not want to spent money for a replacement card, which you can find for sure over ebay or local used parts resellers.


Hoping, that you have success with reflashing. All the best.

Link to comment
Share on other sites

On www.techpowerup.com there are 4 bioses, one nvidia and 3 acer, I tried them all! Nothing, on reboot same black screen!

The are fourth acer bios but I don't know if it's for ddr2 or ddr3 version so I dont use that rom.

I dont think original rom is corrupted, I can open it fine with nibitor...

With your help guys I must undestand why flashing stops at some point and if I must push some Y or YES?

I told you i've tried doing that with autoexec.bat but have same result...and it is way slowly cause once I reinsert my usb boot flash

I cant see anymore autoexec file and cant overwrite it so must reformat the usb flash...

And I will spend money for another card when I be shure I cant do anything else, until that I will try to found a solution...maybe with your support!

Thanks again!

Link to comment
Share on other sites


  • Create New...