Jump to content

Maverick 10.9 Intel DX79TO Install


3 posts in this topic

Recommended Posts

For the record:



Intel DX79TO firmware update to lastest version 2013
16 GB Ram Kingston
Video Gigabyte GTX 570 (also used GT 220/440 with same results)
Kingston SSD SV300 series 120 GB (bootable)
WD 3TB (bootable)
Nexxt ION 150 WiFi card
USB Wireless Keyboard and Mouse
Chameleon latest version at the time Chameleon-2.1-r2258
Displays: 1 HP L1706 and Sony TV HDMI input 1080p

No DSDT available for this MB.  :(


Built In LAN
Sound via VoodooHDA

Unknown Working:

USB3.0 hasn't worked in all previous versions so I guess it wont work now. Don't have a 3.0 device.


SATA as usual to AHCI
Only needed to change the Front Panel Audio to DISABLE.



If you have the Virtual Video Settings in the BIOS (default), booting or first working screen WILL STOP WITH a message like "Kernel kext loading stopped/disabled" or something similar and HANGS forever.

Just disable this feature and all is well. TOOK a whole day (30 boots or more) to finally figure this one out.


Use myHack 3.3 in USB and then on SSD installed.


The video GTX 570, GT440 or GT220 (did it with both) was perfect with GraphicsEnabler=Y in the org.chameleon.boot.plist. Careful where you put the VGA display since there are two vga ports but one is shared by the HDMI so if you have the HDMI and connect to the vga to the shared port you will get a black screen. Use the other vga/dvi+adapter port.


Sound did not work as usual so I tried to install many (at least 6) Realtek ALC892 versions from many sources. None worked for my combination so I used VoodooHDA_2.7.6d2 (also had to try many versions). Then in System Preferences>Sound chose the Line-Out (Green Rear) option. You might want to give it a shot with something else. Haven't tried the Mic. Apparently Video Cards with HDMI have another HDA controller and it causes "confusion".


The very economic wifi card Nexxt Ion 150 $10 (around this part of the world) is actually an Atheros 9285 code. It could work OOB if your IO80211Family.kext has the AirPortAtheros40.kext, otherwise need to install this kext.


BOOT only in Verbose Mode

Suddenly it would boot only in verbose mode. Finally figured out that the kextcache must be corrupted or something. Throw it away, touch /system/library/extensions and reboot without forced verbose mode.

Hope it helps. 

Link to comment
Share on other sites

  • 8 months later...

Im currently trying to install Mavericks on the DX79TO MB, but everytime halfway my install the install fails (and its not the last part) my disc is not recgornised as bootable in charmeleon :/.... 
Do you have any experiences with that?

Thnx in advance :D

Link to comment
Share on other sites

Never mind that, got mavericks installed, but now im stuck with forced safe mode :P ...... as soon as i do otherwise it halts almost directly.
Problem is that my videocard is recorgnised by the system as Radeon HD 7xxx 6144MB but i dont have any QE/CI

My setup: 
Ram: 32GB 1600Mhz G-Skill
Graphics: Sapphire Radeon HD 7970 Vapor-X 6GB edition 
Display: AOC U2868PQU on res 3840x2160

Wifi: DLink card Recorgnised OoB as Airport Extreme card.


Ive had a hackintosh running on this system on 10.8.4 without any problems only negative thing was that my graphicscard was nerved to only 3GB available (ML was unable to detect the full 6GB in anyway, Open GL showed 4GB available)

Can you help me with getting this up and running?
Many thnx in advance.

Link to comment
Share on other sites


  • Create New...