Jump to content

Mavericks on XPS 8500


8 posts in this topic

Recommended Posts

I have an XPS 8500 that is running Mountain Lion well. I've downloaded Mavericks from the AppStore and created multiple bootable thumb drives with MyHack and the UniThingy.


All of the thumb drives will boot into the Installer on a couple of other systems so I think the images are basically clean. But they all fail on the XPS 8500; crash and reboot at Starting Darwin.


I have tried dozens of combinations of bootloader switches:


-v -x -f GraphicsEnabler=Yes|no PciRootUID=0| etc.


I've tried copying the smbios.plist and org.Chameleon.Boot.plist from Mountain Lion.


And it still crashes at Starting Darwin :-(


FWIW, this system has a Samsung 840Pro SSD and Nvidia GTX650ti.


Any and all suggestions appreciated.






Link to comment
Share on other sites

you have a spare hard drive, you can put in and make a installer.

Maybe I'm missing something but isn't that going to be just the same as I've already done except that I'll be booting via SATA versus USB? You think there's a problem with the Mavericks USB drivers?


I know the thumb drives themselves are are okay: I've tried three and they all boot up to the installer on other machines.

Link to comment
Share on other sites

Well, I tried yet again, and this time it worked.


I have absolutely no idea why and what changed.


In any event I got Mavericks installed and running reasonably well. A few issues:


* Bluetooth. I don't use that so I killed the BT related daemons to stop them constantly crashing and restarting.


* Spotlight was a disaster. I've completely disabled that for the time being. Will revisit later.


* Audio. I tried several drivers for the ALC887 audio. VooDooHDA 2.8.4 was the only one that worked.


* Flash. Not surpisingly this was a disaster. It almost works but very badly in Safari and not at all with Firefox.

Link to comment
Share on other sites


  • Create New...