Jump to content

[SOLVED] Mv 10.9 no graphics enabled after installation mistake

10 posts in this topic

Recommended Posts

Hi all,


I tried to install Mavericks DP on desktop in my signature and it didn't work good, i had several kp so I decided to wait for the final version, but with the 10.9 DP my GPU worked natively.


Then I trid with 10.9 final version downloaded from Apple store, but cause inattention i mistake the choose of partition to install, instead to select an empty partition I selectet the ML 10.8.4 one without format it. At reboot all was chaotic and there was no graphics acceleration. "About this mac" showed 10.9, but the desktop was the old one and all was slow with many crashes. Too bad, I thought, I'll re-format and re-install all.

Incredible, I re-created pandora installer for ML 10.8.4, I repeat all I made previously... and GPU does'nt work!

For ML 10.8.4 I opened another post here



and here





Here I hope to resolve with 10.9. My Nvidia 220GT always worked natively, since s.leopard 

going through lion to ML 10.8.2, 10.8.3 e 10.8.4 that I subsequentely installed, I never had to put any kext or graphics enabler.


Since I mistake that installation there is no way to enable GPU, I tried to initialize partitions, to format, to change hard disk, nothing.


Now starting in verbose I read that GPU is recognize (I have a patched DSDT), but graphic acceleration does'nt work and resolution is only 1024x768.

I tried to enable graphics options in pandora post-installation and chameleon wizard, ma nothing changed.


Waiting for help...

Thank you all.

Link to comment
Share on other sites



If all things doesn't work, your graphic card lost support


You'll need edit the kext that control your graphic... or you can upload NVDANV50Hal.kext  and i edit it to you


I'm not expert, but i can try help you. Post original kext from Mavericks installation.

Link to comment
Share on other sites


 I have 8600GT and i tried many methods that previously worked (nvenabler,Inject etc) but on mavericks none is working and there is no video acceleration.So please be patient and this is a common problem.

 But for now i am using these kexts (credits goes to the original uploader) Try installing all these kext using kext wizard with backup option enabled. Now the video is working perfect but i am getting kernel panic frequently.

 I hope this helps.

Thank you

Link to comment
Share on other sites

your problem and to others users  is that  when you create your USBInstaller with Pandora, this not copy the info.plist to all Garphics kexts ATI* Intel* AMD* NVDA*, is a bug with Pandora, you can try copy from USBInstaller/S/L/E all NVDA kexts and install to your System with KEXT WIZARD app/repairpermissions/reboot, I had the same problem.

Link to comment
Share on other sites


  • Create New...