Jump to content

Black screen before Apple logo


7 posts in this topic

Recommended Posts

I've already asked in the Italian forum, but none answered me yet.


I've installed Mavericks on an already existing ML partition (triple boot: Windows 7, a copy of ML and now Mav).

I used MyHack to install it and everything was ok. I've also modified the USB stick with the MBR patch.


Now Mav starts loading kexts, shows info and then just stucks on a black screen before the Apple Logo. I already tried the bootlags -x, -f, GraphicsEnabler=No/Yes, PCIroot=0/1, PCIrootUID=0/1 but none of them worked.


Unlike Mav, the old ML backup copy keeps working as it used to do: no DSDT involved, modified kexts for lan and audio only and nothing else (mic doesn't work, but who cares?).

Mav's and ML's /Extra folders are identical (i've just imported it from ML partition with MyHack tool during the installation).

In Mav's /S/L/E folder, there are 50 more kexts, but I don't know if they can affect the boot somehow or if it's ok to remove them.


Unfortunately, I can't found anything useful on the net, and as I said, on the same hardware, while ML works, Mav doesn't. Did I miss something?




MB: Asus Intel P5Q SE quad-core

Graphic: NVIDIA GeForce 9600 GT

HDMI cable for video only (don't know if that can help somehow), I've even switched it with the DVI, but nothing changed.

Do you need other info?

Link to comment
Share on other sites

None, it seems everything it's ok.


I was wrong XD. I've tried again and watched carefully. The last line before going black is something about the FakeSMC, it shows something like "key not found... length -6"

Link to comment
Share on other sites

I tried again to toying around with bootflags and reading on the net that SMC is a touchy matter and can involves a lot of things, from sensors to power management. Then I remembered to remove the AppleIntelPowerManagement as I did with ML a lot of time ago.
Unfortunately the first boot after that was the same old black screen. That made me disappointed and lost.


I then took the smartphone to take a video of all the verbose infos, so I could read carefully everything. The only flags I used was -x... and bang! Mavericks appeared on my smartphone screen XD.


Audio, graphic, internet, CPU sensors... all seems to work greatly.

Link to comment
Share on other sites


  • Create New...