Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
petaire

GTX660 OpenCL and Mavericks?

12 posts in this topic

Recommended Posts

Hey guys ! 

 

I've got a brand new installation of the Mavericks GM on my Z87X-UD3H. Everything works like a charm, except my GTX660. On luxmark, I get 448, which is very low regarding to the other guys (they got something like 1158). Now, I know the problem is related to OpenCL, because FCPX doesn't work. I've got this error from FCPX everytime I open a video on the timeline or in the event manager, like ten per second : 

 

22/10/2013 11:12:32,812 Final Cut Pro[336]: dynamic_cast error 1: Both of the following type_info's should have public visibility.  At least one of them is hidden. 23PCSerializerWriteStream, 17PCHashWriteStream.
 
And after several minutes, FCP just crash. 
 
Do you guys have any idea? I'm pretty sure I have to enable OpenCL for my keprel card (which is 2GB of memory), but I honestly didn't found anything to do that on Mavericks…
 
Thanks a lot !
 
edit : And yes, I did tried with the other topic with the kext from the DP8, but still the same issue…

Share this post


Link to post
Share on other sites

I have the same problem.  It appears that this is a relatively uncommon problem, however.  So it may take a while to come to Apple's attention.

What hardware are those of you with this problem running?

I have a MacPro 4,1 with 32GB RAM.  Can't recall the GPU right at the moment.  I'll have to check that out.

John

Share this post


Link to post
Share on other sites

I have exactly the same issue with a 'GTX 650ti boost 2GB' card.

Console is full with 'OpenGL' related errors, OpenCL seems not supported according to several benchmark tools and the graphics performance is horrible, any ideas?

Kasper

Share this post


Link to post
Share on other sites

I have the same problem i have a gigabyte gtx 660 2gb, when i run Luxmark i only score 448. Still not any known way to fix it? 

Share this post


Link to post
Share on other sites

Somewhere I read that series 6xx 7хх Kepler videocards in OS X have no OpenCL support

Share this post


Link to post
Share on other sites

Kepler cards have OpenCL support. What they don't have is power management with OpenCL. So if you use it your card stays stuck in a high power state until reboot.

 

I used to have to patch my cards to enable OpenCL. Now I patch to disable it.

 

Just avoid nVidia if OpenCL is important to you. I doubt they're interested in properly supporting it considering it's competition for CUDA.

Share this post


Link to post
Share on other sites

nVidia are developing current web drivers for 10.9.x. Hopefully in the future they will fix the openCL bugs.

 

If you are running 10.9.2 try the web drivers and the cuda drivers.

 

They wont help with the power management issues, but they might help with other errors you are having.

 

I know personally on my system they GREATLY improved my graphics performance with a kepler card using macpro 4,1 smbios.

Edited by mvd120

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×