Jump to content

DVI-DVI cable works, but DVI-HDMI doesn't on 10.8.x?


6 posts in this topic

Recommended Posts

Hi guys and gals,


I was wondering what the problem was with my setup.


I have an Asus P7P55D with an Asus 9800GT that has two DVI ports.


Everything has worked on my 10.8.2 flawlessly via a DVI-DVI cable to a 23 inch monitor. (1680x1050)


I recently upgraded my monitor to a 27 inch (1920x1080), and it only accepts HDMI, not DVI. 


So when I booted 10.8.2 with the included DVI to HDMI cable, everything goes fine until I get a blank screen and the monitor goes to stand by because it doesn't get a signal.


I can confirm that it has successfully booted because the caps lock key lights up when I turn caps lock on.


I switched back to my 23 inch monitor temporarily with a DVI-DVI and everything works well again.



When I attempted to reinstall ML using U**Beast, the same thing happened with the new 27 inch monitor (no signal) but it loaded just fine with the old one.


Any help would be appreciated, thanks a lot!


PS. I'm using the first PCI-E slot for the GPU and the main DVI port out of the two. I'm using a DSDT.aml extracted via AIDA64.


I tried to boot from 10.8.3 and 10.8.5 prepared using #####, but they both didn't fix this issue. 

Link to comment
Share on other sites

I don;t know if this will work for you or not...but it did for me.

I actually had to set "GraphicsEnabler" to "no" in the Extra/org.chameleon.Boot.plist to get my setup to work with hdmi.

Link to comment
Share on other sites

  • 2 months later...

I have nearly the exact same issue. I have a BFG 9800GT 512MB w/ Gigabyte GA-H55M-UD2h. Had 4 monitors: connected 2 via motherboard (vga+dvi) which displayed bootup (gray apple logo) for the first part of boot (then they stay that way), then 2 DVI driven off the 9800GT would go online and function normal during install and normal usage (1280x1024 and I think 1680x1050).


When I though the Hackintosh thing was safe (aside from 2 of the 4 monitors displaying apple logo all the time) working for about a week with IOS 10.9: Logitech USB cam worked, mail, virtual box/win7, 3TB drive + other sizes, dual booting to windows, audio, sleep, ethernet, time machine, etc,  I went out a bought a Asus MX279 27" since I was going from 4 to 2 monitors. It only takes HDMI so I used a DVI to HDMI adapter. Pretty much no matter what, when I have the MX279 plugged in I can't boot correctly. Monitor is essentially "no signal". I've tried a bunch of things so far:


* Mavericks and Mountain Lion (since people were saying better multi-monitor support

* Messed w/ my bios setting to enable/disable onboard video, disabled as much as I could

* GraphicsEnabler=Yes/No

* safe mode (-x)

* vesa graphics modes: Graphics Mode: 1280x1024x16, 1280x800x32, and a handful of others

* occasionally w/ safe mode I had no video but the system was online. I was able to SSH into the box and tweak things and clear cache.


Thinking because the MX279 wants 1920x1080 or some general incompatibility somewhere. Wondering if I need to get a more supported video card.



Any suggestions? This is a real PITA, actually w/ all the messing about the system I can't boot safe mode where I could before, thinking time for TimeMachine restore.


Want so say my MB is ok since there is a DSDT config out there. If thinking the video card, what is a good video card that can support 2 DVI/HDMI monitors at 1080p that's PCI-e 2.0? I don't have gaming needs so under $200 if possible.






Link to comment
Share on other sites

Very weird indeed, thanks for replying to this topic. 


It's been quite some time since this project was on hold because I couldn't get the display to work. 


Seems common in setups where the monitor only accepts HDMI signals. (Which is very weird though, since HDMI and DVI are almost identical except for the sound signal.)


Let me know if you get something working! :)

Link to comment
Share on other sites


  • Create New...