Jump to content

Managed to get Sigmatel HD audio to show up in System Prefs, but no actual sound.


King George
 Share

6 posts in this topic

Recommended Posts

Hello guys,

 

I've been f***ing around with kext's for 2 long days now. I've tried just about anything that is said on audio on this forum and on wiki.osx86project.org.

I've tried a wide variety of combinations with 1, 2, 3 or 4 kexts replaced and with adding my hardware ID to them. That is VenID 8384 and DevID 7661.

 

The ONLY thing I have yet achieved is "HD audio output" showing up in the Sound options in Sys Prefs, by removing AppleHDA.kext and replacing AppleAzaliaAudio.kext by the one that can be downloaded on this forum, whith my vendor/device ID added to it.

 

I also reïnstalled the whole OSX, which is 10.4.7, to try the Sigmatel9220 guide from the Genius Bar. That didn't work either, didn't make any difference.

 

I just posted here to see if there is any hope for this Sigmatel thing... Reading and googling it seems that everbody just gives up on this one... Is it at all possible yet?

 

I also wonder (since the device is recognized in system prefs) if maybe I just need to map the sound output to the correct connector (line out).

I tried this with the Audio Midi Setup utility, but I only saw two ports, already correctly mapped. Is there another way to do this? By editing kexts?

I ask this because, since the device is shown in sys prefs, I can hear a slight noise from the microphone input.

 

Anybody solved the sigmatel problem yet. I have a Sony Vaio VGN-FE21M.

 

Now having a go at the intel wireless, power management, display brightness, ...

Link to comment
Share on other sites

Now having a go at the intel wireless, power management, display brightness

No drivers for Intel wireless. Find a Broadcom device (like Dell 1390 or 1450) or Atheros device. Or get a suitable wireless USB device. You can check the Wiki compatibility lists under wireless networking: http://wiki.osx86project.org/

 

Power management: http://forum.insanelymac.com/index.php?showtopic=14912

Link to comment
Share on other sites

From what I remember I have a Sigmatel HD Audio 9220 and managed to get it working.

 

I recently installed Vista and haven’t yet sorted access to my OSX partition which is where all my OSX related file and info are. Once I get access to them I’ll try and send you the info and the kexts I used. If i forget then send me a pm or something.

 

But this is all assuming I do have theh 9220 audio.

Link to comment
Share on other sites

There is only a solution for the following Sigmatel devices: Sigmatel 9220, Sigmatel 9752/53, SiS 7012

 

There is no solution yet for a Sigmatel 9200 or the others. You would need to read your manual or check the website of your computer/motherboard to find out what version of Sigmatel you have.

 

When dealing with sound, there are two chips involved - the codec chip and the controller chip. The "VenID 8384 and DevID 7661" that you specify is the for the Sigmatel codec chip. But when you are modifying sound files like AppleAzaliaAudio.kext, not only do you have to modify the vendor/device id of the codec chip, but you also have to modify the vendor/device id of the controller chip.

 

If you look at the Appendix in this guide: http://forum.insanelymac.com/index.php?showtopic=18642

you will see how to find the controller vendor/device id's in Windows. And if you read the actual guide, you will see where these numbers are used in AppleAzaliaAudio.kext. This would apply similarly to other sound kexts.

Link to comment
Share on other sites

  • 2 weeks later...

Rammjet...

 

Checking my advanced specs, I have now found out that my audio chip is called "Sigmatel CDX9872"...

 

Have you heard by any chance of anything for this one?

 

I have also looked at the DEV en VEN id's of the codec AND bus driver...

 

Many thanks,

KG

Link to comment
Share on other sites

 Share

×
×
  • Create New...