Jump to content

System reboots on kext loading [TMSafetyNet]


13 posts in this topic

Recommended Posts

Hi all,


I cant manage to get passed the kexts loading to the install screen.
Im using the following guide to prepare/install: http://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners-updated-for-mavericks/

I also tried another 1 or 2 guides, as well as 10.8.


The lasts kexts which are loaded are the 2 TMSafetyNet kexts, immediately after the system reboots.

Installed kexts: FakeSMC.kext, NullCPUPowerManagment.kext, custom DSDT, SMbios.plist.

I've had 10.6.8 running for what seems like Centuries now with no problems.
I've tried EVERY-KIND of System and Bootloader flag (and i mean EVERYTHING!, there is no point in writting them all down)

Searching for TMSafetyNet doesnt give very much.   Could somebody PLEASE shed me some light!



Core2Quad, Gigabyte GA-EP45-DS4, 8800GT 512

Thank you!!!!

Link to comment
Share on other sites

-f -v GraphicsEnabler=Yes npci=0x2000 PciRootUID=1    


Unfortunately, no luck. I've tried a veriety of simmilars.


Can you post a picture of boot log?

How/where can i find the .log? I've searched the USB drive for a log file but cant find one. var/log doesnt seem to have one.

Link to comment
Share on other sites

this is a problem with config of your bios, disable IntelSpeedstep


and this       -f -v GraphicsEnabler=Yes npci=0x2000 PciRootUID=0


don´t use smbios



  set this config + or - in your bios, this solve the problem with reboot: 


BIOS settings: (only the most important)

CPU Configuration
Enhanced Halt State [Disabled]
Intel Virtualization Tech. [Enabled] : (this option is present only if your CPU supports this technology)
CPU Thermal Throttling [Enabled]
No-Execute Memory Protection [Enabled]
Intel SpeedStep Tech. [Disabled]
On-Demand Clock Modulation [Disabled]

ACPI Configuration:
Suspend To RAM [Auto]
Repost Video on STR Resume [Yes]
Check Ready Bit [Disabled]
Restore on AC/Power Loss [Power Off]
Ring-In Power On [Disabled]
PCI Devices Power On [Disabled]
PS/2 Keyboard Power On [Disabled]
RTC Alarm Power On [Disabled]
ACPI HPET Table [Enabled]

Sata Configuration:
SATA Configuration [AHCI]

USB Configuration:

USB Controller [Enabled] 
USB 2.0 Support [Enabled]
Legacy USB Support [Disabled] (PS2 mouse and keyboard)

Link to comment
Share on other sites

Well i did find a few settings in the BIOS which i changed.(i used 10.6 for a few years, never seemed to have any problems)
However, i cant test it just yet......
For some reason the external USB HD stopped working (not showing up under PC). It happened when i tried to re-install a fresh copy of the OS onto the drive.
On my macbook it shows up fine, on the PC, nothing.... I've never had anything like this!!!!! Absolutely ridiculous!  Driving me crazy! 

I've set it to erase/0 over 7 times, i dont know what else.....

Link to comment
Share on other sites

Ok there is some progress in terms of OSX. 
The system now does NOT restart but rather the Display/monitor turns-off/goes into Standby.
This is the log pic at the time the screen goes blank.

Help VERY much appreciated!!!

Link to comment
Share on other sites


  • Create New...