Jump to content
mattsnowboard

TP-Link TL-WDN4800 - 5GHz issue/investigation

5 posts in this topic

Recommended Posts

I saw the TP-Link TL-WDN4800 was supported for OS X so I bought it but couldn't get 5GHz to work (it's my only 5GHz client right now and in an apartment, 5GHz is awesome...for the time being). I checked the console and noticed that the off-channel scans only do 1-13, 36-60. So it misses if your router defaults to one of the higher channels.

 

Any idea why that is? Does the AR93x driver not support those channels (on a real Mac)? Does the scan just have a bug?

 

It's also curious that the scan does 12/13, which aren't supposed to be used in North America.

 

It almost seems like the country configuration is just off: http://en.wikipedia.org/wiki/List_of_WLAN_channels

Israel? Singapore? China?

 

Anyone know if there is some locale setting that the wlan driver is getting? I'm interested in diving into this issue a bit more because I'm a developer for some of the WiFi components in Windows :whistle:   and look at similar issues to this every day at work.

Share this post


Link to post
Share on other sites
Advertisement

Try channel 48, gives 5GHz but only 300mb

Not helpful...

I know I can switch to a specific lower channel, but why should I have to?

And where are you coming up with this "only 300mb" stuff? Please don't misinform others who might read this thread.

 

As a more helpful update, I've stumbled upon this:

http://www.tonymacx86.com/network/64158-tl-wdn4800-not-recognized-mt-lion.html

Supported Channels:    1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64

 

That's consistent with my findings, though I don't really know:

A) How to check that output about the wireless interface in terminal

B) How to change those channels if it is even possible (since the NIC itself should actually support higher channels). Is there a different Atheros driver that supports those? Some bad configuration that causes the supported channels to get limited to some non-USA set?

Share this post


Link to post
Share on other sites

Ah, this thread again...

 

I still wish I knew how to get the NIC to use all of USA 5GHz channels, and not just the subset it reports as supported. Since I have dual booting working now though, I guess I could double check that the hardware actually supports the higher channels in Windows just to confirm it's an odd Mac driver bug.

My best guess is the card shows up as something that Mac identifies as a Chinese or other country NIC and loads some driver with less channels supported than it should. If that's correct, there's likely a way to make the card appear as something else and work fine. Who knows...I'll probably just live with parking my router on a channel that works though.

Share this post


Link to post
Share on other sites

Welcome to the "misinformed" club ;)

I wanna join the "misinformed" club too, but what should I do since my WDR7500 only support 149、153、157、161、165 under 5g mode? I hate this stupid router.....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By 그맆조닛
      Hi there
       
      can someone please compile AirportBrcmFixup.kext and other Broadcom kexts for macOS Catalina
    • By End3rPower50
      Hi, I bought a Dell DW1820A based on BCM94350ZAE
      I can't install kext for this chipset on my hackintosh
      Can anyone help me?
      Thanks in advace 
      P.S Sorry for my bad English
       
      CLOVER.zip
    • By Corrin
      Hi all,
       
      so ive been trying to get the wifi working on my hackintoshed laptop for a full week now, but i have little to no experience with macs or hackintoshes.
       
      my wifi card is a BCM43142, and my laptop is a HP pavilion 15 p004na running Mojave 10.14.4
       
      i was told on another forum that this card did work on macos, but im starting to doubt it a little :)
       
      any help would be much appreciated,
      Corrin
    • By vhviveiros
      Hello guys!
       
      I'm using a Samsung ativ book 2 np270e5g-xd1br, with i5-3230m/HM75, and everything is working fine, except by sleeping and wifi connection (the Hackintosh internet speed is about 10% of the windows/Linux, and sometimes It downs randomly).
       
      I've tried a lot of tutorials but nothing solved my problem.
       
      Hope you guys could help me
       
      obs: I also figured that if I left the laptop for some minutes, It sometimes reboot.
      Send me MacBook-Pro.zip
×