Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
iLinux

Chameleon confusion? A little help

2 posts in this topic

Recommended Posts

HI. I downloaded the chameleon wizard and the first I did was to update it(picture below)

screenshot_04.jpg
windows 7 screen shot

 

After that. I then go to the SMBIos tab and select the macbookPro(8,1)

screenshot_06.jpg
image hosting

 

but the problem is I dunno where to save. I believe its on the extra folder but the extra folder is missing

screenshot_03.jpg
screen capture windows 7

So i just install it to the documents folder and then go to org.chameleon.boot and select the plist. Then I restart the pc. Boot from hard disk but it went straight to Windows OS. Whats the problem here? I was expecting a boot option where i can selet to bot to windows or mac? Anyone? help

 

Share this post


Link to post
Share on other sites

You didn't say a word about your install method (or how you are currently booting your installation) so, here are two possible reasons why there is no "extra" folder:

 

1. Chameleon is installed to the hidden EFI partition, which is unfortunately not supported by Chameleon Wizard. You can mount the partition manually and copy files generated by Chameleon Wizard to it, but Chameleon Wizard still won't let you install Chameleon there, or upgrade Chameleon if it's installed there, even after manually mounting the partition. At least that's what I found last time I ran it.

 

2. Most likely Chameleon was not installed at all to begin with. Manually create the folder "Extra" at the root of the drive where you want to install Chameleon. This is folder is required for Chameleon to work properly, this is where you keep the theme you want to use, as well as configuration files, DSDT etc etc.

 

Regarding your first screenshot; the Chameleon boot loader itself is comprised of three files. The option you selected installs "boot" to the root of the selected partition. However, you need to select boot0md as well. Also tick "update more boot loader files" - I don't know why they even make that optional, it's a recipe for disaster - you should always update all 3 files (boot, boot1h and boot0md) when installing Chameleon. Mixing and matching core files from different versions of Chameleon is a bad idea and will cause trouble. Of course, if Chameleon is not installed at all, it will not work if you only select to copy "boot" to your harddrive!

 

Regarding your third screenshot; you have not updated anything - you're about to install Chameleon 2.1 r2109 from 2012. Presently Chameleon is at 2.2 r2264.

 

Installing to the documents folder does not work!

 

Also, please don't use external file hosting services, once your screenshots disappear from there your post will no longer make any sense. Always attach files locally. use the Full Editor to attach screenshots and other files.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    •   Boot option name retrieval 1) Locate the booter image as explained blow. 2) Locate ".contentDetails" in the parent folder 2.1) if unsuccessful, locate ".disk_label.contentDetails" in the parent folder 2.2) if unsuccessful, retrieve the volume's name   HFS Boot 1) Retrieve blessed file via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleBless.h#L41 1.1) if unsuccessful, retrieve blessed folder via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleBless.h#L45, append "\\boot.efi". NOTE: This is broken in the latest binary I checked. 1.2) if unsuccessful, use the following hard-coded paths: "\System\Library\CoreServices\boot.efi", "\EFI\APPLE\{ARCH}\BOOT.EFI", <StandardEfiPath>, "\\boot.efi" in this order 2) FV2 Recovery does not follow the usual practice because it is not shown by BootPicker anyway. Determine it via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleBless.h#L49, verify it does not match 1).   APFS Boot 1) Determine the APFS Volume Info (and hencefor detect whether it is APFS in the first place) via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleApfsInfo.h#L54 1.1) Determine the APFS Container Info via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleApfsInfo.h#L36 1.2) Verify the Volume Role via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleApfsInfo.h#L51 1.3) Retrieve blessed file analoguous to HFS 1). NOTE: This step and 1.3.1) are broken in the binary I checked, hencefor it does not happen, but is probably supposed to. 1.3.1) if unsuccessful, retrieve blessed folder and append the booter name the same way as in HFS 1.2) 1.4) (if unsuccessful,) locate all Volumes that are part of the same container, check whether the current Preboot partition has folders named by the just located Volumes' GUIDs and append the hard-coded paths from HFS 1.2) if existant 2) Recovery detection works the same way as 1.4), just for a Recovery instead of a Preboot volume
    • Got garbled sound in earphone    Notebook Asus X550VX i7 - 7700hq with ALC255 not working with applealc  layout id  3, 13, 17, 18, 27, 28, 99 its is working with VoodooHDA but the new one 2.9.1 it much has low volume, but bad sound in earphone     codec dump linux https://drive.google.com/file/d/1pg2y76WvFYsO8vFY-2B_2OLyKMmkQ8Tg/view     latest debug http://www.mediafire.com/file/2pjny4eq5r64ed8/debug_1383 (1).zip  
    • For F6 Bios, which DSDT is the one i should use? I´m a little confused in the Mass of DSDT here ;-).   Great Thread by the Way.   Another Question: I have 2 960Pro inside my Rig (one with OS X, one with Windows 10). When i try to mount my EFI on OS X NVMe the system freezes... :-(   DWhen i unplug the Windows NVMe everything is fine an it mounts the EFI.   Anybody an idea?   Tried the upper Port on the Board (OS X) & the middle / lower Port, in the Middle it mounts the EFI in the lower it freezes.   But i need the middle Port for an SATA M.2 SSD :-D... Even when i plug the Windows NVMe into an PCIe Adapter Card it freezes at the point i mount the EFI.   I´m mounting with Clover Configurator.     Thank You guys.
    •   Just add "ngfxsubmit=0" to config.plist to disable the fix within nvidiafixup
    • @MegaCookie   ok, I have no solution for that Trial 7 good for the release?
      Is this codec good enough for you?


×