Jump to content

P67A-GD55(B3) - 100% 10.9.5


70 posts in this topic

Recommended Posts

UPDATE: Now dual-booting off Samsung 850 Evo SSD. OSX Boots in <4 seconds -- WHOAH!!!
UPDATE: Just discovered this fix for HDMI audio on GTX 660 -> http://forums.macrumors.com/showthread.php?t=1499797
Go to final posts for Mavericks 10.9.5 info.


Well, I finally did it. I have a 100% working Mavericks install on one of the most finicky motherboards for Mac OS X installations.


Extra Installs/patches:


Patched latest BIOS file (Backed up to Fat32 USB after automated install) with Power Management - PMPatch.sh

Now using VoodooHDA (with random crash fix), now have HDMI Audio too

Used M*bst to install patched AppleHDA for ALC892

Now there is a HDMIaudio.kext to get HDMI audio out working (not needed for me, but available nonetheless)

Custom patched DSDT

Custom SSDT

Patched IntelCPUPowerManagement (AICPMpatch.pl)

Put graphics card info (GTX 650) into iMac12,2 in AGPM kext -- set machine type in Chameleon Wizard or similar

GenerateCStates & GeneratePStates = Yes in org.chameleon.boot.plist <- not needed

SMBIOS for MacPro5,1

SMBIOS for iMac12,2


What is working:


Correct reporting of CPU, RAM and speeds (hard-coded into SMBIOS file using Chameleon Wizard).

Sleep/Wake (one USB HDD is not waking correctly, but this is a spin-down issue that even effects Win7 - Uses a ridiculous USB->IDE/ATA Bridge)

USB3.0 (including Sleep/Wake) thanks to latest GenericXHCI kext

Rebuilt the Dydl cache using Onyx -> got many things working again, including SDLMame

Some ALL power states seem to be functioning fine on CPU and GPU (very low temps)  :)

Retail NVIDIA driver now available and working - no CUDA or OpenCL yet?! CUDA working fine now, no lockups

Full QE/CI and all resolutions using default graphic kexts (GraphicsEnabler=No in boot.plist) via HDMI

Win7 hard drive working fine under VirtualBox (for emergencies - see Google for instructions) - AHCI SATA or IDE-ICH6 depending on your BIOS setup

Mac App Store -- restored all purchased items fine

Almost all my software tested and working fine, including CiderX and Wineskin games (after updating Wineskin wrappers)

Mac Steam



What is NOT working correctly:


WAKE (video driver related? May be working now with patched AGPM kext... will test later

CUDA/OpenCL, Perl patch should work -- will try with retail NVIDIA drivers tonight

OpenGLExtensionsViewer software started crashing on startup?! don't know why? 1st time I used it under 10.8.5


What is NOT tested:


2nd DVI port (almost certainly works)

HDMI audio (available with VoodooHDA) <- never use, so not interested in fixing at this time

Multiple Monitors (will almost certainly work with DVI+HDMI). I have a new DVI monitor, so may test this shortly


:)  :)  :)  :)  :)

Link to comment
Share on other sites

I have updated to 10.8.5 (MISTAKE!!!)


I am starting to wish that I had a full Time Machine backup at this point.  :(


I have lost my CPU power management entirely, which means running at 3.3GHz all the time, and no turbo mode. Temperatures are up about 8-10deg C.


Also, I could not get the patched non-DSDT HDAEnabler1 working with my ALC892. Reverted to VoodooHDA (which now keeps volumes across reboots, probably thanks to nvram module in Chameleon). As an added bonus, it now looks like I have HDMI audio too (with volume controls).


Sleep is no longer working, well it is working, but monitor is not waking up. I made some edits to AGPM kext, so will test with those, with and without darkwake=0. It was working without darkwake=0 before. I don't really use sleep at all, so this doesn't bother me.


I will do some real research into getting AICPM working again (I have a PMPatch'ed BIOS).

Link to comment
Share on other sites

Reinstated SSDT-1 as I thought it might be useful for full turbo-boost support. Unfortunately, I have never seen the speed go over 3.3GHz, and I don't think it ever will. Tried running GeekBench, and not only did turbo not engage, the final benchmark result was slower than with 10.8.4 :(

Link to comment
Share on other sites

Those ALC892 patched AppleHDA kexts just do not work anymore. They worked under 10.8.4?? Anyways, went back to Voodoo, sound good again, even without SSE2 selected.


STOP PRESS: I got Sleep working again. I did two things at once, and don't know what was ultimately responsible... I also repatched the virgin BIOS, but it was already patched, so shouldn't make any difference. The main thing I did was remove AGPM kext entirely. Also reinstated DSDT and changed the model to MacPro5,1


PS. I am seeing the spinning beachball more often than normal. Will try reverting to MacPro3,1 and editing AGPM correctly (more than three states?)

Link to comment
Share on other sites

UPDATE: I now have working speed step (2 speeds?) and working Graphics Power Management, and working Sleep. Strangely, my copy of OpenGLExtension Viewer no longer works, so I can't check my benchmark results. The only thing not working perfectly is the XBOX 360 Wireless Controller for Windows. The driver doesn't appear to work after sleep. Will write a script to unload/reload the kext on sleep/wake. Should fix the issue.




Reinstated original patched DSDT

Created new SSDT manually

Disabled UXHCI support in BIOS (didn't even know I could do this! now USB2.0 only - GenericUHCI kext still works, even across sleep)


TL:DR = now working 100%

Link to comment
Share on other sites

I may have patched AGPM kext incorrectly. Will try again tonight without copy-paste. I don't care if I only get 2 or 3 states... 


PS. Played HL2:Episode 1 last night under Mac Steam. I got ridiculously smooth gameplay under Full-HD with FSAA etc on. Looked spectacular!

Link to comment
Share on other sites

  • 3 months later...

I have recently swapped my Mac Pro 4,1 for a Dell XPS 435t Core i7, and then swapped that for my original P67A-GD55 (B3) and I am setting out to install a dedicated 500GB ML 10.8.5 again. I have a Time Machine backup from the Mac Pro 4,1 so will attempt to emulate this machine to restore the OS.


I still have the patched UEFI BIOS installed. I really want Turbo Boost to 3.7GHz, but I never got that working with Revogirl's script. I might need to drop SSDT and use a custom built one.


It also appears that my RAM, although DDR3 1600 Corsair Vengeance, it is only working at 1333MHz (proven with Windows Experience Index for RAM benchmark). I will now up the RAM to 16GB with two spare 4GB DIMMs, making sure to manually set the speed in the BIOS beforehand.


More news as it comes to hand.

Link to comment
Share on other sites

Never mind, I was using a boot disk created on a real Mac, using no "added goodies". Using ##### fixed this.


Have a 99.9% working solution, with Intel SpeedStep working WAY better than before (at least 4 states, instead of 2). I have seen it at 3.3x 3.4x 3.5 and 3.6x (3.7 is the maximum).


Sleep/Restart/Shutdown all working.


Non-DSDT ALC892 now working with 10.8.5 :)  Both digital-out ports showing (optical-HDMI), not yet tested, but assume they are working.


More news soon!

Link to comment
Share on other sites

Things are moving rapidly. I am now loading the video BIOS using an extracted video BIOS from GPU-Z. Nothing has changed, but I can boot using only GraphicsEnabler=Yes and UseATIRom=Yes (I have also included ATYbinimage=Yes, not sure if it is needed). There is NO NEED for AtiConfig=Eulemur or AtiPorts=3. I haven't tested all three graphics ports, although I might test them tonights, as I have the cables, and now have a monitor with all three connectors (HDMI, DVI-D, VGA). I only ever have one monitor connected (and currently only have 1 monitor) so I won't be testing multi-monitor setups.


Now using CSTusingSystemIO=Yes, and SpeedStep seems a lot more responsive (almost instant). Switched BIOS from IntelSVID to APS (Active Phase Switching). Might switch it back to IntelSVID and see if it works even better.


Strangely, About This Mac/System Report is still only showing Radeon 5000 series (instead of 5500), which is weird, as others who have got the card working show 5500 and link interconnect speed.


I added the vendor/device info into the second ATI section of AGPM (MacPro 5,1) for working power states on the graphics card. The fan seems to be running too fast at lower temps with this setting. I might try switching to the first section for quieter fan operation. Both original sections were for NVIDIA cards, but it appears to work with ATI as well.


Whoever told me that iMac12,2 smbios.plist was needed for the PowerColor Radeon 5570 to work at all was totally WRONG.


Computer seems to be working as quickly as possible for a rotary hard disk.


NOTE: My Core-i5 supports Intel HD Graphics 2000/2500, but motherboard has no connectors/support. weird?!

Link to comment
Share on other sites

  • 2 weeks later...

Now have 2GB GTX 660 installed, looks like CUDA, OpenCL and everything else working perfectly. Need to re-edit AGPM and replace my previous settings. I will need to switch to one of the most recent iMac SMBIOS to get working GPM? I'll try and copy the section outright if this causes problems, as MacPro5,1 is easily the best performance out of all I have tried.

Link to comment
Share on other sites

Update: I now have FULLY WORKING Intel CPU Power Management, and Graphics Power Management on my system (reinstalled patched 10.8.5 AICPM kext with MuBst) and also installed Core i5 SSDT using same utility. Also using CSTuseIO=Yes or whatever in Boot.plist.


Processor FINALLY hit 37x (3.7GHz) last night for the first time EVER (running GeekBench). Motherboard/PSU fans both now idling at very acceptable volume, temperatures a bit higher than normal (due to wanting a quieter system), but if temperature becomes a problem, I'll just up all the values in the BIOS fan controls (it used to be 65% minimum CPU fan speed, which was about 2100rpm, and quite loud -- now 35%, and it comes up as needed, very smoothly too I may add). I might take the requested CPU temp from 45c down to 40c, and see if I can get slightly better cooling without too much extra decibels. Graphics power management (only have discrete graphics dues to Mobo design) is instant and perfect, with smooth transitions, and nearly silent (Galaxy 2GB GTX 660 GC) dual-fan design. For some unknown reason, my GeekBench 64-bit score has jumped by at least 750, which is good. Now 10,033 :-)


I might switch back to Active Phase Switching (instead of IntelSVID) and see what happens. This is a VERY ABRUPT transition in the PSU fan speeds tho, very loud and noticeable.


OpenCL working under OSX = 551 novabench, 697Gflops with Galaxies. For some reason I have only Software OpenCL under Win7??? Anyone have any ideas?

Link to comment
Share on other sites

  • 1 month later...

Updated from 10.8.5 to 10.9.2 last night. Ran combo update from 10.9.


Used Myhack to create install USB stick.


Had to use NullCPUPM until I had patched AICPM (copied from myhack USB).


Reinstate entire Extra folder (chameleon.boot - SSDT - etc)


ALC892 sound was interesting. Finally started working after removing Pandora boot.chameleon options.


Geekbench 64bit is now 100 faster than under 10.8.5. Also, now using MacPro3,1 in SMBIOS (instead of 5,1).


screenshots to come!


EDIT: NVIDIA have 10.9.2 drivers out ALREADY!!! Has to be a new record!

Link to comment
Share on other sites

Also, another great bonus. Geekbench 64 now recording 1150 score !!!


A slight improvement from the (non-SSDT) screenshot above :)


Also, I am finding that a lot of non-working software was just too old/corrupt, and compatibility is now 100%


Even Wineskin apps are working correctly...

Link to comment
Share on other sites

  • 2 weeks later...

UPDATE: I have discovered that Sleep/Wake is not working well at all. Sometimes it wakes, other times it just sits there like a lump of dough (machine wakes, screen doesn't). This is a serious issue, combined with no working AGPM for my GTX 660, I may have to downgrade back to 10.8.5 Mountain Lion.




NOTE: This info was originally for a 10.8.5 install, which WAS 100% working. Now just need to discover if there is an EASY way of downgrading.

Link to comment
Share on other sites

  • 1 month later...

UPDATE: Fully updated to latest 10.9.2 and all software + security update installed and updated. Working perfectly except sleep and AGPM.


I now have an HP XW6600 Workstation, and Shutdown, Restart and Sleep/Wake all work perfectly. I need to find a working ethernet kext that doesn't panic the computer in 64bit mode tho.


Strangely enough, the networking seemed to work on the first boot?!

Link to comment
Share on other sites


  • Create New...