Jump to content

Asrock A75M-HVS 10.6.8 Audio Issue

1 post in this topic

Recommended Posts

Hi folks. Been away from Hackintosh for a few years, but I recently got 10.6.8 running nicely on my A75M-HVS AMD FM1 board, once I'd added an HD5670 gfx card. Installation was done via Modbin CD, starting with 10.6.3, then 10.6.7, and finally 10.6.8, which picked up the gfx card beautifully and everything except the audio is working perfectly.


Now - audio was working fine in 10.6.7 but the graphics card wasn't working at all (no video - just garbage), so 10.6.8 was required... however, I lost the sound and can't get it back. I've been fiddling with this for about eight hours to no avail.


The A75M uses the VIA VT1705 HD Audio codec, and while this was working perfectly with AppleHDA.kext under 10.6.7, the same kext in 10.6.8 doesn't even pick up the hardware. The volume icon remains greyed out. I've tried ##### (rollback, Voodoo, ALC8xx) and absolutely nothing works. I find this puzzling since everything was fine before (although I'm aware that 10.6.8 changed AppleHDA.kext - hence the rollback).


To be clear - I don't want the HDMI audio on the gfx card - just the back panel line out.


Real shame if I can't get this going, since the system is otherwise very nice. Catch-22 situation, since the gfx wouldn't work in 10.6.7 and the audio won't work in 10.6.8...


Any help or advice would be GREATLY appreciated. Meanwhile, I'll keep researching... ;)


EDIT: went back to a disk image of 10.6.7 (with gfx card removed), copied the ATI kexts from 10.6.8 into System/Extensions, put the card back, and the machine booted with full graphics support. However, even under 10.6.7 the sound went missing with the graphics card installed. Some kind of conflict?


Anyway: now I've eliminated 10.6.8 itself from blame, I've gone back to 10.6.8 but am still not getting anywhere fast...

Edited by flashjazzcat
Link to comment
Share on other sites


  • Create New...