Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

HP Envy 15-j003 OS X ML 10.8.4 problem

10 posts in this topic

Recommended Posts

Hey everyone!


I recently bought a new laptop, the HP Envy 15-j003 with a i7-4702MQ Haswell processor, 16 GB RAM, Nvidia GT 750M and all those goodies.

I managed to run OS X Mountain Lion 10.8.4 via VMWare on Windows 8, so I created a bootable USB with ML 10.8.4 using myHack. I booted with my USB, but it hangs at the Apple logo; no loading, nothing. Just a simple black Apple logo with a grey background.


I also tried a few flags: -v GraphicsEnabler=No PCIrootUID=0, but it didn't work out too.


I really have no clue about this, I don't have any previous experience. Could anyone tell me what I'm doing wrong? What can I do to fix it? I'm trying for 2 days now, but still no luck so far.


Kind regards

Share this post

Link to post
Share on other sites



I created a new USB with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and Chimera 2.2.0. I also installed [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 1.0.0, this is the progress: it loads a bit, then gets stuck and gets a white symbol above the apple logo like this:



I tried with the flags -v -f and this is what I get:



Anyone familiar with this? I really have no clue.


Thanks in advance.

Share this post

Link to post
Share on other sites

You're probably missing the AHCI driver for your chipset. I'm not familiar with any of TMX86 stuff, so you can ask there if you want. I'd recommend you wait for 10.8.5 or download 10.9 for native support for haswell.

Share this post

Link to post
Share on other sites

I read that AHCI is enabled by default on my laptop (no change option in BIOS), so I don't think that's the problem. Besides that, I just tried 10.9 (DP 1), but in this case, it's not stuck at the Apple logo, but the computer restarts itself at a certain point, anyone familiar with that?




EDIT: Also, any idea when 10.8.5 will be released?

Share this post

Link to post
Share on other sites

why don't you replace mac_kernel with 10.85 mach_kernel and check, Have you installed chimera 2.2 that support Haswell?...if not 

install it and you will be fine. i just did the same on my acer v7 haswell with intel HD 4400. 

Make sure u have NullcpupowerManagement and FakeSMC in Extra or S/L/E and try running with -v flag to see what is the issue.

Good Luck

Share this post

Link to post
Share on other sites

This is what I did, created a fresh USB (again), installed the latest version of Chimera 2.2 (this already had FakeSMC en NullCPUPowerManagement in Extra), added AHCIPortInjector.kext, changed smbios (used Macbook Pro Retina as reference) (with Chameleon Wizard), replaced mach_kernel (with 10.8.5). This is the result: it immediately restarts without even showing the Apple logo.


I changed the mach_kernel again (with 10.8.4), and this time it was stuck at the Apple logo (again...). I booted with -v to see the problem, and the problem is that it stops loading the kexts after 10 seconds or so.. No errors, it just stops loading, the black screen clears up immediately.


Unfortunately, I'm afraid it's never going to work out as I really need Mac OS for xCode.

Share this post

Link to post
Share on other sites

I hate to post just to be a buzzkill, but I've an HP ENVY dv6-7247cl, and I've yet to be able to upgrade beyond 10.8.1. After weeks of researching and trying possible solutions, I'm pretty sure it's because of the lack of a SATA controller mode option in the BIOS (which, as you noted, shouldn't matter because AHCI is supposedly already enabled -_-). I, too, get the "Still waiting for root device" on both my 10.8.4 installation and 10.9 installation. I don't want to say "give up" since that would mean I should as well, but just know that anyone with an HP has had the same issue, and as of yet, I can't find a solution.  :(


Edit: Just thought I'd clarify about AHCI already being enabled--what I mean is that RAID mode apparently has the features of AHCI, but that doesn't help the situation of it not actually being AHCI.

Share this post

Link to post
Share on other sites

Please don't discuss here problems with the outcomings of an here not supported site. You should therefore go to the developers site and ask there or themselves for support.


You should read in this particular case this http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/  and the other in the New User Lounge pinned topics.


You do better to have a look at this guide: http://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners/ to learn in the goal of this something about OSX and installing it on PC's. You could also have a look here under Downloads at Pandora. You get guided trough the install options with tips.


You are well advised to keep away from the tools of this here not supported platform, because the installed software is branded with the signature of this site (look for example in a SMBios .plist). Even enctrypted files are in this tools (Look here: http://www.insanelymac.com/forum/topic/278907-permanently-banned-from-tonymacx86/page-15?do=findComment&comment=1937877 ) If they harm, nobody knows except the developers of these files or even not by themselves.


I bet, if you ask there about this circumstances, you all are  banned for lifetime form there.


if you don't want to spread easy to be followed marks all over the  Internet, then stay away from the above mentioned.



In addition are  this builds in misbelief of the operator company by installing the beasted Software as OSX-Hosts legalized. I'm wondering all the time about , why the labeling "CustoMac" is not already registered as protected trademark.  :whistle: :whistle: :whistle:


:hysterical: :hysterical: :hysterical: :hysterical: :hysterical:



Have fun and no harm meant!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Angelo_
      HI, i've installed high sierra a while ago and never really used it that much but i got bored of w10 so i've decided to use it as my daily driver for a while and i noticed that usb 3.0 ports don't work with usb 3 devices and only with usb 2.0 devices(capped at the 480mb/s limit of usb 2.0), is there a way to get past that? i couldn't find it in this forum, i don't need the speed that much for right now(even tho i might since i shoot in raw and usb 2.0 is slow for file transfer of big photos or videos i take on holidays or on days off)  but i'd like to at least be able to use the usb 3.0s with my usb 3 devices and hub. 
      Hope that i write this post correctly, english is not my main language.
      ps  i don't need because i'm on lan but does it exist a driver/kext for intel wifi/bluetooth combo integrated in my z87 mpower(centrino 2200) ? bluetooth works already.
    • By Dallastyle
      Hi insanelymac,
      I'm using a Dell All in one Inspiron 5348. It has a Pentium dual core G3240 Haswell clocked at 3.07 ghz in Mac. I've successfully booted and installed Mac Os X el capitan on an external hdd using a fake cpuid (0x0306E0) its ivybride. But my problem is the drivers. The only thing I could remotely do is wifi. I've installed the kexts for my wifi card. What I need is to install intel hd graphics (desktop) kexts and audio drivers (alc668)
      I've tried doing every method. Except for Ddst because I don't understand it whatsoever.Also found this thing called xcpm and was wondering if I can just spoof the graphics ids or something like that. Hopefully you guys can help me and thanks!
    • By YannisKrp
      What is the best Mini-ITX motherboard for my i5-4460 (replaceable Broadcom chip, if it's possible m.2)? I'm planning to make a Mini-ITX hackintosh inside a Streacom F1C. Is the F1C Evo taller than the F1C and is there any way i can fit a GPU inside it (PCIe raiser etc.)?
      Thanks in advance.
    • By frompdog
      I recently acquired a Samsung U28E510 monitor (4K UHD) for my hackintosh and had a hard time finding the information I needed to get it working with my integrated Intel HD 4600 graphics (desktop H97 chipset with i7-4790s) at full resolution.  This post will share how I got it working.  As a new hackintosher, a lot of the information I found was confusing because it assumed I knew how the pieces fit together,
      I was using Sierra 10.12.6 (iMac15,1 SMBIOS) and already had the HD 4600 working with full acceleration on my 1080p monitor.  When I first plugged in the new monitor, I could get at most 2560x1440 @ 60Hz from MacOS using the DisplayPort cable that came with the monitor.  Using a Linux Live USB, I could get 3840x2160 @ 60Hz so I knew the hardware was working and capable.
      My old config used the kexts Lilu, Shiki and IntelGraphicsFixup via Clover injection.  I was injecting the ig-platform-id 0x0d220003, and on the desktop "<Apple Icon> -> About This Mac" showed that my graphics were allocated 1536MB.
      I added CoreDisplayFixup.kext to avoid the pixel clock limit in the CoreDisplay framework.  Since that required a newer version of Lilu, I downloaded updated source for Lilu, IntelGraphicsFixup and Shiki and rebuilt all of those along with CoreDisplayFixup.
      The hardest part for me to understand, was why MacOS wouldn't offer me the option to go above 1440p resolution.  I could get to 2160p with SwitchResX, but it wouldn't stick across reboots and I was seeing a phantom display on my system when I used that app.  I spent a couple of days trying various things, and upgraded to High Sierra 10.13.1 along the way.
      I eventually stumbled across a post at RampageDev, which explained how the magical ig-platform-id value is used -- which ended up being the key to my problem!  I don't know if the bits in 0x0d220003 are important, but for my purposes that value is used as a key to a table in AppleIntelFramebufferAzul.kext which is used to initialize the HD 4600.  This includes attributes such as buffer sizes and memory allocations which are needed for large, 4k displays.  The link helped me understand the contents and format of that table, which in turn helped me understand the problem.  By patching the kext via Clover, I could have MacOS configure the graphics hardware so that it would work as I wanted.
      The patch itself is added to config.plist -> KernelAndKextPatches -> KextsToPatch (it's in an <array>):
                              <dict>                                 <key>Comment</key>                                 <string>Framebuffer for 4K display</string>                                 <key>Find</key>                                 <data>                                 AwAiDQADAwMAAAACAAAwAQAAAAAAAABgmRQ=                                 </data>                                 <key>Name</key>                                 <string>AppleIntelFramebufferAzul</string>                                 <key>Replace</key>                                 <data>                                 AwAiDQADAwMAAAAEAAAgAgAAAAAAAACAmRQ=                                 </data>                         </dict> I won't go into the grisly details here; if you're technical and want to understand, you can figure it out from the patched values.  Basically, I'm increasing three values to accommodate the larger display: The RAM allocation The framebuffer memory size The VRAM allocation Once I enabled this patch in Clover and added CoreDisplayFixup.kext, I was able to boot into glorious 4K UHD.  I also see the retina resolutions in the display settings.  It's possible that I did not need to change all three fields.  I changed them all on the first try, and things seem to be working well.  I would be happy to update this post if an expert can tell me a better way to do it.
      Note that this does allocate 2GB of RAM for the Intel graphics, but that's fine with me since I have 16GB and plan to upgrade to 32GB anyway.  I'll probably end up getting a discrete GPU when I upgrade the RAM, but this patch helps me stay productive while I save for the upgrade.
      I suspect that this approach could be packaged into a Lilu plugin for those that prefer to do their patches from kexts rather than the Clover config.  Similarly, some of the Lilu plugins I'm using could probably be implemented via Clover patches.  At this point, I'm just happy to have something that works.
    • By gygabyte666
      LAST UPDATED: [11/22/2017]
      Recent Changes:
      -added artur_pt to Thanks list for being the first person to try to help me 4 years ago.
      -FINALLY removed the [WIP] in title. I think it's safe now, haha
      -HUGE post cleanup! should be (hopefully) easier to navigate
      -added new section for 10.13 High Sierra
      -added link to Andrw0380's 10.13 files
      -removed old link to Andrw0380's 10.12.1 / 10.12.2 beta files
      -updated link to Andrw0380's updated 10.12.4 files
      -updated thread title, now shows 10.8.5-10.13.x
      -removed images as they weren't loading anymore anyway
      Previous Changes:
      -added link to Andrw0380's 10.12.1 / 10.12.2 beta files
      -updated 10.12 about image, not a clone of 10.11 about image anymore
      -updated thread title, now shows 10.8.5-10.12.x
      -slight post cleanup
      DISCLAIMER: I can be in no way held responsible for any damage to your computer as a result of the information or files provided on this page. I can't be held responsible for the faults and errors of those who follow (or choose not to follow) my advise or instructions. You are on your own if you proceed. This was created with the assumption that anyone following it would be using the SAME machine model and hardware setup as mine, a HP ENVY 17t-j000 Quad. Using any other model or hardware configuration may work but is completely unsupported! This was never intended to be used as an installation guide and shouldn't be referenced as one. It is merely a place to list my testing results. Consider this your one and ONLY warning. Continue at your OWN RISK...
      NOTICE: I will always be very proud of the work that was put into the making of these files not just by me but through the amazingly generous and wonderful people in this community. During my absence, that same community even took over and provided others with the assistance to keep up-to-date with the newer flavors of OS X. All of that hard work, time and effort will remain here on the first page for as long as possible for both reference and historical purposes. For reference, I supported and maintained packages for 10.8.x Mountain Lion, 10.9.x Mavericks and 10.10.x Yosemite (briefly).
      Andrw0380 has generously been providing more updated support packages for this thread for quite some time now. If you are to use any of the files listed below, I would recommend his as they are typically more recent and better tested. Be sure to check over his posts for further details and usage instructions and don't forget to say THANKS for his time and effort.
      The good news is it has recently been brought to my attention that RehabMan has been hard at work and has created a much better, more reliable method for both current and possibly future OS X installs. His new method, named the "hotpatch" method is far superior to our old ones and should rightfully take its place. I leave you with a direct link to his detailed and extensive guide to assist both current and future users with their adventures in OS X. Should you find success using his method, please remember to say THANKS for his work and to possibly add to his growing repository to hopefully assist future users in their own success stories.

      RehabMan "hotpatch" guide
      10.13.x (macOS High Sierra) ENVY Files:
      Files generously provided by Andrw0380 HERE
      Be sure to say THANKS for all the hard work!
      10.12.x (macOS Sierra) ENVY Files:
      Files generously provided by Andrw0380 HERE
      Be sure to say THANKS for all the hard work!

      10.11.x (El Capitan) ENVY Files:
      Files generously provided by Andrw0380 HERE
      Be sure to say THANKS for all the hard work!

      10.10.x (Yosemite) ENVY Files:
      Files generously provided by Andrw0380 HERE
      Be sure to say THANKS for all the hard work!

      [LAST UPDATED: [10/26/2014]
      Dropbox Mirror

      10.9.5 (Mavericks) ENVY Files:
      [LAST UPDATED: [04/07/2015]
      Dropbox Update
      [LAST UPDATED: [10/26/2014]
      Dropbox Mirror

      10.8.5 (Mountain Lion) ENVY Files:
      [LAST UPDATED: [04/07/2015]
      Dropbox Update

      [LAST UPDATED: [08/28/2014]
      Dropbox Mirror
      [in no particular order]
      - CharlieSheen
      - bcc9
      - RehabMan
      - mnfesq
      - toleda
      - Mieze
      - Micky1979
      - artur_pt
      - TimeWalker75a
      - Slice
      - Andrw0380
      - 59117108
      - jerrywilborn
      - Cobra03
      - hotKoffy
      - mnorthern
      - PikeRAlpha
      - nrjmadan
      REMINDER: An unbelievable amount of hard work, dedication and enormous amounts of time have gone into the making, testing and maintaining of the content for this post, this thread and the entire forum as a whole. Please do try to remember that SOMEONE has to make all this happen. Be sure to THANK those who deserve it. A little appreciation goes a long way.
      CONCLUSION: Lastly, I am rarely active anymore and would just like to say thank you to all those who stepped up and not only took my place during my absence but also improved upon what I started so many years ago now. I truly can't believe how long this thread has survived and it is awe-inspiring to see how much further it has moved along since I last visited it. You are all just amazing and wonderful people for doing what you do. You all know who you are. Keep doing what you do and thank you again for everything that you've already done and for everything that you will hopefully continue to do in the future.