Jump to content
wocketpatch

M-Audio Delta with Logic Pro

2 posts in this topic

Recommended Posts

I've seen around the web that a number of people have had good luck getting the Delta 1010 to work with Logic on their hackintoshes.  I'm putting one together at the moment, and since my bandmate owns Logic Pro, I'm eager to give it a shot.  I messed with it one time and really liked it -- actually pretty similar to Cubase which is what I'm used to.

 

Anyway, what I have is three daisy chained Delta cards -- two Delta 44s and a Delta 66.  This gives me a total of 14 channels (12 that I use the inserts on my mixer for as preamps, and two that come in via a stereo preamp I have into the SPDIF on the 66).. 

 

This works great on Win, the Delta control panel shows all three devices and I can map them all in Cubase.

 

For the most part this works like a Delta 1010, but I wonder if anybody has tried chaining the smaller Delta cards on a hackintosh and/or in Logic..  It'll be a couple weeks to source the parts, just wondering what to expect in the meantime and if I should even bother putting all those PCI cards in this machine.

 

Thanks!

Share this post


Link to post
Share on other sites
Advertisement

I realize this is old but Im replying anyway lol. I believe this is a driver issue and and how many PCI slots your motherboard has. I think the driver that you can find a link for here allows 10 or 12 channels if I remember right.

 

It works with Logic I have used it for years. I have the delta 1010 and the 44 but in separate computers

 

Good luck

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By BiTRiP
      Hi,
       
      Is there any PCi-E audio interface that works out of the box and supports the OSX volume control so I can control it by apple keyboard.
      If not, any USB interface that does it?
       
      I have currently a Digidesign 002 rack which is has a firewire interface. It's works well but volume control by OSX is not supported.
      I know there is a workaround with SoundFlower but I don't want that because it delays the signal.
       
      Hope to here your suggestions!
       
      Thanks in advance.
       
      BiTRiP
    • By xandde1
      Hello!

      I recently installed the OS X 10.9.2 using the following components:
      Motherboard - Gigabyte H61M-DS2H Socket 1155
      CPU: Intel i5 3330
      4GB RAM DDR3

      Everything is running perfectly! However, I can't boot into the OS X while my audio interface - Avid MBox Mini 3 - is connected to the USB port (I get stuck at the Missing Bluetooth Controller error). So, I need to unplug the interface every time I'm booting and plugging it back only when the OS X is loaded.

      The strange part (at least for my newbie comprehension) is that my USB Wi Fi Adapter doesn't break the OS X boot like the audio interface does.

      Does anybody know if there's a way to solve this issue?

      *Some info that may be relevant (or not):
      > I'm using VGA output, even though HDMI works;
      > I did not install the audio driver / kext for my motherboard;
      > I'm using USBBusFix=Yes to enable USB ports in Mavericks OS X;
      > I do not have external graphics card. I'm using the HD 2500 that comes integrated with my CPU.

      Thank you so much!
    • By xrhstaras666
      I have too much Background Noise on line input or mic I tried some soundcards  even two usb mini soundcards
      but I have noise . It seems like it is amplified three times the normal or something like that.
       
      I play guitar for my hobby and I would like to be able to use software like guitar rig (guitar effects)  etc
      but this loud noise destroys guitar recording /effects etc.
       
      Can I do anything about that ?
    • By beta992
      After some research (took me a year ) I think I finally found a solution to get a more smoother interface.
      I don't know if this also fixes "Channel Timeout" errors, more testing is needed.
       
      Some history:
      After reading several topics/post about power-states that are used on GeForce-cards, I found out that the Fermi series only has 3 P-states instead of 4 (or more).
      P-states can control clockings on a GPU down or up when needed. (Down when more 'power' is needed/Up when being more idle)
      You can check your clocks by running the tool nvidia Inspector in Windows
       
      My EVGA GeForce 450 GTS (1GB) has the following clock-speeds:
      State 3 (lowest energy use)
      CPU Clock: 50Mhz
      CPU Memory: 324Mhz
       
      State 2 (mid. energy use)
      CPU Clock: 405Mhz
      CPU Memory: 324Mhz
       
       
      State 1 (high. energy use)
      CPU Clock: 783Mhz
      CPU Memory: 1.80Mhz
       
      After looking in Windows 7 what state the nVidia card runs on, I found out that this is usually state 3. In OS X however I could only get smooth animations if the GPU was running in state 2.
      My theory is that OS X simple needs more 'power' because it is running on OpenGL and their are way more animations (enabled) than on Windows.
       
      I also checked how my card was running on Linux (KDE). When using their interface I also find out my card was more in state 2 than in state 1.
       
      Editing AppleGraphicsPowerManagement.kext:
      To set the correct clock-speeds based on load, editing AGPM.kext was needed since they are undefined for my GPU.
      After searching through some post, I found out that some users were using all the 4 'load-fields', when my Fermi-card only has 3.
      Also some users simple tried to disable the last two, by setting really high values. This should prevent the CPU hitting state 3.
       
      Some users claim that state 3 is causing the freezes and the slow interface. My theory is that the GPU doesn't switch to state 2 when needed. It is either taking to much time for the GPU to reach state 2 or it would simply mean that the GPU doesn't like being on state 2 all the time for some reason.
       
      To make a long story short: I wanted to have a smooth interface, but also don't wanted the GPU to be fully loaded all the time (causing me a high energy bill).
       
      At the moment I'm using iMac12,2 as model. This because my i5-2400 seems to be inside this model.
      By setting this model, it also loaded the AGPM.kext.
       
      These are the values I have chose for my GPU (device id 0dc4):

      <key>Vendor10deDevice0dc4</key> <dict> <key>BoostPState</key> <array> <integer>0</integer> <integer>1</integer> <integer>2</integer> </array> <key>BoostTime</key> <array> <integer>2</integer> <integer>2</integer> <integer>2</integer> </array> <key>Heuristic</key> <dict> <key>ID</key> <integer>0</integer> <key>IdleInterval</key> <integer>200</integer> <key>SensorOption</key> <integer>1</integer> <key>TargetCount</key> <integer>1</integer> <key>Threshold_High</key> <array> <integer>70</integer> <integer>87</integer> <integer>100</integer> </array> <key>Threshold_Low</key> <array> <integer>0</integer> <integer>60</integer> <integer>92</integer> </array> </dict> <key>LogControl</key> <integer>0</integer> <key>control-id</key> <integer>17</integer> </dict>
       
      As you can see (or don't) I have simply removed the last row (aka row 3). My GPU is clocking as it should be and I can enjoy movies again.
      Also the sound from the GPU fan seems to be lower as it normally would, since this is also controlled by the GPU-clock.
       
      Setting details:
      I have set the IdleInterval from 250 to 100. It seems that setting this as 250 it takes to long for the GPU to switch to a higher or lower state. My theory is that the 250 value is set for the GFX0 (aka the nVidia/ATI-GPU) because it 'only' needs to render a game/high-use application. When the 100 IdleInterval of the Intel GPU, is needed because more/faster switching is needed for 'normal' use.
       
      The BoostPState and the BoostTime simple defined what state to be used when an application needs more 'power'.
      The SensorOption should need to be set to read-out the GPU-status.
      The TargetCount should be the state were the GPU should focus on.
       
      At least I think so, please let me know if you have more/better information.
       
      Testing:
      I would like to see some (test) results from Fermi-card users. That's why I posted this as new topic.
      But please know that doing this is at your own risk!
       
      As 'proof' please check the following pictures:
      Idle (4% idle or less):

       
      Browsing/doing stuff: (more than 4% load)

       
      Benchmarking: (more than 45% load)

      AppleGraphicsPowerManagement.kext.zip
    • By BirchMusic
      I've been running my hackintosh for close to a year now with little issues. Generally, I love this thing. Unfortunately, I recently had a problem arise suddenly that I have not been able to fix and need some help.
       
      While running my hackintosh I unplugged my RME Babyface audio interface so that I could get audio from my laptop for a moment. When I plugged the device back in, the computer was unable to detect it. The babyface still works with my MacBook, but I am unable to get audio out of the hack. When it's plugged in, the babyface lights up like it's getting power from the USB bus, but the system profiler does not show it. Other USB devices work (mouse, hard drive, keyboard, iLok, droid) and the USB busses are listed as internal on the system profiler.
       
      Since this issue has come up, I have reformatted my drive and reinstalled 10.6.8. I have updated the firmware on the babyface and re-installed the RME USB drivers for the device.
       
      I'm currently running a hack on a GA-X58A-UD3R motherboard with an Intel i7-950, Crucial Ballistix sport 12GB (3X4GB) RAM, and a Sparkle GeForce graphics card. This system has been working for close to a year, but I can't figure out how to get it back online since it's gotten messed up. Any thoughts or advice is greatly appreciated.
×